Qobuz Favourites not appearing in Roon Favourite Albums [Ticket In]

Can you post a screenshot of Settings > Services > Qobuz Edit?

Cheers, Greg

Hi @Greg. Pretty much identical behaviour here as reported by @Jon_Evans.

Can’t identify the circular arrow on Roon remote on android phone - is that correct. See pic

Just in case, I did a resync from Services - Qobuz - Edit, but no difference. Settings are:

Any ideas?

image

Greg,

Edited out email yet can PM if you need to track back to account.

Jon

Thanks @ToneDeaf and @Jon_Evans,

I’ll pass this to @noris to help you out further.

btw, the circular arrow at the top of the screen isn’t available on the mobile phones. You’ll need to go to Settings > Services to do your sync.

Cheers, Greg

Appreciated @Greg. Thanks!

@Greg. Just as an update - I removed Kinny ‘Acoustics’ from the Qobuz app and readded it. Performed a resynch and it shows up now under Roon>Albums. This suggests the metadata tag being referenced on the object itself is ok in Qobuz and there is some historical issue on the data stored in the Qobuz account (?)

Hello @Matt_Crayton/@Jon_Evans/@ToneDeaf,

I just tried adding a few Qobuz albums on my end and they’re appearing as expected after performing a manual sync. As @Greg mentioned Qobuz syncs are not real-time and may take a few hours to propagate down.

If you are looking for the new albums on the Albums page you will want to sort by “Date Added” instead of by Artist to see them (as they would be only be shown later on next to the Artist name if sorting by Artist).

Please let me know if you are still experiencing issues because I am not able to reproduce on my end at this time.

Thanks,
Noris

Hello @noris. Thanks for testing.

I just added one Qobuz album (Toulouse Street by the Doobie Brothers) by clicking the ‘+ Add To Library’ link next to the album cover, starting from a situation in which favourite albums (releases) on Qobuz were identical to those shown by Roon under Qobuz Favorite Albums.

This is what I see:

In Roon, under Albums: added, fine:

In Qobuz app, under Favourites / Releases: added, fine:

In Roon, under Qobuz, My Qobuz, Favorite Albums: not added. Even 2x manual ‘sync library now’ from settings after ca 5 and ca 20 minutes, the album is not visible here:

But after disabling and re-enabling Qobuz in Roon it will show.

That’s about it. Am I simply too impatient, and could it take longer? About half an hour since adding the album.

Hello @ToneDeaf,

Thanks for those clear reproduction steps. I was able to follow them all the way until accessing the “My Qobuz” section of Roon where it did not show up for me either. On PC’s you have the option to refresh the “My Qobuz” section but on mobile you do not.

A simple refresh (using the refresh button next to back) on my PC allowed it to appear but since you can’t perform this on function on mobile, I will ask QA to investigate. Thanks for reporting this and I will let you know what they say.

– Noris

Thanks @noris. I’ll try similar on MacOS tomorrow (UK, getting late here). My recollection is that when doing this on MacOS I had no joy either, but never used (noticed :shushing_face:) the refresh button next to back, always went to Settings, Qobuz, Edit…

I’ll confirm either way. Keep up the good work!

EDIT Ps. Any reason for the refresh button not showing on mobile? Seems to me there would be sufficient space on pretty much any handset.

2 Likes

The refresh was the lightbulb moment for me. The albums started appearing slowly, then I clicked that (on iPad - it’s not on my iphone, which is why I’d never seen it before!) and hey presto - they’re all there.

Thanks!

Hello @noris, I promised an update on this.

  • On MacOS, I added a Qobuz album to my Roon library, went straight to Roon’s Qobuz screen, hit the refresh button and the album appeared under Favorite Albums.

  • I then added another album, navigated to [Settings - Services - Qobuz - Edit] and hit ‘Sync Library Now’ , but the album did not appear under Favorite Albums on Roon’s Qobuz screen. I hit the refresh button and, again, it appeared immediately (on the mac).

(aside: when I check on my android phone in another active instance of Roon, they are not there, and also do not appear when using ‘Sync Library Now’. They do however appear after closing and reopening the app)

  • As to the album I used as an example yesterday when working exclusively from my android phone, some 10 minutes after my previous post it did eventually appear on the Qobuz screen.

  • Of two further albums I had added in the meantime using Roon on the android phone, one behaved exactly like that (showing up with delay of perhaps 30 minutes or so, but not before -even using ‘sync library now’. But the other showed up immediately after adding it to the library without any further intervention.

Bottomline: it looks like the the refresh button next to back on the Qobuz screen in Roon does exactly what it suggests, although results do not propagate 'immediately to other open Roon interfaces on the same account . But the (Settings - Services - Qobuz - Edit) ‘Sync Library Now’ option has no effect I can determine with regard to favourites, on MacOS and on an android phone . Are both options supposed to be identical / yield the same result?

As ‘Sync Library Now’ under settings is the only forced sync option available on mobile (I think - bar disabling and re-enabling [EDIT] Qobuz in Roon), I hope it can be made to work. Also, in my opinion, the resync arrow should be added to the top of the Qobuz screen on mobile.

Again, thanks for looking into this already!

@noris It looks like there are two issues; one with the refresh that is now known, the other though is a sub-set of Favourites not propogating to Library > Albums. For new content, this has worked on testing yet there are historical Favourites (added prior to 1.6 release) that have synchronised to Roon>Qobuz yet not to the Albums view. The Pink Floyd ones for instance I screenshotted. It suggests the import is holding bad data on these as I can go back and remove/re-add in Qobuz and then they propogate to Albums. The issue may share a common relation to content that is showing in Albums yet is not shown in Qobuz Favourites (either in Roon or via the PC App ) - e.g. New Order ‘NOMC15’ (and there are others) that were removed from Favourites several weeks ago and never should have been seen by Roon. How did it get these? Thanks, Jon

1 Like

Hello,

@ToneDeaf - Thanks for the followup, I have attached your findings to the ticket with QA.

@Jon_Evans - Would it be possible to provide reproduction steps for that issue? You mentioned that the Pink Floyd album was under favorites but not appearing under Albums, I mentioned to you that you are sorting by Artist and that it should appear under “P” which is further to the right in the album listing. Try to sort by “Date Added” instead of Artist, are they still missing?

Can you provide any further screenshots or steps that show this issue clearly before I ask QA to take a look?

Thanks,
Noris

@noris
I’ve attached a number of screenshots - there seems a pattern of this affecting batches.
Filtered by Date Added for the screenshots yet also verified by Album and Artist view.

ROON > QOBUZ: I’ve highlighted some albums…
image

ROON > ALBUMS: … and then shown where they should have been (Coil is a purchase with Show Hidden on).
image

ROON > QOBUZ: Pattern emerging of batches not carrying over.
image

ROON > ALBUMS
image

ROON > QOBUZ: Pink Floyd
image

ROON > ALBUMS
image

ROON > QOBUZ: This one highlights another issue where Albums are both missing and wrongly imported into Roon > Albums. Highlighted start and finish of the area to review.
image

ROON > ALBUMS: compare to below and note Patti Smith and Royal Trux… these were deleted from Qobuz several weeks ago and long before the Roon import. Also note missing albums.
image

Regards

Jon

Hello @Jon_Evans,

Thanks for letting me know that info and posting those screenshots. Hmm, I wonder if this has anything to do with your Qobuz cache. Can you please try clearing your Qobuz cache using these instructions and let me know if you are still able to reproduce afterwards?

  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Thanks,
Noris

Hi @noris

I removed the cache and no difference. I then tried two other steps - disabling Tidal integration in case of something weird there and then I moved the core to a device that was still on 1.5. After update, confirmed its status then enabled Qobuz - the import gave the same results. The fact it is also importing albums not in my Favourites tells me Qobuz has an issue with the metadata on my account which the Qobuz component is able to resolve - and suggests that Roon is able to read both the correct Favourites metadata and ‘bad’ Favourites metadata leading to inconsistentency.

Regards
Jon

Hello @Jon_Evans,

Thanks for letting me know that the issue still occurs after a cache clear. I have submitted your steps to the QA team to reproduce and take a closer look at this issue. Thanks for the report!

– Noris

A post was split to a new topic: Qobuz only lists half of favorites