Qobuz freezing in Roon

Core Machine: Small Green Computer i5, Roon 1.7)

Network Details: AT&T fiber, AT&T router 5268c and AT&T fiber modem

Audio Devices: Principally Bricasti M3 with network as end-point and DAC. Also tried the iPad as endpoint (see text).

Roon is not playing Qobuz. Accessing Roon through an iPad. My local library plays fine, but Qobuz albums are not playing. I have: rebooted the SGC i5, restarted the Roon core, cleared the Roon cache, and restarted the AT&T Network Router. Logged out of and into Qobuz through Roon settings. Same problem - I am able to access Qobuz albums but they will not play - playback bar with the time played just displays left to right highlights (like an eye sweeping back and forth). Happens on multiple endpoints.

I should add to the above that Qobuz is playing just fine on the network using its native apps.

There are 2 ways to play Qobuz Albums, 1) via the Roon Album Browser by selecting a Qobuz Album that you “Added to Library” or 2) via the Hamburger menu selecting Qobuz, which takes you to the Qobuz Browser, can you play anything there?

A couple of things to try, some people setup their Router to use a different DNS, I set mine to in the Router and in my Roon Config, here’s what my browser config panel shows, which matches my router:

Also you could try disabling the Qobuz Service and re-enable it, try lowering the Streaming Quality, try Sync Library Now.

Also you could try delete the albums you “Added to Library” and then try to play them from the Roon Qobuz Browser.

Hi @William_OBrien,

Welcome to the forum! Can you please confirm if the Qobuz web player (play.qobuz.com) works properly with this same account?

I would also be curious to know if just the SonicTransporter if affected by this issue or if other Roon Cores are as well, if you have another PC around the house I would try this:

  • Create a Backup of your Roon database
  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Play.qobuz.com works with my login, as does the Auralic Lighting DS (I have an Aries G2 as one of my endpoints).

Today Roon upgraded itself to 1.7 build 610. No change in ability to access Qobuz - clearly the system is accessing Qobuz as I can see albums and it created recommendations, however it will not play albums or tracks - just gets stuck after pressing play. The ipad client slows down after this in terms of responsiveness.

Roon continues to play local files fine to all endpoints.

I installed a Roon client on my Android phone - it is unable to find the core.

I am thinking AT&T quietly made some changes to the settings that the Core doesn’t play well with - is there a troubleshooting guide here? I looked at some things on the Roon website, but it doesn’t clearly apply.

Note: I moved to a SGC running Roon core as the way I am using the network makes installing and running a Roon core on a PC problematic. Are there some logs I can send you before going down that route?

Hi @William_OBrien,

I’ve activated diagnostics mode for your account and what this action does is automatically upload a log set from your Core. I’m looking over the logs and it looks like your Core is failing to fill up the buffer and network requests are timing out: 08/19 23:49:57 Warn: [streamingmediafile] in immediate read: System.Net.WebException: The request timed out and quite a few NetworkError (Error: NameResolutionFailure).

This looks like you might have bad DNS servers on your network and/or Core, I would suggest you look into changing your DNS on a router-level to Cloudflare DNS, Quad9 or Google DNS and see if that helps.

Also more suggestions can be found in our Networking Best Practices Guide.

Thanks for the followup. I contacted AT&T about changing the DNS settings for my router b/c they don’t let me do that myself. Still waiting on them.

I moved my core (Sonic Transporter) behind my VPN router, which is hooked into the AT&T router. No issues playing Qobuz via the Roon core/remote. Clearly AT&T did something. Are there some special permissions I should ask for apart from the DNS settings?


Hi @William_OBrien,

It does indeed sound like the ATT router is doing something wrong with regards to the DNS routing. If ATT does not allow you to switch the DNS servers, I would look into placing the modem into Bridge Mode and using another router with their modem.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.