Qobuz genre filters no more working

Hi, Qobuz filters on genre (pop, classical, etc) are no more working: in all the cases, the filter is not applied and the results include all the albums.
On Qobuz app, filters are still working fine.

I am running with everything up-to-date and already tried to restart the core.

I can confirm this. On my iPad Roon app if I apply the Classical filter to Qobuz (which still is misspelt Classica after years) I get all sorts of genres in the Qobuz Grand Selection and Top Albums on Qobuz sections. But Still Trending and Press Awards are correctly filtered.

Hi @Andrea — The team is looking into this. We appreciate the report.

2 Likes

Same here, both on the desktop and the Android apps.
It was working yesterday (saturday).

1 Like

Hi @Jez, @Andrea, and @Pascal_Girard — Our team made a change to address this and we believe things should be better now. If you’re still seeing any issues just let me know!

1 Like

Just checked, sorry it doesn’t look like you’ve fixed it, just changed the behaviour. Here is a filter on Genre=Jazz. The “Qobuz Grand Selection” is indeed Jazzy, but the “Still trending” is decidedly Classical. ( my previous selection). Could it be that some sections reflect the currently selected genres but others remember the last one?

Hi @Jez,

We aren’t seeing the same thing on our end — If you force a refresh by clicking the Icon pointed out below is there any change?

image

Nope, however many times I press refresh when the Genre is Jazz, the “Still Trending” section is all classical (which is the other Genre I often select - it’s like its got stuck).

This is the case on the iPad app. and on Roon on my Windows laptop.

Hi @dylan, now it is working fine for me.
And in my case all the sections are properly filled with the selected genres.
Thanks for your support.