Qobuz in Roon drops out often

Qobuz seems to drop out A LOT. Sometimes it just won’t even start to play a track. Sometimes it will play for a few seconds before cutting out. Occasionally it plays ok for while before it drops out.
When I use qobuz with my Bluesound speaker there is no problem. I can also play local files with Roon no problem. It’s something to do with Roon and Qobuz. I have disconnected qobuz and re-connected, re-booted core (which is my MacBook) and the squeezebox that I’m using. All connections on with Ethernet cables. Don’t remember there be any of these issues with Tidal.
I think other people have had problems with qobuz and Roon but can’t find any solution. Thank you.

1 Like


Your topic was moved to the support section of the forum, let see if @support can help.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Especially the full specification of your notebook (CPU and Operating System), how it is connected to your home network (WiFi or Hardwired) and what that network looks like (Router and Switches).

1 Like


  • Core machine (OS, Hardware specs, Roon build) - MacBook Pro 13 Mid-2012 running Catalina v10.15.7, Roon 1.8 build 931 Processor 2.5 GHz Dual-Core Intel Core i5 Memory 16 GB 1600 MHz DDR3

  • Details on your Remote(s) (OS, Hardware specs, Roon build) - Iphone 11 Roon 1.8 build 923

  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured) Sky Broadband Router. MacBook (Core) connected via Ethernet. Router Connected to Logitech Squeezebox Touch via Ethernet

  • Audio devices in use - logitech squeezebox, chord mojo DAC, Arcam A29 amplifier, Kef LS50

  • Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library) - Files held on MacBook (these play fine), Qobuz

Issue is something to do with Qobuz and Roon as Qobuz will play fine via my Bluesound speaker. Also, if I make the Audio output the speakers on the computer I still get the same dropouts.

Sometimes get a popup 'Qobuz media is loading slowly…"

Qobuz works everywhere else, just not with Roon. This seems to have been an issue for many. I prefer Qobuz over Tidal, so if I can’t rectify this then I may have to (sadly) ditch Roon.

Im having the same issue since i’ve updated Roon yesterday.

Local files and Tidal plays without issues, but Qobuz cuts tracks.

1 Like

I notice sporadic dropouts of Qobuz images and the same hesitation or dropping of Qobuz tracks. Usually a restart of the core helps, but sometimes I have to resort to a reboot of the entire machine. Occasionally it’s just not working despite restarts and I have to revert back to my local library.

1 Like

Hey @Dean_Bucknall , @Ivan_Dahl_Nielsen and @GoodEnoughGear

We’re sorry to hear that you’re having trouble with Qobuz streaming in Roon. These issues typically, but not always, point to network problems. Please take a look at our Networking Best practices article closely to see if any of the recommendations there apply to your setup.

Ivan_Dahl_Nielsen and GoodEnoughGear - please log out of Qobuz in Roon, restart your Core, then log back in and see if that helps.

Dean_Bucknall, it sounds like you’ve already tried that without success.

So, let’s try to clear your Qobuz registry and see if that helps. Please use the steps below:

  • First, Close Roon or Stop Roon Server
  • Then locate your Roon Database
  • Navigate to Database>Registry>Core
  • Locate the Qobuz_account file and delete it
  • Restart Roon or Roon Server
  • Log back into Qobuz
  • Please let us know if this helps.

We’ll be watching for your update and get back to you as quickly as we can.

Thanks for getting back to me.

I did already try this (saw the advice in other posts), if you mean deleting the two folders for Qobuz that appear inside the cache folder.

Just did it again though. Unfortunately the very first track I play cuts out every second. However, subsequent few tracks are playing through so I am just going to let things play for a while and see what happens.
The problem isn’t just related to the higher resolution tracks it seems to happen at all resolutions.

Have been playing local files without any issue at all.
I will probably sign back up to tidal at some point soon, just to check that works ok (I had no problems with tidal before).

I did change my DNS to the / as outlined in other posts (not quite sure if I did it correctly though, done via MacBook network setting as opposed to in the sky router settings). Doesn’t seem to have changed anything.

Appreciate my setup may not be optimal as I don’t have a dedicated core, but haven’t had issues with local files and tidal, and I think this Qobuz issue has only recently appeared.

Will post again to say if things start cutting out again. In the meantime, any other advice much appreciated. I really do like the combo of Roon and Qobuz.

Thanks, Jamie, it’s good to have these pointers, and to your point I do believe this is frequently network related. At one point I was using Google’s public DNS (configured at router level) which I reverted during a troubleshooting session and that did help, though I have seen the issue resurface since then.

I’ll grab some logs next time it happens, but the errors last time were definitely network related for both image loading and streaming.

1 Like

I would also check your devices running roon are all up to date with the latest build 931

Yep up to date.
Played nicely for a while yesterday, with just the occasional hang between tracks, but today i’m back to the same issues.

I have once again deleted the qobuz folders from cache and re-started Roon and it definitely seems to help with the issue. Seems to play nicely if I select an album and just let it play, but once I start to skip tracks it affects play back.
Is there a permanent fix for this?

Hey @Dean_Bucknall it sounds like you’re removing Qobuz folders from a different directory (Cache) than I’ve described below.

Please try clearing your Qobuz registry (much different) and see if that helps. Please use the steps below. You’ll have to log back into Qobuz after doing this.

  • First, Close Roon or Stop Roon Server
  • Then locate your Roon Database
  • Navigate to Database>Registry>Core
  • Locate the Qobuz_account file and delete it
  • Restart Roon or Roon Server
  • Log back into Qobuz
  • Please let us know if this helps.

So I’ve been using for a while using a wired connection between my laptop (core) and router and it had been playing nicely for the most part. Still get the occasional stutter but not often and it tends to sort itself out after a minute or two.

1 Like

Hey @Dean_Bucknall, I’m glad to hear things have improved!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.