Qobuz isn't completing songs. RoonServer for Linux

I recently added a Qobuz subscription and have been having problems with it. It doesn’t happen 100% of the time, but most of the time if I’m listening to a song via Qobuz it will play for a minute or two and then just skip to the next track in the queue. It doesn’t seem to do this with Tidal or local files. I’m running RoonServer on a Linux laptop with multiple endpoints.

Is anyone else having this problem?


I occasionally (as in maybe once or twice a day some days) get a Qobuz track stopped at around 80% and advanced to the next one. My system is Windows based,

Okay, how in the hell does someone actually get Roon support staff to help you?

You need to flag @support or post in the support bit of the forum.

Hi @Nicholas_Seltzer,

I’ve moved your post over to the #support category, this is the category that is regularly monitored by support staff, although tagging @support also gets our attention.

Are you seeing this issue occur on multiple zones or just one zone in particular? Can you please provide setup details by using this thread as a guide?

Hi Noris,
Thanks for your reply and for moving the post.

The anomaly seems to occur in all zones. My setup is as follows:

Core machine: Asus UX305FA ultrabook running Xubuntu Linux, RoonServer 1.7 (build 610 stable).

Remotes: iOS and Android.

Networking details: all ethernet between core, router, and two endpoints.

Endpoints: Windows 10 PC, Mac laptop, Sonore ultraRendu digital streamer.

DACs: RME ADI-2 DAC, RME ADI-2 Pro FS, iFi Micro iDSD Black Label

Library: Files locally stored on an external HDD attached to the core, Tidal, and Qobuz. (Again, there are no issues playing local files or Tidal; it’s only Qobuz).

Hi Noris,
Any ideas yet?

Hi @Nicholas_Seltzer,

As for next steps, I’m hoping that we can take a look at your Roon logs to see if they contain further clues.

Can I please ask that you reproduce this issue, note the exact local time + date of the issue occurrence and which track/artist was playing and then send me a copy of your Roon logs?

You can access logs by using these instructions, and I can forward the logs for review with the QA team.

Hi Noris,
I’ve attached my logs. I was listening to Therion’s Beloved Antichrist around 1:30pm on 10/6. I wasn’t paying a whole lot of attention at the time, but “Anthem” skipped a minute or so in the next track “The Palace Ball”.

Link to logs:


Here is a whole sequence. Starting about about 8:40pm Pacific time (10/6). Basically the whole album of Smashing Pumpkins - Melon Collie and the Infinite Sadness skipped one after another until it got to the track “Galapogos”, when it just stopped.

More logs: https://www.dropbox.com/s/4ugz6e2wzgur44i/Nicholas_Seltzer.zip?dl=0

edit: Something else I want to mention is that currently I can’t play Qobuz at all. It won’t even start. This has happened previously. If I restart the RoonServer on my Linux box it will work… for a while.

1 Like

Hi Noris,
Are these files working out okay?

Hi @Nicholas_Seltzer,

Thanks for sending those files over and for your patience while I had a chance to consult with the team regarding your case.

Looking over logs, we are seeing signs that this could be related to your network setup. Can you please provide more details regarding this? What is the model/manufacturer of all your networking gear and how is the Core connected?

Are you using default DNS servers or are you using
Cloudflare DNS, Quad9 or Google DNS? Can you verify if the behavior is the same with all DSP turned off?

Hello Noris,
My router is a Spectrum Wave 2 RAC2V1K. The manual is linked below.

However, I don’t use WiFi. Both my core machine (Linux laptop) and my streamer (Sonore ultraRendu) are connected the router via ethernet/cat6. I’m using the default DNS servers. There are several other devices on the network connecting via WiFi, including a Macbook, an iPad, an iPhone, an Android phone, and a Roku.

This behavior is the same with DSP on or off. Note that I have other issues with Tidal, local files, or Internet radio. I have no issues with slow or spotty connectivity to the Internet. As far as I can tell, the two common factors seem to be Qobuz and RoonServer for Linux.

Hope this helps.


Hi Noris,
Anything new happening on this front?

Again, this problem seems to be very specific to Linux + Qobuz. Perhaps I’m not the only person having an issue.


Hi @Nicholas_Seltzer,

Thanks for the additional information and for your patience while your case reached my queue again. I’m looking over your logs right now and this is what I am seeing:

When trying to play Qobuz material

10/01 19:35:55 Warn: [streamingmediafile] in immediate read: System.Net.WebException: The request timed out
  at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00049] in <69f8661c94644655a06862d3e6b439f6>:0 
  at System.Net.HttpWebRequest.GetResponse () [0x0000e] in <69f8661c94644655a06862d3e6b439f6>:0 
  at Sooloos.Media.StreamingMediaFileImpl._ReadImmediate (System.Int64 file_off, System.Byte[] buf, System.Int32 off, System.Int32 count) [0x00086] in <9063275a1023456382c09ec02bddbe43>:0 
10/01 19:35:55 Error: [cachingseekableurimediafile] while reading: System.Net.WebException: The request timed out

Issues logging into your Roon account:

09/30 00:49:40 Warn: Error in web request https://accounts5.roonlabs.com/accounts/3/login: NetworkError (Error: SecureChannelFailure (One or more errors occurred.))
09/30 00:49:40 Warn: [broker/accounts] failed to refresh account info: Result[Status=NetworkError, ErrorText=Error: SecureChannelFailure (One or more errors occurred.)]

Issues loading images from our image server:

10/01 19:20:50 Warn: Error in web request https://imagecache.roonlabs.net/im/1/albums/a6003137303035323734/cover/1024sq.jpg: NetworkError (Aborted.)
10/01 19:20:50 Warn: [broker/images] update imageid=360 from url=roon://albums/a6003137303035323734/cover/__ROON_IMAGE_SIZE__.jpg => NetworkError in 10001ms

Having just the Qobuz traces might have been a sign that this is a Qobuz account issue, but from my point of view, I see this as a general network instability with multiple services, not just Qobuz.

We have two areas to investigate further:

ISP-provided gear is often not the best, so if you have another consumer-grade router you can try using, I would give this a try to see if it helps. I’d also change the DNS to Cloudflare DNS, Quad9 or Google DNS on the router.

I would try running Roon outside of this Linux environment, on a standard Windows or Mac PC if you happen to have one and verify if the issue is still the same. You can switch the Core by:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Hi Noris,
I don’t really understand the code you’re looking at. However, I can tell you that I do encounter streaming issues with Tidal, but only after using Qobuz. As I mentioned in my initial complaint, I’ll be temporarily only able to listen to local files. Rebooting the Linux server/restarting RoonServer seems to fix the issue, at least until I stream Qobuz again. I never encountered this problem until I started using Qobuz on RoonServer for Linux. It may also be useful to know that other than this problem, I have no issues with network connectivity in video streaming (via Roku) or online gaming, nor any issues when I only stream Tidal.

However, tonight I’ll move my RoonServer to a Windows machine and see how it goes.

This morning I was listening to Qobuz. It stopped and wouldn’t start again. I then attempted to stream Tidal. As expected, it didn’t work. So then I proceeded to do as you suggest and migrate from the Linux server to the Windows server. It then worked like a charm streaming Qobuz. I migrated back the Linux Server and it worked for an hour before it began skipping again. I immediately switched back the Windows box and it’s playing without any error or skipping (streaming Qobuz).

I hope this helps.

1 Like

Hi @Nicholas_Seltzer,

Thanks for running those tests!

This suggest that there is something environmental with regard to that Linux box.

How do you have your firewall configured for Roon? Perhaps this will help?

As I mentioned earlier, from my point of view it looks like the general Roon - network is not stable on that machine, so it seems like it would be a firewall or network configuration issue.

Thanks for the instructions. I’ll give this a try this weekend. However, I’m curious why this problem would only occur when streaming Qobuz? Is there an explanation for that? Because Qobuz won’t work properly, I’ve let me subscription lapse and am no longer a member. I now stream only Tidal and am having no issues.

I’m curious why this problem would only occur when streaming Qobuz? Is there an explanation for that?

Hi. Different aspects of streaming music (remote discovering core, core discovering network music storage, core discovering endpoints, remote controlling core, core streaming to end points, core talking to streaming music services, streaming music services feeding core, etc.) use different kinds of network connections. Often some will work and others will be blocked by firewalls and router settings.

In my case I tweaked firewall rules until Android remote -> Roon core running on Fedora laptop -> Chromecast and Orchard PecanPi endpoints worked, but I don’t use streaming music services and have a pretty simple network setup.

Try disabling the firewall on your Xubuntu Linux laptop and see if that helps; if so you can either live dangerously or craft appropriate rules for Roon (I know nothing about Xubuntu). I’m not sure what to try on your router.

1 Like