Qobuz jumping tracks. New ROCK installation

Core Machine

Intel NUC 7 i3 BNH
Roon ROCK
8GB RAM

Network Details

Talk Talk UK DSL Modem/router/switch
Cisco 2940 Ethernet unmanaged switch

Audio Devices

Devialet Expert Pro 440 hard ethernet wired to Cisco 2940 switch

Description of Issue

New installation of Roon ROCK. Playback from Qobuz skipping on every track. Each track will skip to next before completing playback.

Just skipped the first four tracks of an album without playing.

Did not expect this problem with a brand new install of ROCK!

Three days and no responses from the Roon support team. This is not good customer care as far as I’m concerned.

I have re-installed ROCK on my NUC and Qobuz is still skipping tracks. I need someone from Roon support to actually support me on this please.

Hi Martin,

May I suggest you run a search on here for the same issue as there are countless other similar posts and I believe a solution was offered.

Hi @Disarmamant

Thanks for your patience over the weekend! Our team currently works Monday through Friday, so there can be a bit of a delay over the weekend.

Before using ROCK did you have a different Roon setup that worked okay, or is this your first Roon setup?

Does this happen for all endpoints? If you play to System Output of a remote instead of the Devialet do you still see skips?

Does local content work okay?

One thing I’d suggest is to use Google DNS or Cloudflare DNS on your router. Sometimes ISP default DNS options don’t work as well with Linux devices like ROCK, and we’ve seen changing DNS help to resolve these types of issues.

Hi @dylan

Thank you for your response.

Before using ROCK I did have a stable setup on a Dell Precision T3500 server running both Fedora Linux 25 and also later running Linux Mint XFE 20.1. Both linux distros were running Roon Core with mostly no issues, but I did have the track skipping problem with Qobuz more than a year ago.

At that time I was advised to try a different DNS server, 1.1.1.1. I found it made no difference to the track skipping problem with Qobuz so I reverted back to the default DNS settings in my DSL router. Since then the problem went away anyway.

I decided to try installing ROCK on an Intel NUC 7 i3 BNH, thats when the Qobuz track skipping started right away. I re-installed ROCK on the NUC, but it was totally unstable and the Ios Roon control would not remain connected to the core. On re-booting the NUC the Roon server would not start, even clicking the start button in the Roonserver web page would not start the core, only a hard reboot.

I have now abandoned using ROCK on the NUC as I just cannot get it to work despite several re-installs. I am now using my old Dell server again with with Roon core running in Linux mint 20.1. No skipping problems, and the DNS is set to my ISP default.