Qobuz keeps failing, then can't log in

Core Machine (Operating system/System info/Roon build number)

QNAP TS-251, v1.8 build 783.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired connection to Netgear router. Connection is good, Dropbox works, live radio works.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

I don’t think that this is a device issue

Description Of Issue

I keep having problems accessing Qobuz. It says it’s failed to connect, I click ‘retry’, but it doesn’t work. So I click Cancel instead. This logs me out of Qobuz. I go to Settings, here I enter my account details. I get the response: There was an Unexpected error, please check your account details. (UnexpectedError).
Needless to say, my account is fine, I can play anything I like through the Qobuz app. I now can’t log back in.
This has happened several times in the last week. Eventually I’m able to log in, the next day or so. Currently I’m locked out though and feeling a little frustrated. What can I do to troubleshoot?


1 Like

Hi @Kit_Withnail

When this occurs are you seeing any other issues with playback of local content or TIDAL (if you have that as well)?

Can you make a note of the next time this happens? We can enable diagnostics and take a look. Thanks!

Hi @dylan there is, I believe, the same issue with Tidal, I have been having the described problem with my Tidal login for the last few days the only difference being that I can login again & “retry” works intermittently in my case.

Thanks Dylan. No problems at all with local playback, and I don’t have Tidal I’m afraid. Happy to enable diagnostics, how do I do that?
As of this morning I can log back in to Qobuz in Roon, but as this happened before I expect it will get stuck again soon.

Thanks again,


Hi @dylan - the problem has just occurred again. What can I do to troubleshoot please?

A post was split to a new topic: Cannot log in to Qobuz, network error

Hi @Kit_Withnail

Please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).


@dylan Thanks for your reply. Here are the logs:

@dylan sent you my Roon core logs too yesterday, as requested
though can’t see the PM: hope you did get it

this morning everything’s still the same: login attempts to Qobuz keep failing with that “Network Error”

tried Audirvana too, using the Lumin U1 Mini as endpoint (as Roon does), and… it works flawlessly

Hi folks,

Whilst I can now log in again, I’ve every reason to expect the issue will recur as it has been for a few months. Is there any update on the log analysis please?



What is your DNS setting in router and/or Roon Core computer?

@pl_svn @wklie Sorry to be that guy, but please can we keep this split threads separate?

I didn’t split them, but now it’s done, I’d be grateful if we could avoid re-merging.


… in fact this morning I posted in the other thread :roll_eyes:

posted here yesterday because…

My question applies to you too.

Thanks. The QNAP uses the router for DNS, and the router uses Cloudflare DNS. No problem accessing Qobuz from the QNAP or any other machine on the network.

Try logging Qobuz out from Roon Core, Qobuz apps, streamers and all other devices including family members’ devices.

Reboot the QNAP. Then retry.

If that does not work, set QNAP to use manual DNS, and repeat the above procedure.

Thanks @wklie - I’ve tried that except the DNS change. I am not willing to stay on Google DNS, so that isn’t a fix that works for me. I can’t test it temporarily either as the error is intermittent.

What country are you in? Is that a Qobuz-supported country? Or are you using VPN?

Hi there. I’ve been using Qobuz for a very long time with no issues. I’m in London, UK. Only ever had problems with Roon integration and even that only in last few months.

Please try setting QNAP to use manual DNS, then restart the QNAP.