Qobuz-lots of tracks not playing

Got my invite today :grin: and signed up for hi-res.
Started exploring via Roon and have noticed that there’s a significant amount of tracks that will not play. Thinking this could be a Roon integration issue I jumped out to the native Qobuz IOS app but am experiencing the same issues. Tried differnt streaming qualities with the same results. See image below for error message.
My 1st througt was a licensing issue but there’s too many for this to make sense.
Using a new iPad Pro with an AQ Dragonfly via WiFi.
Will cross post at the Qobuz forums if there is such a thing.
Any insight would be much appreciated.

I’ll be watching this thread. Had the same issue earlier today.

Hmm… plays perfect here (Germany)

Thanks for the replies.
Just tried playback from the Qobuz PC app, iPhone and Roon and the track listed above is now playing. iPad app was still failing but logged out/in and its now playing. I did try this yesterday and still had the issue. Chalk it up to a glitch in the matrix. I did create a support ticket with Qobuz. If I get a response with relevant info I’ll add to this post.