Qobuz media is loading slowly with Nucleus and new network [Solution: changing ISP provided DNS]

Core Machine
Roon Nucleus
OS Version 1.0 (build 227) stable, Roon Server software Version 1.8 (build 795) stable

Network Details
Nucleus is connected to router through Ethernet cable.
The router is provided by the ISP and it’s an ARRIS NVG468MQ.
Internet download speed on cable: 525 Mbps

Audio Devices
Bluesound Powernode 2 connected to network through wifi
Internet speed on wifi where the Powernode is located: 300-320 Mbps

Library Size
26,049 tracks

Description of Issue
While playing Qobuz from Roon, very often (sometimes multiple times in a day), music suddenly stops or tracks are skipped midway and I see the error message “Qobuz media is loading slowly. This may indicate a networking or connectivity problem”.

I see other users have reported the same issue and it is usually attributed to network issues. Attributing the issue to my internet connection, I just lived through the frustration. However, I’ve recently moved, switched ISP and switched to the router they provide and I still get the same issue.

I can stream from the Qobuz app on laptop, phone and tablet without issues. I can also stream Qobuz from the Powernode without issues. This issue only occurs when streaming through Roon.

Thanks in advance for the help.

what are your DNS setting like in the router, try using or in place if the ISP ones…make a note of what you have first before changing them

Thanks for the suggestion. I haven’t touched these type of settings before, so I’ll wait to try until I finish work today. In case I mess up my connection!

I’ll need to give it more time, but first couple of hours after the change and it’s running smoothly!


Hi @Manu

Updating DNS settings are definitely a good suggestion! Keep us updated if things continue to work well.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.