Qobuz music is taking almost 5 minutes to load and play in ROON. Started 3 days ago

I have had my system for 3 years with ROON, Windows 10 I5 computer with 2 zones, PS Audio Sprout and Schiit Yggy dacs. Works fine from my library stored on my hard drive, instantaneous playback. Three days ago when I click on a recording from Qobuz I get all the information and songs, but it can take up to 5 minutes for it to play. Then after each selection it does the same pause again. I have restarted everything computer, ROON, Qobuz and router.
No clue what to do next!

I’ve moved your topic to the Support category of the forum, where it will be seen, and responded to, by a member of the Support team.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup and the nature of the issue using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they have a clear understanding of how your devices are connected.

Hello @David_Holzman,

Thank you very much for reaching out when running into issues. We appreciate it.

Would you please share a bit more detail about your Windows 10 Core machine? What is the CPU chipset, for example.

Is the delay present when playing to either one of your zones, or just one of them?

In the meantime, could you please try:

  • playing from Qobuz directly. Is there a delay in starting the track?
  • log out of Qobuz in Settings → Services, reboot your Windows machine, unplug it for a couple of minutes, turn it on and log into Qobuz in Settings → Services

Thanks :nerd_face:

P.S. Thanks for your help, @Geoff_Coupe :pray:

I am running Roon 1.8 Build 795,stable 64 bit. Core runs on a 9 month old Dell I5 computer. I have an Xfinity white router(no vendor name) that is 6 months old. I have a direct ethernet connection from the router to my computer. From there I have a usb connection from my computer directly into my PS Audio Sprout 100. I have my main system in another part of the house, but I disconnected the ethernet connection to it to make it easier to troubleshoot. Pretty straight forward system to troubleshoot I hope.
This has been a stable system for over a year when I purchased the PS Audio. Sometime this week I could not play from Qobuz without it buffering for 5 minutes before play started. I can access my local music stored on my computer no problem with ROON. I can also stream Roon radio instantaneously. I have connected and reconnected my Roon connection and Qobuz repeatly. I am also current with my Windows updates.
No clue what to do next. I’m guessing xfinity made an update that messed things up.
Thanks
David

1 Like

Delay is in both zones. I logged into Qobuz directly from my computer and it played immediately without delay. I logged out of Qobuz and rebooted and logged back in. No change in the delay.

I have an
Inspiron 3880
I5 10400 CPU @2.90 Ghz
Ram 12 GB Windows 10 Home Version 20H2
Installed 10,13,2020
OS Build 19042.1052

My download speed test was 607 mbs, I think that’s not a problem!

Any suggestions?

David

Hey @David_Holzman,

I appreciate the detailed post :nerd_face:

Could you please try one more thing? Changing your Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS.

Thanks :pray:

I have never done any router changes. Can you point me to some instructions that would help me do this?

I logged into the server and I went through all of the server options and there is not one to change the DNS server

It looks like it is currently set to
Primary DNS Server(IPv4) 75.75.75.75

also says
IPv6
Stateless Stateful

when I google how to change the server, I found some folks who said

No, it’s hard coded into the gateway to prevent DNS Hijacks and similar attacks.

No clue what to do now, although I do know how to access the server now.

Hey @David_Holzman,

I do appreciate the effort you went through to follow our instructions :pray: . I wonder if this would help?

Since we’re returning to work on Monday only, I was wondering if you could navigate to Settings → Services → Qobuz and lower the streaming quality. That should help :nerd_face:

My latest efforts

1- Dropped the streaming speed all the way to MP3 range. Same problem with delays

2- Could not find an option to change the DNS on my router in the router settings… When I looked online I found xfinity does not let you change things

I wonder if my Roon app is corrupted and needs to be uninstalled and then a fresh install. Again Qobuz works fine from a browser session so something is pretty funky

Thanks

David

It depends on the actual model of router you own. They started changing things up in the last year or so. That being said, the best option, is to call them Comcast tech support directly and ask.

If indeed you are stuck with a router with that limitation, then there are other options, depending on how you use Comcast services. You could get a new router and set the comcast into Bridge mode, for example.