Qobuz no album art

Core Machine (Operating system/System info/Roon build number)

Core is on MacMini late 2012 (Catalina) running RoonServer 1.7 (build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

These are the clients (all 1.7 (build 667)) on which the problem appears: MacMini late 2012; iMac 27" late 2015, all running Catalina 10.15.7. Audio devices appear to have no impact on this (problems appear irrespective of zones chosen)

Description Of Issue

All album art missing from Qobuz, and all/most local album art is also missing. We also run a Roon client on a MacBookPro and on iPhones and an iPad. The album art problem does not occur on those.
Qobuz display on iMac:

Local album art on iMac displays on the first page but disappears thereafter:

The MacMini is no different.

For what it is worth: I also have an old iMac running High Sierra. The problem of missing album art does not appear there. This old iMac shares the same network connection, using the same switch as the iMac running Catalina where the album art is missing.

Hi @Luke23,

Can you give some details on your network setup?

Are local files appearing okay?

In the past we’ve seen that using Google DNS or Cloudflare DNS might help in cases like this — Can you give one of those a try on your network and let us know if things are better (you might need to reboot your Core / remotes after setting this)? Thanks!


As my previous screenshot shows, local album art also suffers, often only displaying the first page or being very patchy, as shown above where only one album appears on page 2.

What more would you like to learn about our network setup? It is a 1Gb ethernet network, using several passive switches of different brands. However, both the iMac that has problems and the iMac that doesn’t (one with Catalina and with High Sierra) are using the same switch.

I switched from Level 3 to CloudFlare to see if this makes a difference, but it doesn’t look like it (or does it take time or a restart?): Qobuz still shows no album art on the Catalina system and only the first page of local art and nothing thereafter.

Do let me know if you need more info.

I restarted the DNS server (as well as the Macs) and verified it was now using CloudFlare (it was). It made no difference.

Hello @Luke23, could you please try temporarily disabling your firewall/antivirus and see if this makes a difference? I’d also like to know if you’re able to reproduce this issue with the core connected directly to the router. Thanks!

might be an issue on Qobuz side: can’t play any of my favourite albums and Roon’s Qobuz section…


I did disable the firewall (I have no antivirus running) and my local art is back (I checked the old High Sierra iMac where this problem did not appear and there the firewall is switched on; the firewall on the Catalina MacBookPro where everything also worked fine was switched off). There does appear to be a bigger Qobuz problem now because like pl_svn I am getting the Error loading page now, even on the machines where it worked flawlessly before (and this includes the iPhones and iPad). The Qobuz stand-alone app works fine.

What do you mean by connecting the core directly to the modem? Without an intervening switch?

I restarted the core and Qobuz is back (after presenting me with a login problem message first), but all album art is grey again and that also applies to the local art (first two pages local art are fine, thereafter just blanks).

Oh, I did connect the core directly to the router. It made no difference.

Hello @Luke23, are you able to connect your core to a separate network temporarily (such as a mobile hotspot created by your phone) so we can see if this is related to your network or that core specifically?

Also, do you have any issues seeing your content through the Qobuz app? Lastly, have you tried clearing your image cache to see if this brings the images back?

Thanks for staying on my case. In a different thread run by one of the other support staff it was suggested I check a thread on PiHole in association with Roon, which I did. The case was not very similar but it did make me wonder. So I disconnected the Raspberry Pi with PiHole completely and that resulted in a vast improvement though the problem did not go away completely. I then re-installed PiHole and only set it up as a DNS server (not using it also as a DHCP server which I had done previously). I have only done that today and the first results are very encouraging.

Though this experiment points the finger at PiHole it cannot be that alone because as I said earlier, Roon on other machines (iPhones, iPad, MBP and even another older iMac) does not have this problem. It only occurs on an iMac and a Mac Mini both running Catalina.

I’ll wait a day or two and see how things pan out once all the leases have been renewed.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hello @Luke23, I have reopened this thread per your request. I know you’ve tried changing DNS, what about signing out and back into Qobuz?

Thanks. I am sorry to say that my problems are back, even after I had completely disabled PiHole. When I had a little time I used some of the computers in the house to systematically check how Roon behaved on them. I did discover that when disconnected the Lan on the problem machines the album art did return, but the weird thing is that of the two iMacs connected to the Lan using the same switch, the older one showed the album art fine, whereas the newer one did not. I listed it all in a spreadsheet, a screenshot of which I have enclosed here.

Hello @Luke23, you previously mentioned having switches in place, I’d like to know more about your networking setup including router model and models for the switches you have in place. I’d also like to collect diagnostics from one of the devices you mentioned so I can show our QA team. Could you please reproduce the issue again and reply here with the following?

  1. Please let me know the date and time you notice the issue
  2. Please let me know the album you noticed the issue on
  3. Use the directions found here and send us over a set of logs using a shared Dropbox link.

Hi Nuwriy,

The screenshot I enclosed last time lists the different switches in use (Netgear GS205 and Asus GigaX1108N). The spreadsheet will also show you that two iMacs are connected to the same switch and one has the problem of missing art, the other does not. If you want a time when this happens, with the iMac almost all the time (now: GMT +1 Friday 21.27) and as my previous screenshots showed it isn’t a problem with a single album but with all Qobuz albums and most of my own albums. Here are two screenshots again: one of Qobuz, the other of my own albums.

I created a logs.zip file but I do not have a dropbox account nor do I want one. How do I get the zip to you?

Hello @Luke23, could you please upload those files here and let me know when you’ve had a chance to do so? Thanks!

I uploaded the files a minute ago.

Hello @Luke23, and thanks for uploading those files! I spoke to the QA team today regarding your issue and we wanted to have you do the following:

  1. Create a backup of your database
  2. Uninstall Roon
  3. Install Roon from here
  4. Restore your database

We’re working on an issue related to RoonServer and Roon Remote on the same machine that in some cases, causes images to go missing like this. I’d like to see if this is the same issue.