Qobuz not delivering music to Roon

I am running ROCK on a NUC Gen 5

I have an iFi USB to SPDIF converter which is connected to the NUC and then via COAX to my Metrum NOS DAC. The DAC output goes to my pre-amp and then to amps (all NuForce Reference). Roon works fine with local files ripped from my CD’s and with the Tidal service signed in.

I updated to the 1.6 build 390 to be able to connect my QOBUZ account. As I have been using Tidal and am very happy with ROON sound and usability, I really wanted QOBUZ connectivity as they offer acces to music Tidal does not offer. Because of this I subscribe to both services. Unfortunately QOBUZ through my Mac Mini to my DAC does not sound as good as ROON with Tidal from the NUC directly to my DAC. I have the Convolution filters active in Roon, which adjust the frequency and impulse response of my speakers (Magnepan 1.7’s) to the room. I really wanted to have acces to the music QOBUZ offers through my ROON platform as configured for local files and Tidal.

I have been using QOBUZ since 2016. I connected my account to ROON. This seems to be successful as it shows I am signed in. But the ROON interface tells me that playlists are empty and does not seem to populate any QOBUZ sourced material. I am including screenshots as examples.

As mentioned before, ROON is working fine with local files (streamed from disks connected to the Mac Mini as server) and Tidal.

My question: is there anything I am missing to make this work? I signed into QOBUZ just as I do with Tidal and the services screen shows I am signed into QOBUZ. I reinstalled the ROCK with no change in this behavior.

I hope you can help.

Flagging @support <-here for you.

1 Like

I just installed Roon first time as Qobuz is now supported. I had the reverse issues you have. I had trouble connecting my NAS to Roon ( now solved) but signed in to Qobuz without any problem.
At one point I lost everything on my MBP: Roon stopped but that was due to a change in passwords.
I rebooted and all is working and Qobuz with “my Qobuz” shows with favorites and all.
You might try changing your Qobuz password (directly in Qobuz) and resign in via Roon?
Hope this helps!

Thank you Wizard of Oz!

Dear Jan-Erik,
Thanks for your suggestion. After reading it I thought immediately that there is a good chance that this path can help. I noticed the first time login in that Roon took a long time to notify me that I was signed in. I thought prompting the system with a fresh password could be successful. I changed my password through the Qobuz website, checked if this works well, then started Roon, signed out of Qobuz and tried with the new password. ‘Signed in’ came almost immediately this time. But unfortunately I’m still getting ‘Empty list’ and ‘No results’ from the Qobuz service. I’ll keep exploring possibilities and hope to continue to get suggestions I can try until I find the solution.

Hello @Glenn_Thode,

I have a few questions to better assist here:

  • Can you please confirm for me that these playlists are loading fine in the Qobuz app?
  • What kind of Qobuz subscription do you have?
  • If you also have TIDAL do playlists show up as expected and are playable?
  • Have you tried rebooting your Core and Networking gear yet? I would give that a try.

Please let me know when possible.


Hello @noris ,

Thank you for the message and the questions. I went through them. I’ll provide answers to your questions and at the end of my reply I’ll go into your suggestion to reboot Core and the Network gear.

  • In the Qobuz app, all playlists and other features appear, and the content of these list show when they are selected. The music which is shown plays through the Qobuz app as expected. I’m including screenshots of how this shows on my screen.

  • The Qobuz subscription I have is an older subscription that is currently not offered anymore. It is called HiFi Sublime. I have taken screenshots of that. Some of the text is in the Dutch language, as that is my ‘region’. I’m living within the Kingdom of The Netherlands at this moment.

1 Like

What a lovely polite way you have to set out your problem and the work you have done to try and solve it. Makes a really refreshing change, hope it is fixed for you soon.

1 Like

Could you use a different user ID and sign up for a free months trial of a different current Qobuz service and see if that works? Might narrow it down to a roon/Qobuz subscription clash.

Dear Ged @ged_hickman1 ,
Thank you for your supportive response to my posts! It encourages me to continue with the same ‘tone’. Your last suggestion about trying with a different Qobuz subscription triggered me to follow up. I did and signed up for a trial of ‘Qobuz Studio’. After I did this, I tried first to sign into the Qobuz app with the new trial subscription. This worked well and I have access to high res files with this subscription. Entering the credentials in Roon was a breeze and it showed I’m signed in instantly. Sadly the playlists it shows in Roon are still empty. Access to the music is still not available somehow. Thanks to your suggestion I now think that it is not the Qobuz subscription ‘flavor’ I have that is the source of this particular issue I’m confronting. I hope this helps @support further on the path to a solution.

1 Like

Hey it’s easy to help a nice person. Can you pick a random Qobuz high Res album and see if that streams properly?

Thanks again Ged :blush: . With the Qobuz app and the Studio subscription I picked some HighRes albums and they played as expected. I picked classical music at 24 bit 96k (Chopin solo piano), pop at the same (Massive Attack), some at 24bit 44.1k (Pink Floyd) and others at 24 bit 88.2k (Daft Punk). All played well through the system.

Strangely, I did run into some issues early this morning with Roon not getting the album graphics right from Tidal. The music played, but the graphics showed empty boxes. After playing with settings without much success I decided to reset my complete network hardware. This did not help, so I went and reformatted and installed ROCK from scratch on the NUC using the roonbox factory reset file provided by Roon through the website. I decided to do that as the process is so quick and smooth. In a few minutes I downloaded the latest file and flashed it on a USB stick, installed ROCK on the NUC, updated, configured and was ready to rock. I am happy that it seems to have solved the issue with the graphics from Tidal albums and tracks. I immediately tried with both my Qobuz subscriptions, unfortunately again without succes.

But then I ran into is a peculiar ‘new’ limitation to the ease with which the system searches, compared to how it performed previously (until last night). For instance, a search for Madonna albums gets me no results now, while Adele for instance works great. I’m including screenshots.

There is something ‘random’ about these hit and miss searches now. Marc Anthony works, but Iron Maiden doesn’t for instance.

I’m in awe and wonderment about these mysteries …

I think the roon system is suffering a few issues at the moment. Your blank album art was actually roon’s fault not yours. Learning lesson, it isn’t always you! :kissing_smiling_eyes:
Have a look at the forums before rebuilding to see if there is a wider problem.
Having said that, this is the first real outage I’ve seen in all the time it’s been live. So give it a while and service should be resumed.

Hang in in there my friend.

1 Like

Dear Ged,

Many thanks for sharing this know how! I am happy to report things are returning to normal indeed and Roon is running great with Tidal again. The flaws and examples of my last posting referring to Roon and Tidal are resolved. This is a lesson learned indeed! :wink:
Even so I am happy I have a fresh ROCK running. I’ll be hanging in there and am confident the other issues, having to do with the Qobuz match, will be solved as well, as time is on our side. Until next time my friend!

1 Like

By the way there are threads under the music category where people post what they are listening to which can be fun… and horrifying :wink:
If you don’t already know, in the three dots menu on albums and tracks there is a share function that takes the equivalent of a screenshot so you can share.

1 Like

Is this the primary issue you’re seeing now @Glenn_Thode? Are you signed in with your main account?

You’ve given us some good information here, so I want to enable some diagnostics on your account and have a ticket opened up in our internal tracker – I just want to make sure I understand the full extent of the symptoms, and have diagnostics that match that description.

Thanks for your patience here!

1 Like

Dear @mike,
Thanks for your interest in this case. The primary issue is indeed that I seem to be signed into Qobuz, just as I’m signed into Tidal. But different from the Tidal interface, the functionality to be able to access music from the Qobuz service is missing through my Roon deployment. I tested a Qobuz ‘trial account’ to compare with my main account, but got the same result as my ‘older’ account. I am now signing into my older or main account and am contemplating to cancel the trial, before it expires. I’m also signed in with my Roon account which is not (yet) a lifetime one.
I hope activating the tracker might help to diagnose the anomaly (which is what I think this is) I’m experiencing.
I’m VERY happy with Roon with Tidal and my local files, which is soooo much easier then swapping CD’s. And the sound quality seems to have improved in my system with the latest upgrade. Rediscovering my music helps much with the patience :sunny:

Dear Ged,
Thank you for the info on the music threads. I was not aware of that, I’m going to explore them. I also certainly did not know about the features under the three dots. I checked it out and noticed it’s very specific, making it possible to ‘zoom in’ on lyrics you like from a song, and share… Great new feature. I’m sure to explore this part of the Roon community more and more in the future. Please keep the great tips coming!

1 Like

Hello @Glenn_Thode,

Apologies for the delay in getting back to you here. I wanted to let you know that we are taking another look at this issue and I have followed up via PM for next steps.


Dear Noris,

Now it is my turn to offer my apologies for the 3day delay (aliterates nicely :slight_smile: ) I have followed your suggestions in the PM. I do hope it helps.

Many thanks for following up and through with me and I hope this enables further steps towards Qobuz integration with Roon in my setup.

Best regards,