Qobuz on Roon only playing at CD quality or lower

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
This is not a diagnostic type problem.
When I play the Qobuz app on any of my mobile devices I get HD.

When in Roon I connect to Qobuz Service I am only given CD quality or lower. Why?

When I play on Roon it identifies the album as 96Khz 24 bit etc. but it only plays 44K 16bit even though the Qobuz stream is higher resolution.

In Roon, if you go to Settings > Services and Edit Qobuz, what does it show as streaming quality? Can you select a Hi-Res quality?

Can you post a screenshot of the Signal Path when playing a 24/96 track?

Cheers, Greg

Edit Qobuz only shows a low res and 44Khz 16 bit, no higher res.
Signal path always shows 44KHz 16 regardless of the quality being pushed by Quboz

Have you checked (/changed) your actual ‘Qobuz’ settings in Roon?


Thats the problem you show High Res Options. I show two identical Red Book and no High Res options

When you sign in to Qobuz native app or via the web what is it saying it thinks your subscription is?
Just in case they’ve had a hiccup.

It is Studio. In native I can play the HD music but unfortunately Qobuz native apps are all for mobile devices which work just fine. But It would be nice to be able to play HD music on my HD system.

Some weird problem. Support will help.

Just out of curiosity, when you go into the settings on the Qobuz native app do you have both “mobile network” and “wi-fi” set to play in high resolution?

If not, that might be the problem.

Interesting question. Where would I even find mobile network or wi-fi settings??? I’ve never seen these settings. They might apply to mobile use of Qobuz but my problem is with getting a high res file off my iMac that is ethernet hard wired to my PS Audio Bridge II streamer that is also ethernet wired…no bluetooth, wi-fi or mobile network involved.

Not a direct answer to your problem, but I’ve used the Qobuz app on my PC to play music.

As for your Roon problem, maybe you only get the choice of CD quality because that’s all Roon believes your devices are capable of?


A screen print of your Signal Path that exists when a track you are having trouble with is currently playing might help shoot your problem.

Actually @Riviera_Bluesman has a really good idea. I did this myself and his mentioning it…
i had tidal and had set a limit on playback on my native app without realising that set that to my Account so it applied to all players including roon. It may well not apply to you but whilst you wait for real support to come along might be worth a look. :slight_smile:

Webplayer and desktop app:

Go to your profile by clicking on the top right of your screen, then on the tab “Music Playing” to select your default listening quality.

While playing a track, you can change the listening quality in the player at the bottom of the screen. Your new default listening preference will also be changed in your account’s settings

1 Like

After thinking about it more, the setting I’m thinking of is likely just for using your mobile devices on either mobile (cellular) networks or WiFi. There are separate settings for each in the Qobuz native mobile app, in case you may not want to use a lot of data when you are on cellular I suppose. You find it here:

my Qobuz > settings > streaming

I was thinking that the WiFi setting was used for your entire Qobuz account, but on second thought it’s more likely used for the individual device that the app is located on. Sorry, not trying to confuse the issue just trying to help.

Slim is likely more on the right path that your problem may be related to the settings within Roon for the device you are trying to stream hi rez too…

Thanks Ged, I thought that’s how it worked but then I second-guessed myself…

1 Like

I was going to reply but thought you would read and …

All files coming from Qobuz give this identical signal path. This Roon display of the cover art indicates this music is 192/24

Again when I set up Qobuz in Roon it doesn’t give me a hi res opion…only Red Book

I use Qobuz app on my iMac to play music also. But what are we talking about when you say play music? I can hear HR Qobuz music through my iMac on internal speakers and anything that is connected to the computer via USB like my PSA Sprout. But nothing using ethernet, or Sonos

Thanks for that.

Sorry, I misspoke. Your device setup is more important. By the time the signal path is in play, it’s too late.

OTOH, your DAC is more than capable.

Did you check out @Riviera_Bluesman’s idea? Probably more to the point.

As far as the Qobuz, I thought you meant that there was no way to play from a PC.

I’m going to butt out now. :pensive:

Hello @Kenneth_Eis,

I sent you a private message for more troubleshooting, please get back to me when you have a chance. Thanks!

I had the same problem. I fixed it removing the Quboz link in Roon. Then re-instated it and, of course, had to log back into Quboz to attach the service. Then all the hires became available.

What had happened is that I signed up originally for standard Quboz service and later upgraded to allow hires.