Qobuz playback hangs randomly

Core Machine (Operating system/System info/Roon build number)

New ROCK NUC, OS Version 1.0 (build 183) stable running Roon Server Version 1.7 (build 511)

Wired network (Ethernet Cat-6), ASUS GT-AC5300 Router, Synology NAS for storage, UltraRendu network streamer, connecting via USB to Chord Dave DAC.

Sonore UltraRendu network streamer, connected via USB to Chord Dave DAC, then to my Naim preamp and amplifier. All connections are wired (I do not use WiFi for music).

Description Of Issue

I am using Tidal and Qobuz, I have no problems with Tidal streaming, very reliable. I also have no issues streaming from Qobuz when using the Qobuz Windows 10 software client, however, when I play Qobuz from within Roon I frequently have tracks freeze at the 0:00 mark, never starting unless I hit the Play button repeatedly a few times… Roon Radio mode also gets frequently stuck when the queue lands on a track from Qobuz.

Hi @thijazi,

Do you experience this issue with Qobuz for all Zones? If you play to System Output of the Windows remote does the same issue occur?

Yes, this happens when I listen to my main HiFi rig, and also when I am listening on my PC when doing work in my office room (same house)… They are two different outputs…

Sometimes, Qobuz would stop playing mid-way through a track, not very often but this happened a few times already…

Hi @thijazi,

As a test, can you go to Settings > Services and lower the Qobuz streaming quality to the lowest setting and let us know if that results in any change?

Just changed the setting as instructed, will test it for couple of days and report back.

The funny thing is that if I use Qobuz deskop client, nothing ever goes wrong…

The issue is still happening, not as frequently, but it seems something is keeping the Qobuz playback from within Roon troublesome for me… Is there anyway I can troubleshoot this using logs or any other tools?

Hi @thijazi,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more using System Output and note the time at which the error occurs along with the name of the track that is playing. Then respond here with that time and track, and I’ll make sure we review the diagnostics related to that timestamp.

I enabled the full resolution option in the Qobuz service settings (inside Roon), funny enough it has been very stable for the past couple of days, no hiccups yet. I will report back if any of the tracks hangs again.

Thanks for the fantastic support team Roon!

1 Like

I’m glad to hear that things have been running smoothly so far, @thijazi!

Please let us know if you see any changes.

Just happened again, I was listening the a Qobuz Playlist, hit the play button, saw that the track counter started with the little vertical bar showing up at 0:00, the icon to the left of the track title showed the little audio level bars dancing indicating some sort of playback, however the timer never moved from 0:00 and after about 15 seconds the playlist just jumped to the following song…

Time stamp: Dubai local time at 9:59 AM
Track: Bossa Nova Nemo (The Jive Samba) by Peter Dominguez on the Groove Dreams album.

Screenshot shows this…

Subsequently hitting the playlist “Play Now” button starts the playlist including the song that failed the previous time just fine…

Just happened again, this time it also cut off towards the start of the track with an error message:

Time: 11:09 AM Dubai time
Album: The Beautiful Not Yet
Artists: Carrie Newcomer
Track: Lean in Toward the Light

And again over the past couple of days, practically impossible to listen to Qobuz via Roon, while the Desktop Qobuz client works fine… Tidal also streams fine in full res…

Last drop timestamp was 07:15 AM (Dubai time), artist: Little Big Town, Album: Nightfall, track: Next to you.

Hi @thijazi,

Apologies for the delay here! I enabled diagnostics on your account and reviewed the diagnostics report with the team. There appear to be some networking errors here when trying to play Qobuz content that seem to be contributing to the behavior you’re seeing.

Can you try to using Google DNS and let us know if that helps?

If no change, can you try going to Settings > Services > Qobuz and lower the Qobuz streaming quality and let us know if that still results in dropouts?

Hi Dylan,

I am on Google DNS, this is my setting at the router level so that is already in place for some time now… I tried earlier to lower the settings of the Qobuz streaming and while the problem appeared less frequently it still did frequent enough to make it a bothersome experience.

Funny enough, the Qobuz client itself (the desktop client) works flawlessly so I am fairly certain it is not the network that is causing these hiccups.


Hi @thijazi,

Roon typically requires a bit more from the network than playing content directly from the Qobuz/TIDAL client directly. Since lowering the Qobuz quality did improve things (even though it wasn’t perfect still), and since we were seeing networking errors in the diagnostics report, it seems like something related to the network is at play here.

Can you confirm what the download speeds are for the network?

As a test, if you ran your Roon Core on a Windows or Mac machine that is on the same network connected the same way does this problem still occur?

I have a 500 mb connection speed from my ISP, I am watching 4k video on youtube as well as HD content from Netflix without a glitch…

How would I be able to run Roon core on another machine? won’t I have to log out/disable my current roon server to do that?

Can you share the nature of the networking issues? I configured my router to use Google DNS but I can try and set it up to obtain the DNS settings from the PPPoE ISP connection instead, let me know if you believe the DNS settings are to blame here.