Qobuz playback issues on Nucleus

Usually all freezes and cannot play anything. Again this is only in Qobuz . Very rarely however when I try to play another track after the frozen one, the other track plays but usually not.
I have activated the nucleus HDMI output just for these diagnostic purposes and will check as you instruct and also note specific time and date when the behavior recurs.

The issue occurred at 5:22 PM. The track Froze as previously described when trying to play to dCS unit. As I had enabled the nucleus HDMI output, I opened the Vivaldi icon and the track was playing to the HDMI output as the blue line was moving up and down whereas the one by the Vivaldi was flat.
I then selected another track which was flat/frozen for 10 to 12 seconds and then began to play spontaneously to the dCS… This has also happened before.

There were no error messages when I tried the above, whether the rune line was moving on the HDMI or not. The error messages do not always appear.

Problem recurred again at 8:12 PM today 2/1120.
I found this workaround (!) in Roon Support, from one of the Roon Techs. It works for me also, as it did for the person (among many) who submitted the same problem I’m having:
“In one case, a user was able to get the unplayable tracks to work by clicking the “Play From Here” button on the first track of the album, and then using the “Skip Track” button to move through the queue’d album.”
I strongly continue to suspect the problem is at your end, Software-related. It’s nice to have a workaround, but there shouldn’t be a need for any!

Again, the problem was with a Qobuz album, this one Hi-Res.

Again, as I’ve written above, here are the pages documenting others who are having this same problem:

Please be sure to click on my previous post’s hyperlinks to open up the full pages for each hyperlink.

Cant say Ive had this problem on Roon but I have had the same issue using the native Qobuz app. I end up having to close the app. Sometimes it will take a few goes and the track will play.

More information:

  1. Have not encountered problem streaming Qobuz from dCS Mosaic App for a total of several hours.
  2. Re-installed the Roon OS but problem recurred.
  3. When problem recurred last 2 times, no orange-colored error message came up. I had enabled the Roon Nucleus+ HDMI for diagnostic purposes, per Roon tech’s suggestion. The blue line that moves when there’s music was flat (no music) on the dCS, but moving on the enabled HDMI output.
  4. This suggests to me that the likely glitch exists with Roon’s streaming Qobuz to the network which includes dCS, as the HDMI was putting out signal as described.

Hi @charau,

Noris brought your issue to my attention during our meeting today and I wanted to reach out to you about this. First, I wanted to recap what has been discussed so far:

  • When switching tracks in Qobuz you receive an error and playback stops
  • This only occurs for some Qobuz tracks, not all
  • The same tracks always skip
  • You reinstalled RoonOS with no change
  • This issue doesn’t occur when playing to the HDMI output of the Nucleus

You’ve also shared a few links to other, similar threads. To be clear, this is not something we are seeing a widespread report of. Some of these reports are a little older, from when Roon 1.7 was just released. Around that time there was a brief issue that customers were receiving, but this is not something that has continued to occur. Thousands of Roon users are playing Qobuz content without any issues, so we need to understand what about your setup makes things different.

We’ve reviewed the diagnostics report from your installation and we are seeing that there are some networking errors in the report. Often times these types of issues are networking related, and the report further strengthens this theory.

Moving forward, there are a few things I’d like to suggest that will help us better pinpoint the root of the issue.

  1. We know that playing to the HDMI port works, which narrows things down to Roon communicating with the dCS over the network. To better understand this, I’d like to suggest playing to a remote over the network. On whatever remote device you’re using, enable System Output and start playback of Qobuz content. Does this experience the same issue? Depending on the outcome we will know if it’s specifically the connection between Roon and the dCS or all networked zones.
  2. In the past, we’ve found that changing DNS settings can help improve the performance of streaming content in Roon. If you switch to Cloudflare DNS (or any other similar DNS) is there any change?
  3. I’d like to focus in on your networking setup. As we note in our Networking Guide, managed switches often require some advanced setup in order for Roon’s traffic to properly flow. Can you elaborate on the exact network chain? What device is the Nucleus connected to? Which device is the dCS connected to?

Ultimately, we need to understand where things are failing for you so we can better assist in getting things resolved. I understand that some have reported similar issues, but currently, the number of open issues related to Qobuz is quite small compared to the number of users with Qobuz in Roon.

I don’t say this to discount your report, or to say that there isn’t an issue with Roon, but it is clear that something about your setup is different than the vast majority of users and we need to understand what this is in order to understand the underlying issue. The tests outlined above are definitely where we recommend you start, but if you have any other suggestions about what might make your setup different I’d be happy to present it to our team.

Please see my previous post which starts with “More Information“. As stated there, following a request by Roon tech, I had enabled HDMI output. When the problem recurred, there was no output to the Vivaldi, but there was output to the HDMI output. Going under Roon—Settings—Audio, the small blue bar that detects sound and moves accordingly when there is sound was flat in the ethernet-connected Vivaldi’s output box of the Nucleus, but moving appropriately in the HDMI output box of the Nucleus.
I will investigate your other two suggestions and let you know.
Thank you for your response.

Please let me know if the information I sent in the last post helps you narrow down the issue. Thanks again.

If it is a network issue, why would it not have shown up before 1.7 upgrade?
I’ve had the same network, no changes in settings, for a year.

Hi @charau,

Sometimes certain components of a network experience hardware issue, I’ve seen reports of even enterprise-grade switches fail, so it is not outside the realm of possibility.

This test confirmed that a local endpoint worked as expected with the Nucleus, but now we need to verify if other devices on the network behave as expected. Can you please give @dylan’s suggestion a try?

Sorry, I had initially misunderstood what you meant by playing to another enpoint on the network.
Playing Roon via Nucleus Plus to a separate small integrated unit yielded same result, with the orange letters “This track is not currently available from Qobuz” on 2 separate Qobuz albums early Sunday morning, twice within one hour. Interestingly, the 2nd time, within 30 seconds and despite that warning, the selected track starting playing spontaneously. This had occurred also on rare occasions with the Vivaldi.
As was the case with the Vivaldi, other Qobuz albums played fine; and no problems with any Tidal album, nor playing from the SSD Drive with music files attached to the Roon Nucleus Plus.
Also, wouldn’t you expect the problem to occur with Tidal also, not just Qobuz, if it were due to a network issue?
I appreciate your follow-through and explanations. Thanks!

I see Roon OS 1.7 (v521) was released today. Reading its content and purpose, I’m uncertain whether or not it specifically addresses the issue I’ve mentioned in previous posts above. Could you please let me know if I can expect the issue to resolve because of this update?
Thank you!

Hi @charau,

Apologies for the slight delay in getting back to you, it’s been a bit busy since we released.

As to answer your question, we have made some general improvements to Roon, but I don’t believe we have made any changes that specifically address the issues you are facing.

Is the behavior the same with the new Roon client on your end or is it still the same?

If the behavior is still the same, I would like to focus on this issue when it occurs on your PC’s System Output zone, as this would be the most useful data point. Can you please let me know the exact local time + date + track when this behavior re-occurs on the System Output zone?

Time will tell if the issue recurs, but I’d like to understand your instructions in case it returns.
I’m using iPad (not PC or Mac) as the remote.
System Output Zone appears and can be activated/deactivated on, the Mac.
If Mac is powered on, System Output shows in the iPad but as soon as Mac is shut down or in sleep mode, System Output disappears from the iPad.
I mentioned this in a previous recent post above:
“…playing to a separate small integrated unit yielded same result, with the orange letters “This track is not currently available from Qobuz” on 2 separate Qobuz albums early Sunday morning, twice within one hour. Interestingly, the 2nd time, within 30 seconds and despite that warning, the selected track starting playing spontaneously. This had occurred also on rare occasions with the Vivaldi.” "
Is this what you are looking for?
Sorry, I don’t understand your request. Could you please clarify?
Thank You.

Hi @charau,

Yes, this is the correct behavior. What we are trying to determine here is if the behavior also occurs on System Output on the Mac (the Mac’s speakers) as this will provide the best information for troubleshooting purposes.

It is not clear what you meant in your previous message regarding a “small integrated unit”, but if this is another DAC, it won’t help us much.

To proceed, please reproduce this behavior on your System Output zone on the Mac and let me know the time + date + track the behavior occurs on, once I have this information the logs will hopefully provide much cleaner clues.

I’m not using Mac but iPad as remote, so with the Enabled (but unselected) iPad’s Audio while listening via another RoonReady Device which I have selected under “Zones” (the preamp of a stereo system) and not selecting nor listening to the iPad’s Enabled Audio (iPad’s speakers), how do I do this?
I don’t listen to Roon via the iPad.
Many thanks for your continued instructions.