Qobuz playback sometimes skips after 10-15sec

Core Machine (Operating system/System info/Roon build number)
Roon Core on QNAP NAS (i5 3470T CPU, 16Gb RAM, Roon DB on 250Gb SSD, Music files on 3*6Tb WD Red) or ROCK on NUC7i3/NUC6i5. Latest build of Roon on all devices.
Library of ca 150K local tracks i various formats, ~350 Tidal albums, ~100 Qobuz albums

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Main router Asus RT-N66u, NAS Core on WLAN link, other cores hard wired. One HP Gb switch in mix

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/ect.)
Diverse, Auralic Aries G1 and Femto, Raspberry Pi, AlloUsBridge, SOtM sMS-200

Description Of Issue
Quite often, but not always, my playback of Qobuz tracks skips about 15sec into each song. This seems to happen more frequently with higher rez material.

I dont seem to have an issue with bandwidth, as i have no issues playing back Tidal material, even upsampled to DSD128. And when selecting a Qobuz song for playback, there is almost instant playback, but it often skips after those 10-15seconds.
I have a feeling this is somehow related to the local caching of streaming content, which i assume is happening with Qobuz as well as Tidal?

Hi @Mikael_Ollars,

Just to make sure I understand you correctly here, you’re saying that sometimes the Qobuz track starts at the 10-15 second mark? When this occurs, does the remaining portion of the song play as expected?

If this is the case, I’d like to see if there’s a reason for this jump in the diagnostics, can you please reproduce and let me know the exact local time in your country of when this issue occurs (e.g. 4:29PM) and I can then enable diagnostics for your account?

Thanks,
Noris

Thanks for getting back so quickly!

Qobuz songs have a tendency to start playback perfectly fine (and immediately) but after around 10-15sec the playback is interrupted and Roon starts playing back the next song in the queue. It is also quite common that the playback is interrupted around the same time but continues after a short glitch.
The message from Roon is the “A Qobuz file is loading slowly…”

This happens quite frequently with Roon Radio as it selects Qobuz content.

When i tried to reproduce this i tried some 24-96files from Qobuz and playback stopped at around 10-15seconds. I happened to play a standard redbook file yesterday and it seemed that is stopped playback at around 30seconds. My suspicion is that this sometimes happen when some cache needs to be refilled.

I’ll let you know when this occurs next time, but it’ll be tomorrow, thank you!

Right now this occurs via Roon, but not via Lightning DS. (I am using a Aries Femto, wired)
Time is 23:22 CET

Hello @Mikael_Ollars,

Thanks for letting me know that timestamp, now that I have this information I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active a set of logs will automatically be generated and uploaded to our servers for analysis.

One other thing that I kindly ask here while I review this info, can you please confirm if this behavior occurs across multiple zones or only on the Aries Femto zone?

Thanks,
Noris

Thanks!
I have heard this on my Aries Femto and Aries G1 as well as on my Raspberry Pi 2B with a Sabre ES9038Q2M chip. All of these are hardwired to my router, the Asus N66-U.

Hi @Mikael_Ollars,

Thanks for providing that info. I just checked our diagnostics servers and the report from your QNAP does not seem to be arriving, is the QNAP powered on and connected to the network? Let’s try two things here:

  1. Can you please reboot your QNAP?
  2. Can you use the instructions provided at the end of this article to manually send me the logs from your Core? You can send this as a shared Dropbox/Google Drive or Firefox Send link.

Thanks,
Noris

Hmm, that was weird? I stopped Roon Server on the QNAP, then rebooted the whole NAS. After startup I restarted the Roon Core.
However, the Control on my iPad required me to enter my credentials for my Roon account, and after the wait of about 60 seconds it said I needed to Unauthorize the current server? I tried restarting the Roon. app on my iPad but a new try resulted in the same behavior. So, I clicked the Unauthorize button next to my only running Core and Roon started up. I took a peek in the settings section and I was, as expected, connected to the Core I just Unauthorized…

Anyway, I retrived the log files, sent by PM!

Hi Mike,

Thanks for sending those over. It appears that when you performed the reboot that the diagnostics report came in as well. I am not certain why you were asked to Unauthorize the previous core, but I have created a case for you and have asked our QA team to review the diagnostics for any issues at the timestamp you reported. We will know more once analysis is complete, I appreciate your patience until my request reaches their queue.

Thanks,
Noris

1 Like

Hi @Mikael_Ollars,

I know it’s been a while since we spoke but I wanted to check in here with you to see how things were going. Last week we released Roon build 416, has there by any chance been a change in behavior with the new build?

I recently spoke to the QA team about the diagnostics from your Core and they noted a few networking related traces in them. Can you let me know the following?

  1. Is this issue still occurring in the new build?

  2. Are you having any issues with local library high-resolution streaming (tracks with sample rate higher than 24/96)?

  3. What is the exact network setup like? You mentioned an HP switch, what is the exact model?

  4. How are your DACs connected in this network setup, are all of the Ethernet based ones plugged into the HP switch or are some connected to the switch and others to the router?

  5. Are you experiencing this issue on just the DACs connected via Ethernet or do USB DACs experience this same behavior?

Thanks,
Noris

Thank you for following up on this! :slight_smile:

I have played quite a lot of Qobuz material lately, even before 416 was made available, but this issue seem to have gone away.
Right now playing Qobuz, uppsampled to 24/176.2 with no issues;

I dont have many PCM albums in higher than 24/96 but i do play a lot of DSD64 DoP. I have never had issues with those, not even when upsampling to DSD128, which i do sometimes.


The HP switch is a ProCurve 1400-8G, a non managed version.

I think the schematic above answers this. However, i think that my Aries G1 was connected wirelessly to the Asus Router at the time. The Femto was wired though, through the HP Switch.

When the issue was apparent i don’t think i used anything else than network connected DAC’s… (My QNAP Core, which is mostly used, is a couple of floors below, connected over a wireless 2.4Ghz bridge. Not near my listening space)

I have a suspicion that this might have had one of two reasons;

  1. Qobuz had some issues at the time, resulting in lower than normal bandwidth.
  2. There was disturbance on my 2.4Ghz WLAN channel at the time, from neighbours or whatever.

Any of these issues could result in heavy duplex traffic over my 2.4Ghz link, could this explain the “weird network traffic” that was seen in the logs?

Hi @Mikael_Ollars,

Thanks for sharing that info and also for letting me know that the issue is resolved!

The QA team noted some network instability in general which may have been caused by your second suspicion, but if things are now stable that’s always a good sign :+1:.

I’m going to go ahead and mark this thread as [Solved] since the issue went away, but if if ever comes back please do reach out to me and we can take another look. Thanks!

– Noris

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.