Qobuz Search does not find Albums (that DO exist in Qobuz)

Well, this is annoying:
Occuring on Roon 1.8 (Build 1021)

Go to: Browse > Qobuz > Search Icon (magnifying glass)
Search for: “Bullet Train”

You will see a lot of search results in Roon, but you will NOT see these 2 Albums
Bullet Train (Original Motion Picture Soundtrack)
Bullet Train (Original Motion Picture Score)

Roon will ONLY include those two albums in the Result list if you search for something like “Bullet Train Original”

In the Qobuz Web Player both albums can be found by searching for “Bullet Train” (of course)

I see this as a major bug because this means the Roon search result list for Qobuz is omiting Albums that do exist on Qobuz.

For the fun of it, I tried it myself. I’m experiencing the exact same behavior.

There is already discussion about the Roon search. Search function is still improving. Mabye this will help you.

For kicks, I tried your search, and the results I got included both albums normally! Qobuz is functioning per design on my end.

Cheers,

I also got both albums up when searching.

1 Like

I get both albums as well.

That said, I have sometimes had the experience the OP is describing with other searches.