Qobuz slow on Roon ROCK and playback won't start

Core Machine


Network Details

Glasfiber through Xyzel VMG8825-T50 router.
Intel NUC i3 with Roon ROCK connected direct on the router with ethernet cable
Synology DS214play NAS also direct on router

Audio Devices

Naim Uniti Atom (WiFi)
Bluesound Powernode (Ethernet)
Bluesound Pulse mini (WiFi)
iFi Hip-Dac direct on NUC USB output (Ethernet)

Description of Issue

Qobuz is very slow, nog syncing at times. (The qobuz app works fine… also qobuz on Naim and blue sound works fine) Playback won’t start. RAAT won’t mount. When I disable and then enable the audio device things work again. Until i want to play a Qobuz album the problem reoccurs. It happens on all playback devices. Playback from NAS is no problem unles i tried a Qobuz album. After that NAS won’t play either. I tried several things. Reinstalling ROCK. Resetting router. Different ethernet cable… but nothing solved the problem.

1 Like

4 posts were split to a new topic: Trouble starting Qobuz playback

That i tried to but did not solve my problem

1 Like

I have the same problems, and posted a call last Sunday. We have in common: an Intel NUCi3 with Roon Rock, and a Xyzel VMG8825-T50 router (T-Mobile). The Roon server however is connected to the router via a switch. Directly connecting the Roon server to the router did not solve the problem.
Anyhow: when can we expect to get a reaction from het Roon support team?

1 Like

I too posted a support request. Hope to het a reaction soon. Send the log file with It.
But it is good to know I’m not the only one.
Restarting en resetting the router didn’t solve the problem either. It’s quite frustrating.

Hi @Rene_Bouwman

I enabled diagnostics on your Core and, upon taking a look, I’m seeing a lot of networking errors when communicating with Qobuz.

Can you try setting your router to use Google DNS? Is there any change when doing so?

Just to clarify:

  • Playback works fine with local content
  • When you try to play Qobuz, that device “locks up” and can’t be played to by any content
  • Restarting the device fixes it

Is that correct?


Thanks. I made a google DNS on my router. It’s seems to improve but the problem persists.

Playback of local files is flawless
When trying to play Qobuz that device locks up and cannot play any content anymore
Restarting the device fixes it
Thats all correct


worked a bit more with the Google DNS settings but it doesn’t make a difference really.


Hi Dylan I don’t know what you did but things seem to work again!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.