Qobuz streaming issue

Core Machine (Operating system/System info/Roon build number)

  • Linux
  • Synology NAS DS918+, 8GB RAM, Volume 1 -> 3x 8TB HDD among others for music files,
    Volume 2 -> 256GB SSD (Samsung SSD 860 PRO) for Roon core
  • Roon version 1.7 (build 505)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

  • Core device (Synology NAS DS918+) and Audio output device (Auralic Aries G1)
    are connected to the network via Ethernet
  • Core and output are connected to a Netgear GS108E-300PES switch,
    which is connected to the router FRITZ!Box 6490 Cable
  • Maximum internet speed is 200 Mbit
  • The remote device (iPad Air SW 12.4.3) is connected with the network via WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

  • Auralic Aries G1, connected to the network via Ethernet
  • DAC connected via USB

Description Of Issue

Very often (more than 50% of the trials) the streaming of Qobuz titles is delayed.
On the NAS network monitor you can see that the reception of the data are delayed.
The delay time is very different (from a few seconds until many minutes).
It is not possible to detect any rule regarding the chronological distribution of the delays.

Playing the same titles directly over the Auralic Aries G1 (without Roon) works fine!

Beside the Qobuz streaming issue Roon works fine (latest Roon build).
In the past (older Roon core builds) retrieving meta data were delayed also.

Unfortunately is this above described issue very annoying!
Using Roon together with Qobuz account makes no sense as long as this issue exists!

At the moment I’ve a bellyful of Roon! Hope you can fix this issue!

Hi @Henrik_Schiller,

Welcome to the forum.

This appears to be a managed switch. As per our Networking Best Practices guide, managed switches are a bit trickier to get working with Roon properly, we have often seen “flow control” help in similar situations.

Is there any difference in behavior if you temporarily host the Roon Core on another PC? You can make this switch by creating a Backup of your Roon Database and then downloading the Roon app to the PC, when logging in, choose “Use this PC” option and unauthorize the Synology Core (don’t worry, you can always switch back).

Hi noris,

For testing purpose I’ve removed the Netgear switch. NAS, Auralic Aries G1 and my PC are directly connected to the Fritzbox 6490. The issue is the same!
After this I’ve moved the roon core to the PC as recommended. Same result!

My network setup and the NAS seems not to be the reason for the issue!

Please keep in mind that I never have seen any other network issue with the original setup.
BTW: The issue is existent from the beginning of using Qobuz. increased is only the frequency and the delay times.

Hi @Henrik_Schiller,

Thanks for running those tests, we have eliminated a few variables here. Next, I’d like to take a look at the following:

Does the same behavior occur if you output to your PC’s “System Output” zone? Testing this would allow us to eliminate the Aires as being the problematic piece.

We have seen users have a better experience in the past if they change their DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS.

Can you please give this a try and let me know if it helps?

Hi Noris,

Sorry for the long time delay!
I’ve tested all setups you have recommended with the following results:

The issue doesn’t depends on the output device.
The change of the DNS server was seemingly not successful also, but one day after later the issue was disappeared! After the following two days all was still fine. Then I’ve switched back the core to the Synology NAS which also worked. One week after this I’ve put back the Netgear switch into the setup. Also this was ok. At the end only the change of the DNS server was still active.
For a few weeks the issue was definitely disappeared and I’ve changed nothing more.

Unfortunately today it is the same situation as at the beginning. The issue is back! Streaming of Qobuz content is nearly impossible!
Please consider the setup has not been changed since it was working perfect!
By the way, when I watching the resources monitor of the NAS (RAM, CPU) all seems to be fine. The roon core seems not to be disabled by the NAS (e.g. also DSP sample rate conversion from DSD64 to PCM 384KHz is working fine).
However, all is working fine, except the download from Qobuz. On the other hand, when I use the Auralic Aries G2 app, the Qobuz download works flawless.

Hi @Henrik_Schiller,

Thanks for letting me know and no worries about the delay in getting back.

Just so that you are aware, this NAS does not meet our Minimum Requirements, it looks like it has a Celeron Core and if the library has grew larger since we last spoke, it is possible that you are running into hardware limitations.

I believe it’s best that we troubleshoot this behavior on your PC Core (assuming it meets the Minimum Requirements). Can I please ask you to:

  1. Switch the Roon Core to the PC

  2. Let me know the exact local time + date + track this behavior next occurs for your Auralic Zone?

  3. Let me know the exact local time + date + track this behavior next occurs for your PC’s “System Output” Zone?

  4. Send me a copy of your Roon logs from the PC by using these instructions?

Hi Noris,

Thank you for the quick reply!

I can confirm that my library has grew larger by about 700 albums (complete library about 3TB, 3200 albums, 40000 tracks). But I thought, that after the identification of the albums, it has no big influence on the performance requirements…
However, I’m going to change the roon core hardware anyway, because I want to use it together with HQ-Player and USB output (without auralic aries).
In the next 3-4 weeks the new hardware should be available. The HW setup then is:
Mainboard: Gigabyte GA-Z390I Aorus Pro WIFI
CPU: intel Core i7-9700 8x 3,0GHz
RAM: 32GB DDR4-3000 Corsair 2x16GB
Display adapter: Nvidia GTX1050 TI 4GB GDDR5

This should be enough for roon and HQ-Player!

After the implementation of the new HW I will send you the results and if necessary (issue still exists) the logs and event times.

1 Like

Hi Henrik,

Sounds like a plan, do let me know how it goes.

Hi Noris,

My roon core is now running on a new HW (i7-9700 8x 3,0GHz, 32GB RAM) on Windows 10 Pro. Output is a USB device. Music comes from my Synology NAS or Qobuz. Remote control via FLIRC dongle.
All is working perfectly.
During the installation I would aware that the directory for library backup should not be part of the music directory. Unfortunately this was the case with the “old” configuration at the Synology NAS. Maybe this was the reason for the Issue!? I won’t switch back to the NAS to find out whether it was the reason or not because the SSD of the NAS is removed in the meantime.
However, it would be great if the hint regarding the different root directories for backup and music can be discovered during the backup configuration and not only in the roon knowledge database.
But beside such little things roon is great if it works!
I’m only missing a “real” stop button, because it is really annoying to switch to the queue, press “Clear Upcoming” and then press “Clear All”. Vice versa it is also not necessary to fill the queue (start playing) by pressing 3 buttons.

For now the support request is finished from my side.

Stay healthy!

1 Like

Hi @Henrik_Schiller,

Glad to hear that the new hardware is working as expected and thanks for the feedback here!

If you have a specific feature you’d like to see added to Roon, please make your request known in the feature request section of this forum, our product team keeps an eye on that section for where to take Roon next.

In any case, I will go ahead and mark this support thread as [solved], if you have any further issues just let us know and we can take a look. Stay safe as well!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.