Qobuz streaming issues abound

Core Machine (Operating system/System info/Roon build number)

Mac Pro 2013, Roon 1.7 build 505 stable. MacOS 10.14.3

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi. Built in wifi in Mac Pro. Amplifi mesh wifi (main base station is 12 feet from computer). Internet connection is ATT Fiber - gigabit.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

TEAC UD501 via optical out from Mac Pro

Description Of Issue

I’ll preface this by saying I don’t know if this is your issue or theirs, but I cannot reproduce it in their native Mac desktop app running on the same computer as Roon.

Qobuz (and only Qobuz) stream support continues to be awful. Takes forever to start, if it starts. Tracks end early, and sometimes playback just stops. Sound quality is fine when it’s working, but getting it to work is a nonstop source of frustration.

I also use Tidal via Roon on the same machine and it is perfect. Zero issues, payback starts immediately, no drop outs, etc.

I really like the Qobuz service (especially with the new pricing) and I love Roon - I just wish y’all would play better together…Happy to run diagnostics, etc to try and help you track down and fix this problem.

Thanks,
Brian

@Brian_Breneman -

Do you also have the problem mentioned in these threads?

Yes and no… I have delayed start problems, but it can be as much as 60 seconds before anything happens, not just a few. I also have skipping problems and tracks that don’t finish playing. It isn’t something that is temporal - I can count on it happening almost every time I try to play something on Qobuz via Roon.

See if it helps to set your Qobuz res to CD quality only.
image

Hi @Brian_Breneman,

Can you please check to see if the same behavior occurs on the Mac’s “System Output” zone?

Yes, it definitely does.

unfortunately it doesn’t.

1 Like

Hi @Brian_Breneman ,

Is there any change in behavior if you log out and back into Qobuz? If there is no change, can you note the exact local time + date when this issue next occurs and manually send me a copy of your Roon Logs by using these instructions? The best way to get them over to me would be via Dropbox / Google Drive, but if you don’t have either service please let me know and I can provide alternate upload instructions.

I’m not sure what changed, but after a restart Qobuz is now much more responsive. Nothing has changed on my config, and this is far from the first restart, so I’ll continue to monitor it and see how it goes. Fingers crossed!

Hi @Brian_Breneman,

Thanks for the update here! Hopefully the issues are resolved, but if they are not please do let me know and we can take another look, thanks!

unfortunately not resolved…please check your PM - sent you the logs

1 Like

Hi @Brian_Breneman,

Thanks for sending those logs over. I spoke to the technical team and I have a few further suggestions:

  • As I mentioned in the PM:

I’ve also noticed that you mentioned that you are using WiFi to connect the Core to the network. I know you mentioned that TIDAL works as expected, but again to limit variables connecting via Ethernet would provide the best data point.

  • Also mentioned in the PM:

What I would really like to know is what the trace looks like when you try to send the Qobuz stream to “System Output”, as this would help remove the TEAC from the equation.

  • We have seen users have a better experience in the past if they change their DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS. Can you please give this a try and let me know if it helps?

  • What is your current download/upload internet speeds? You can find this information by going to speedtest.net and running a speed test.

Regarding wifi, I have subsequently migrated the Core to an ethernet connection (about a week ago), with no changes to the Qobuz behavior. Current Speedtest is 870.23 Mbps down, 938.55 Mbps up. This is an ATT Fiber connection.

I have been streaming Tidal all day w/o issue. Just switched to Qobuz to test. Picked an album at random and pushed play. After about 90 seconds, I finally got some music. Logs attached.

Note that I have switched from the TEAC DAC to the PS Audio as a part of re-working my office system. Doesn’t seem to have any effect on Roon.

Stopped the playback, switched to Disc 3 of the same set, and pushed play. Took about 3 minutes this time - gave up on the first track, automatically moved to the second, and finally started playback.

Log send via PM - action starts around 15:39 today, which is near the end of the log.

Hi @Brian_Breneman,

Thanks for sending the new logs, I am taking a look through them and I see that the buffers are not being filled up in time and requests to Qobuz servers are timing out. Did you by any chance give this suggestion a try?

I’ve been using Google DNS for years. The unusual thing is that this is very Qobuz specific, and only within Roon. Using their app directly on the same machine produces zero errors so far, and I also don’t have issues with other streaming services. Do you know if you (Roon) are using a different Qobuz endpoint than their own app uses?

Your description sounds a little different from mine. I had interminable delays in Qobuz tracks starting. But each track would typically play fine once it got started.

For me, it was an IPv6 versus IPv4 issue. Changing DNS servers didn’t really help. Editing /etc/gai.conf to prefer IPv4 addresses did. I have had no further problems with Qobuz after making that change.

That’s interesting - I’m running a Mac and when I run the same nslookup you describe in your post I’m only getting IPV4 address in return. I’m not sure if there is a similar behavior or solution documented on the Mac, but I’m open to trying to reproduce it

Fascinating.

From my Mac:

% nslookup streaming2.qobuz.com
Server:		192.168.0.1
Address:	192.168.0.1#53

Non-authoritative answer:
streaming2.qobuz.com	canonical name = d3ukpcl6kuujlx.cloudfront.net.
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 143.204.160.3
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 143.204.160.44
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 143.204.160.15
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 143.204.160.43

But that’s just the way nslookup is configured on the Mac:

% nslookup -query=aaaa streaming2.qobuz.com
Server:		192.168.0.1
Address:	192.168.0.1#53

Non-authoritative answer:
streaming2.qobuz.com	canonical name = d3ukpcl6kuujlx.cloudfront.net.
d3ukpcl6kuujlx.cloudfront.net	has AAAA address 2600:9000:20ef:d400:a:4c43:3140:93a1
d3ukpcl6kuujlx.cloudfront.net	has AAAA address 2600:9000:20ef:7c00:a:4c43:3140:93a1
d3ukpcl6kuujlx.cloudfront.net	has AAAA address 2600:9000:20ef:c800:a:4c43:3140:93a1
d3ukpcl6kuujlx.cloudfront.net	has AAAA address 2600:9000:20ef:bc00:a:4c43:3140:93a1
d3ukpcl6kuujlx.cloudfront.net	has AAAA address 2600:9000:20ef:2c00:a:4c43:3140:93a1
d3ukpcl6kuujlx.cloudfront.net	has AAAA address 2600:9000:20ef:f000:a:4c43:3140:93a1
d3ukpcl6kuujlx.cloudfront.net	has AAAA address 2600:9000:20ef:a000:a:4c43:3140:93a1
d3ukpcl6kuujlx.cloudfront.net	has AAAA address 2600:9000:20ef:8600:a:4c43:3140:93a1

From my Roon Core machine (Ubuntu 19.10):

$ nslookup streaming2.qobuz.com
Server:		192.168.0.1
Address:	192.168.0.1#53

Non-authoritative answer:
streaming2.qobuz.com	canonical name = d3ukpcl6kuujlx.cloudfront.net.
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 143.204.160.44
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 143.204.160.15
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 143.204.160.43
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 143.204.160.3
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 2600:9000:20ef:f400:a:4c43:3140:93a1
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 2600:9000:20ef:4800:a:4c43:3140:93a1
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 2600:9000:20ef:600:a:4c43:3140:93a1
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 2600:9000:20ef:c000:a:4c43:3140:93a1
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 2600:9000:20ef:8800:a:4c43:3140:93a1
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 2600:9000:20ef:5a00:a:4c43:3140:93a1
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 2600:9000:20ef:de00:a:4c43:3140:93a1
Name:	d3ukpcl6kuujlx.cloudfront.net
Address: 2600:9000:20ef:dc00:a:4c43:3140:93a1

So there’s still no telling whether the Mac prefers the IPv4 or IPv6 addresses. My best suggestion would be to disable IPv6 entirely in SystemPreferences->Network->TCP/IP and see whether that has any effect.

I can’t say for sure that this problem is not related to IPv6, but turning off this functionality on the system is worth a try.

We have seen issues in the past with Technicolor routers and IPv6, I’m can’t say for sure if ATT networks would display the same behavior.

Do let me know if you make any further progress, thanks!

I will try it, but it seems like something at the OS networking level should affect both the Qobuz app and the Roon app equally.