Qobuz streaming latency?

Roon Core Machine

MacMini (late 2012) 16GB RAM.

Networking Gear & Setup Details


Connected Audio Devices

Etherfiber wired to Sonore, SOtM endpoints.

Number of Tracks in Library

Description of Issue

I have issues when steaming Qobuz to my endpoints through Roon. I keep getting a regular message that Qobuz is loading slowly. It then skips to the next track playing when it catches up. I don’t have this latency issue with my library and oddly have never had this issue when I use the Qobuz software directly with the same endpoints through the same network.

I bought a Roon subscription to integrate streaming with my library. I find myself using the Qobuz software more to avoid the frustration but would prefer to use Roon.

Does anyone know of a fix in settings or elsewhere?

Check Roon KB about networking:

Hello @Brian_Haselden,

Thanks so much for letting us know of this. We’d love to help.

As @DanielAvasilichioaei has mentioned, especially since Roon + Qobuz is more bandwidth intensive than Qobuz alone, making sure your network is set up in the best way possible is paramount.

As a test, could you please temporarily lower the streaming quality in Settings → Services → Qobuz?

Also, could you please change your Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS?

Do you see any improvement?

1 Like

This topic was automatically closed after 12 days. New replies are no longer allowed.