Qobuz synchronization broken

Description My Setup

Details on your Core machine (OS, Hardware specs, Roon build)

  • Pinkfaun 2.16X Server, running on Audiolinux, AMD 7 3700 processor, 16GB RAM, 1 HD Samsung SSD 250GB for Roon + 2nd HD Samsung 4TB SSD for local music
  • Roon version 1.8 build: 1021
  • HQPlayer: HQPlayer Embedded 4.31.0

Details on your Remote(s) (OS, Hardware specs, Roon build)

  • iPad Air Pro – 64GB - running iPadOS 15 - Roon version 1.8 build: 1021
  • Samsung S10e – running Android version 12 kernel 4.14.113-23727351 – Roon version 1.8 build: 1021 Wifi 6
  • PC running Windows 11 Home - 11th Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz 2.80 GHz Ram 16GB, Roon version 1.8 build: 1021

Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)

  • Ethernet & Wifi Mesh network (Wifi 6) built on 3 * Asus Zenwifi XT8
  • Connected to Service Provider modem
  • Speedtest connection speed ethernet 93Mbps download – 18Mbps upload
  • Roon Core connected via ethernet, Remote PC connected via ethernet
  • Mobile Remotes connected via Wifi6

Audio devices in use

  • T+A 8 DSD connected to Roon Core, using HQPlayerEmbedded, connected via USB
  • Endpoints : 1 * Cambridge Audio CXN v2 , connected via ethernet

Library details

  • Local library on separate internal 14TB + 12 TB SSD harddisks in Roon Server
  • Qobuz Hi-fi Sublime streaming service
  • 69870 tracks (4662 albums – 2370 local, 2292 Qobuz)

Backup details

  • Location 1 : USB disk connected to Core Machine - 2GB capacity
  • Location 2 : Synology NAS 10,8 TB capacity
  • Location 3 : USB disk connected to Synology NAS - 7,2 TB capacity

The latest synchronization between Qobuz and Roon happened on August 19th. After that no synchronization at all, even when I often tried to force synchronization manually.
Not one album is added to My Library anymore, even not older ones.

When I search for an album favorized in Qobuz, but not added to Roon, I have no problem (in 99% of the cases) searching/finding it in Roon. I can then add this album manually to My Library, by clicking ‘Add To Library’.

So, adding albums starting in roon works fine.
Adding albums from Qobuz via synchronization fails every time.

And yes, I have rebooted everything including router & Roon Server several times, without any positive change in behaviour.

Dirk

I was having high hopes looking at the software release notes of Roon version 1.8 build 1105.

Behaviour is still the same. Everything is working fine except the synchronization from Qobuz to Roon.
As a (repeated) test I favorized this Madonna album in Qobuz:

Roon is not detecting/getting this album in My Library.

2 minutes before I selected the following album in Roon’s New Releases For You’:


and ‘Added’ it to My Library. Done in less then a few seconds.

Can somebody from support please make the effot to look into this?
Thanks in advance
Dirk

Hey @Dirk_De_Taey ,

Sorry to hear that the new update didn’t help in your case. We’ve enabled some additional logging for your account, can you please reboot your Roon Core twice and reproduce the issue, as you’ve done above? Hopefully, this new logging tells us more about what’s going on, thanks!

Hi Noris

I did reboot my server (and as such my Roon core) twice as requested. I had to login a Qobuz as my credentials were lost (which most probably was the intention)

After logging in again at Qobuz, I got back all the albums in My Library but also a spinning wheel on my Qobuz Services

This is now going on for more than 5 minutes, but it finished right now whilst I am typing this.

Looking at My Albums, the albums I favorized in Qobuz still are not added to My Library.

Neither the Madonna album I favorized before, nor the Oasis album I favorized in Qobuz about 5 minutes ago are not added to My Library.

A new ‘Synchronize Library’ execution finished in a mrere 2 seconds or so, without any difference.

Adding a Qobuz album starting in Roon works flawlessly

Thanks for your support

Dirk

Just ot make sure, I favorized another one in Qobuz

And performed a Sync Library Now in Settings-Services-Qobuz.
Unfortunately, problem remains.

Dirk

Important update and partial solution to this problem.

I have performed some additional tests, and came to the following bizarre result:

If I favorize an album in the Qobuz APP (on my windows PC), it is synced and added to My Library.
see the example of the Madonna and the Lisa Batiashvili albums.

If I favorize an album in the Qobuz webplayer, than the album is NOT syncronized and added to My Library. (initial problem).

@support: this is repeatable!!. Feel free to use my account to check for yourselves.

In Qobuz, I do not see any difference whether I favorize an album in either the APP or the website.
If I favorize in the APP, it shows favorized in the Webplayer, and is listed in in My Account- Favorites in the Qobuz account page.
If I favorize in the Webplayer, it shows favorized in the APP and is listed in my account details.

Before I finish this update, another check just to be 200% sure:

In Qobuz webplayer I favorized this Oscar Peterson album

I performed a manual Sync Library Now in Settings -Services - Qobuz.
No album synced to My Library.
Repeated once more. Same result- no album added to My Library.

In my Qobuz account the album is correctly listed with My Favorites:

I logout from the Qobuz Webplayer, and switch to the Qobuz app
After logging in and clicking Favorites in the title bar, I see:
image
The album is clearly added to My Favorites.

Checking once more in Roon, still the album is not synced to My Library.

I now unheart (de-favorize) the Oscar Peterson album in the Qobuz APP:

Album is not in My Qobuz Favorites anymore.
I quit log out) the APP and go check in the Qobuz Webplayer:
Album is not listed in My Acount-My Favorites anymore
image
and in the Download store, the album is not hearted anymore:
image

So for me as a Qobuz user, the Webplayer and the APP are behaving 100% the same.

Last test: I signout again in Qobuz Webplayer, anf login again in the Qobuz APP.
In the APP, I subscribe (heart - favorize) this album again:
image

In Roon, after manual execution of Sync Library Now, there it is:

I.e. To/For Roon there is a difference between Qobuz Webplayer and APP information.

Hopefully, these tests help you to sort out the problem with Qobuz.

Dirk

I agree it is a bit weird. Add an album via the Store heart. Go to Roon. Sync the service. Then go to the Qobuz Tab and My Qobuz and you will see the album there (at least I did when I tried this).

Indeed, I just tested with another album Jude from julian Lennon, and as you said, the album is presented in the Qobuz-My Qobuz tab.

However, it should ALSO be added automatically Added to My Library, and that is not happening.

It does happen when I subscribe to the album in the Qobuz APP.

I have no clue how there can be a difference, but there clearly is )-;

Dirk

My point was that the album might be in Roon, just not under the albums list but under the Qobuz My Favorites tab. Like this…

The circled album has the same issue as you described, not showing up in My Library Albums; but, it is showing up in the Qobuz/MyQobuz tab in Roon. If you had mentioned this point before, I must have missed it in your prior pics.

Thanks for your confirmation that you actually have the same problem as I do.

I have done some extra testing!.

This time I have unauthorized my Linux-based server, and started Roon Core on my Windows 11 PC.
Exactly the same problem.

So, it is an error that is OS-independent (Linux, Windows 11 at the very least).
It is not unique to my account : see previous reply from @Rugby.
It is reproducable in a consistent manner.

Up to you guys.

Dirk

1 Like

Hey @Dirk_De_Taey ,

Thanks for the testing you did here! This is indeed strange behavior, I’ll bring this up with the team.

Does it also fail to show up under My Library → Tracks or Home → Recently Added?

No trace to be found in either Tracks or in Home-Recently Added.
Dirk

1 Like

Hi @Dirk_De_Taey ,

I’m discussing this issue with the team, but I just wanted to confirm if you’re still seeing this in Roon 2.0? Please, do let me know if you are, thanks!

Sorry, not on 2.0 yet. Not supported (yet) by my Pinkfaun server.
Cannot test it on Windows, as I will not be able to use my PC as client with 1.8 anymore.

1 Like