Qobuz: Too many failures

Tried playing a bunch of music from Qobuz. All resulted in too many failures, skipping over each and every track. In the logs, I spotted these entries for the tracks I tried to play.

08/23 12:35:53 Debug: [easyhttp] [20427] GET to https://www.qobuz.com/api.json/0.2/track/getFileUrl?format_id=27&intent=stream&request_sig=2a61259b3603780ec62e4c199262b49a&request_ts=1661258152&track_id=154826674 returned after 815 ms, status code: 503
08/23 12:35:53 Warn: [qobuz] [http] error result from http request: <html><body><h1>503 Service Unavailable</h1>
No server is available to handle this request.

Fixed after restarting the Roon Server software, which I have running on a Nucleus+ (ie. not an actual reboot of the device). Seems suspicious that it works after a restart of the software.

@support: any thoughts?


This may be due to Qobuz, not Roon…

A thread on Reddit suggests that Qobuz has been unavailable for some users over the last day or so.

The macOS (Qobuz) app has stopped working for me completely.

Usually very reliable.

1 Like

Normally I’d agree, but I’m still suspicious. If Qobuz was unavailable, it would be for a period of time, and not something that can be fixed after a restart of the software.

I agree, @Nepherte; thanks!

My post was based on the similarity of symptoms; and the fact that one official Qobuz explanation mirrored them. As though something in a new release (of the software) would obviate the need to restart.

The outage appears to have been fixed now… Akamai CDN has been put forward as a possible cause.

But it’d be great to get Roon working well again with Qobuz whatever the cause.

Hey @Mark_Sealey Thanks for the input and I certainly wouldn’t rule out the possibility that you’ve ushered. Since my issue has been resolved, my intention was merely to bring up a data point, hoping it might help Roon narrow down what the problem might be.

Thanks and glad to hear that I’m not the only one with this issue. I have rebooted twice over the last couple of weeks and that has resolved the issue.

@support Another suspicious thing is that while I had the outage, other Roon users using Qobuz in the same area were unaffected. So I am not too sure this is a regional service outage either.

Hi All,

Thanks for the reports here, as mentioned earlier in the thread we are tracking this behavior in the following thread, we will update the thread here once we have any status updates to share, thanks!