Qobuz Tracks Unavailable in Roon

A number of albums and tracks in Qobuz have become unavailable in Roon, denoted by a red “unavailable” label over the tracks. This is in spite of the fact that I can play the tracks without any issues with the BluOS controller.

I also am having issues with tracks not playing in Roon. When I select them, the album art on my streamer/integrated amp reverts back to another track, and nothing plays.

I am using the NAD M33. All firmware is up to date on the NAD and Roon Rock.

Please advise. Thank you.

If the non playing albums are in your Roon libary check if Qobuz has a new version of the album in their libary. If so remove the old album from your Roon libary and add the new version.

Hello @Kentlands,

Thanks so much for letting us know of the issue you ran into and sorry about the trouble…

The number of albums and tracks in Qobuz that have become unavailable in Roon are they in your Roon library? Are you using the search function to find them, or maybe go on the Qobuz tab?

Could you please share some relevant screenshots as examples?

Could you please try:

  • logging out of Qobuz in Settings → Services
  • rebooting your Roon Core (turning off, unplugging for a few minutes, plugging back in and turning on)
  • logging back into Qobuz in Settings → Services

Thanks in advance :pray:

Hello Rebeka,
Thanks for your help. I’ve uploaded a screenshot of the Mark Knopfler album All the RoadRunning, and the Jazz at the Pawnshop albums. As you can see - all the tracks have a red “unavailable” label in spite of the fact I can play them through either the Qobuz or BluOS apps. When I select one of those tracks to play, Roon looks like it’s playing the track Ii.e., I see a blue histogram of frequencies in the track list, but the track never advances beyond 0:00.

I tried logging out of Qobuz, rebooting the Nuc and logging back into Qobuz - it had no impact.


Hope this helps. Please let me know if you have additional questions.

Playing fine here. Europe. Did you try removing them from your libary and add them again?


That worked for a few albums, but not Jazz at the Pawnshop. The curious thing is that it’s happening with another album, The Order of Time by Valerie June, and when I click on the first track in that album, the Roon app shows the equalizer next to the track, but the track doesn’t actually play or advance. At the same time, the NAD M33 shows the album art and track name of High Life from the Jazz at the Pawnshop album, even though the Valerie June album is showing in the Roon app and the equalizer is playing in the Roon app for that album.

Hope all that makes sense. It seems as if the issue has to do with the NAD M33 given that the album art and track on the M33 display is reverting to another album which is having the same issue.

Thanks