Qobuz: Unexpected error: limiting Roon radio to library (2020-11-07)

Core Machine (Operating system/System info/Roon build number)

MacBook Pro running MacOs 10.15.7.
The MacBook has OS build that has only been used to run Roon version 1.7 (build 667). Nothing else (other than MacOs processes running)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Macbook is wired to the network. There is a TP gigabit switch and the network is controlled by a Synology 2700ac router. The network is very stable, especially when using wired devices. For example, I have NAS devices that never loose connectivity.

I am in the centre of a City with very reliable 200Mb+ broadband download speeds.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mostly I use RaspberryPi controlled devices: IQaudio and HifiBerry too drive amplifiers or passive speakers.

Description Of Issue

I always get the “Unexpected error: limiting roon radio to library” message whenever I try to use a Qobuz track to drive the roon radio. I have reboot everything, disconnected Qobuz and reconnected etc, to try to remove the problem. I see from other similar topics that this problem exists with many users but that sometimes you are able to resolve it.

I use Qobuz all the time and although I would not describe the roon/Qobus connection as stable, it does work most of the time. I have a reasonably substantive local library so library works well with some tracks, but always limited to my local library.

I have tried this, as you suggest elsewhere, using Beatles abbey road.

Help would be very welcome. For example, Is there a separate network channel created when using the radio that I need to enable?

Hi @Neil_Brown1 — Sorry for the trouble here!

Do you have local media? If you start Radio from that content does it work, or do you see the same error?

Can you try starting it from the Beatles album once more and let us know the time that you try this? We’ll enable timestamps and take a look.

Thanks!

I do have local media and I get the same error if I start with a local track or a Qobuz track.

I attempted to run the radio from “Come together” and got the usual error at 1:30am GMT (essentially 4 mins ago) .

In this case it also just jumped around trying and failing to play tracks. I retried and then I restarted roon and ran it again at 1:33. It plays local tracks but again repeats the same error message.

I hope this helps. Neil

Thanks, @Neil_Brown1. We’ve enabled diagnostics and we’ll take a look.

Hi @Neil_Brown1,

Thanks for your patience here while we have had a chance to review logs. Looking over your logs, I am seeing quite a few networking issues.

What kind of switch are you using, what is the exact model? Is this a managed or un-managed switch?

How do you have your DNS servers configured on the router? Are you using Cloudflare DNS, Quad9 or Google DNS?

The switch is an unmanaged TP-Link TL-SG1024D 24 port switch. Just used to connect all the wired connections in the house.

No DNS services are setup as far as I am aware on the router and no other services are used.

Hi @Neil_Brown1,

Can you please try setting one of the above DNS services on your router and verify if that helps?

I used DHCP to deal with the various devices on the network. It does the allocations on my local network. How would replacing this with a DNS service help?

Thanks, Neil

Hi @Neil_Brown1,

DNS and DHCP are two different services, DHCP hands out IP addresses for your local network while DNS translates website names into external IP addresses.

My suggestion here was to verify the DNS servers on your router to ensure that the translation from website name -> IP works properly, as your logs showed quite a few networking errors.

We can also try a Roon reinstall here to see if it will help, I would check the DNS and then give this a try:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Try to verify if the issue happens on a fresh database for a few days
  • Restore from backup created in step 1

Hi Noris,

For some reason I thought that you were saying that you were seeing network errors on my local network. There was no DNS setup on my router so I have installed a DNS. I’ve not created any zones, so it is just the default for now.

I have also re-built my LAN mesh network and I have re-installed and rebuilt the roon database as you suggested above.

I think it is now behaving better - can you tell me if you are still seeing the same issues from your end or if it has removed the network errors?

Thanks, Neil

1 Like

Hi @Neil_Brown1,

Thanks for changing that DNS!

I just took a look at the new log set and it’s looking much better, I’m not seeing the network issues any longer. Have you had any issues over the weekend or has the DNS change resolved them?

I’m still getting the same error occasionally. It seems like if the roon server has been running for a short time it starts to error even if it has not been busy playing musics. I’m still using the rebuilt library.

BTW is it possible to get my playlists back from a backup?

Hi @Neil_Brown1,

Can you please let me know the exact local time + date + track you get the error on next? I would like to activate diagnostics mode after receiving this information.

Yes, once you restore the backup your playlists + edits should re-appear in Roon. Our Backup documentation also provides more details on what exactly is backed up.

I’m getting the same error. Is there a permanent fix in the works?

Hi Paul,

No there doesn’t appear to be a permanent fix. This error has now gone by wiping everything and starting again, but this is just replaced with another error which means that streamed music stops (usually after 2/3 seconds or skips). I really love using Roon - such a shame it’s not reliable with Qobuz.

I think I’m going to see if BluOS is more reliable.

Cheers, Neil

Hi @Neil_Brown1 ,

Sorry to hear that you’re still having issues here, can you please let us know the exact local time + date + track when you next encouter this issue?