Qobuz will not stream [Resolved - Bad Ethernet cable]

Qobuz seems to be having an issue loading all day off Nucleus+. Wondering if it’s just me was working perfectly till this morning. Everything else works fine, Tidal, Roon Radio and personal library.

Thanks in advance as I miss the HIRES audio they offer better.

Have you tried deactivating Qobuz and then reactive again in Roon ? Logging out and in again usually also fix these issues. Restart of Nucleus+ might also be a solution.

Yes I have. And reset a few times. And logged off and back on Qobuz.


I know these sounds weird, but shut down all devices connected to your local network. Restart router, then turn on Nucleus+ and the other devices needed to play music. Did this fix the problem ?

Can try that, did some DNS configuring today and that may have confused the Qobuz streaming for some strange reason.

I think you are pointing to the right thing here. It is often wise to use Google DNS.

On all devices on the network (router, and local DHCP should be configured to use the same DNS).

That’s what I changed today from auto. Reset everything got a Qobuz login error and is working now.

Thanks man!

1 Like

Down again. No idea why it keeps not loading. Everything else works fine.

Did you try the Qobuz app on your Windows 10 (or MacOS) or your mobile device (iPhone/iPad, etc), and see if you see the same issue?

Yes and the Qobuz app works fine.

Finally got it working today, seems like I had a bad cat6 cable and reverted to manual DNS entries.

Thanks to all who replied, much appreciated.