Quiet background crackling noise whenever upsampling in Roon

This has been an issue that I’ve put up with for some time as I’d believed it was a byproduct of using Powerline Adaptors to feed ethernet to my Sonictransporter and switch.
However, last night I finally got round to trying two LPSU-supplied FMCs and a run of fibre optic cable from my Router in place of the Powerline Adaptors. Yet the problem continued!

I notice the faint crackling noise between tracks or in quiet passages of music mid-track, and it seems to be at its worst when upsampling to DSD512, but is still present when upsampling to PCM176,192 or 384. In effect, playing native sample rates pretty much remedies the issue.

I use a Sonictransporter i7 to direct feed a MicroRendu which then feeds a Singxer SU-1 that passes i2s to a Holo Audio Spring (L1) DAC. The ethernet feed to the Sonictransporter is derived from a small 5-port switch which is fed from a Powerline Adaptor local to my Hifi.

Once a track stops playing and I stop browsing in Roon’s Control App, the noise tends to settle down a bit. It is noticeable only when listening with headphones.

I find that the problem is still there when I try a direct USB feed from the MicroRendu to the DAC.

Hopefully this a known issue which has already been resolved elsewhere, but I couldn’t find anything exactly the same amongst the noise issues already covered on the forum. Maybe it’s a problem with the hardware in the chain, but someone may recognise this and be able to solve the mystery.

Hi Dave

I gave my old man (dad) my sonicT i7 and he was having all sorts of dramas up-sampling to DSD512, including what you’re seeing/hearing. After a long period of denial, I eventually realised the root cause was the powerline adapters.

I assume getting someone to hardware ethernet is out of the question, in which case can you try a WiFi mesh system? A local shop that offers returns with full refunds would be ideal, if it doesn’t work for you with DSD512?

Real-time DSD512 up-sampling stresses everything from the Roon Core, to the network, to the endpoint, to the DAC input etc etc.

There was very little to adjust/tweak/configure with the top of the line TP-Link powerline adapters I got for my old man’s setup, so unfortunately I can’t offer advice on things to try.

Maybe support or someone else can offer advice. But the hardwire route or WiFi Mesh system would be my recommendation based on my experiences.

What are you using for your I2S cable and how long is it?

Hi. First of all, thanks for the input, Sean.
I would have expected the use of a fibre network feed to the switch direct from the router (as trialled last night) should have solved the problem, but it made zero difference. Maybe I should look at the WiFi option though (we get about 40MB/s download speed at our home).

Joel, it’s a Supra screened HDMI which is 0.5m long, but I get the same issue when I connect the MicroRendu to the DAC via a solid USB A to USB B adaptor, i.e. with the Singxer and i2s taken out of the chain.

I do suspect it’s related to CPU workload, but the ST i7 is supposedly designed specifically to cope with upsampling in Roon!
It’s not going to be cheap or easy to test another streamer is it. Maybe I should look into a ‘home audition’ option, but l’d need a NAS to trial a conventional streamer. :thinking:

The only other thing that I can think of is whether or not you have enough headroom (in conjunction with your up-sampling). That’s an easy test at least.

Hi Joel,
I noticed that upsampling to DSD128 or PCM192 (so comparatively very little workload) was stillenough to cause the issue, and I know from past experience of a Mac Mini using a similar CPU that an i7 should be good for upsampling up to DSD256. Maybe SGC sold me a dud all along and I’ve been blaming the Powerline Adaptors?!
One thing I haven’t tried is connecting the ST i7 to the MicroRendu via the switch (I’ve always used the direct bridge), so I’ll test that tonight to see if it makes any difference. Alas, I don’t have another DAC to try and therefore eliminate that component as a possible cause.

Sorry Dave, when referring to headroom, I meant the following, not CPU headroom:

and also:

Oh… duh! Sorry, should’ve realised!

I’ll try it later on a setting lower than the current -3dB setting then. Worth a try :+1:t2:

Oh, just remembered! I had trouble with my Holo Spring (L3) at the highest sample rates until I restricted output to 24 bits! (default is 32 bits)

1 Like


1 Like

It was probably the USB output from my RPi… :wink:

Ok Joel, that sounds like it could be the answer so I’ll try that first. Is the 24 bit limit set featured in DSP?


No, it’s in device setup, under advanced settings:

OK, thanks Joel.

Well, headroom and 24-bit limiting had no effect, neither did feeding the MicroRendu via the switch - as opposed to using the STi7’s direct bridge feature.

But I found that disabling all DSP addresses the problem!

Does this mean my ST is struggling with all but the easiest of tasks? If so, it indeed suggests I’ve been sold a dud and I’ll need to get the cover off to see if I can confirm the processor is actually what I thought it was.

It’s been like this for over a year so the warranty is probably expired :neutral_face:

Highly unlikely, I have the same sonicT i7 (i7 - 7700 ) running both Roon Server and the more CPU intensive HQP Embedded for DSD512 upsampling…

You can whip the top (or bottom) off to double check but SGC (and Vortexbox) have been doing this for a long time and have a great reputation.

What’s your processing rate when up-sampling to DSD512 btw? ~2.5 ?

Can you share a screenshot of your Roon signal path?

I agree that it’s unlikely and Andrew Gillis has been nothing but a great help whenever I’ve had any queries.

I’ll check tomorrow and report back as I’m overdue hitting the sack! Cheers.

Hi Sean,

Processing rate also 2.5x…

Hi Dave, that rules out the sonicT i7 being short of power.

What’s the distance between your sonicT i7 and your microRendu?

Is it possible to buy a really long ethernet cable to connect your sonicT i7 to your Rendu?

I know it seems like a waste of money just for a quick test but it would confirm if it’s the powerline adapters that are the issue (or not)…

The longest I have is a 3 or 4 metre STP cable somewhere in the spare room - I’ll try it tonight.

I currently use a 1 metre Meicord Opal UTP, but the use of screened or unscreened ethernet cable made no difference to the problem when I tried it.

Just wish my amp had a digital input to at least eliminate the Holo Audio DAC from the investigation.