Radio is being limited to library

(Scott Seiler) #1

Good afternoon. I have been experiencing the same problem over the course of several days. For instance I would select Jazz as a genre and select Roon Radio, it would return the same errors, either limiting it to my library or saying there’s nothing to play. What I found was that it only occurred for me with the Roon application on my Samsung Galaxy 8. I removed and reinstalled the app and the problem hasn’t arisen since. I’ve attached a picture of the error message here. Hope that helps!

Roon radio: unexpected error: Error Limiting to Library
(Scott Seiler) #2

And for what it’s worth I’m running a Mac Mini Core on AT&T fiber connected to a Google Mesh network.

(Noris) #4

Hi @Scott_Seiler,

Just to clarify, this issue occurred only on your Galaxy 8 and only with the Jazz genre? From another remote or from the Core itself, this behavior was not present? Did other genres work properly from the same Roon remote?

Thanks,
Noris

(Scott Seiler) #5

Hello! The issue occurred several times across genres but I’ve only noticed it when using my Galaxy as a remote. In each instance I either picked a band or genre and tried to start Roon Radio from it. In one case it told me there was nothing to play (I tried to start a Radio for Blues) and the other cases it displayed that it could only play from my library. I didn’t try to replicate it from the Core, so my only experience with this issue was from the Galaxy 8 (although I did try and play it to several different endpoints). Thanks!

PS - I haven’t experienced it again since reinstalling the Roon app.

(Scott Seiler) #6

Aannnd just as I hit reply it happened again, albeit slightly different this time. From my Galaxy 8 I selected R.E.M, of which I have a large local collection. I click on the artist page and select Roon Radio and it returns a message “Nothing Similar to Play!”. I’ve attached the screenshot.

Thanks!

(Noris) #7

Hi @Scott_Seiler,

Thanks for sharing that screenshot. I have tried to reproduce this behavior on my end but R.E.M is starting fine off of Radio. What is your Core’s model/manufacturer and operating system?

When this issue occurs on your Galaxy, can you please check to see if the same behavior is also occurring on your Core?

Also, if you have not done so yet, can you try rebooting the Core to see if that changes anything?

– Noris

(Scott Seiler) #8

Thanks for checking. I’m running an Apple - Mac mini - Intel Core i5 (2.6GHz) - 8GB Memory - 1TB HD as my Core. It’s running the latest Apple OS (I updated it a few weeks ago and it rebooted then). It’s connected to a G-Technology G-Drive Mobile 4TB hard drive that stores all my music. I have the system dedicated as a Core so nothing else runs on it. I’ll see if I can replicate the issue again on the S8 and then see if it happens on the Core too. I can reboot it as well.

Thanks!

(Scott Seiler) #9

So I tried replicating the issue with a few searches and requests to start Roon Radio but was unable to replicate the issue. I’ll keep an eye on it and revert with any issues.

Thanks!

2 Likes