Radio limited to Tag


I am trying to figure out if it is possible to limit the radio to the album grouped in a given tag.
To explain bit more what I am trying to achieve, I have two different zones for Roon, the main zone is using a Devialet 250Pro and the other one (headphones) is using a Brooklyn DAC capable of playing MQA.
So for each Tidal Album I have the the MQA and the normal FLAC version. The MQA is for headphones, the normal for the Devialet. The normal FLAC is set to be the primary one and the “Show hidden tracks and album” setting is OFF so I am sure that if I play a song on the Devialet it will always play the primary one that is not the MQA, this turned out to work fine with Radio too.
Also I have tagged all my MQA albums with the Tag “MQA”. Now I can Focus and see all the MQA albums using the Focus function using “MQA” (name of the tag) and “Duplicates”.

Now I was hoping that starting the radio from this Focus set-up the radio would have limited the choice only to the album that are filtered by the Focus, however this doesn’t seem to be the case. Any suggestion on how to achieve this? If this is not possible perhaps this is a new feature that can be added in the future of Radio?


If you wish track selection limited to only the tracks in focus then use Shuffle Play rather than Radio.

Hi @Carl,

I am not sure how this should work. If I press shuffle it says Radio: Nothing Similar to Play! If I press Raodio it starts playing but then goes to the normal Flac at the second song.
What I am doing wrong?

I think I got it, You were referring to the tracks in Focus not the album in Focus.
That works, but there is no way to show the duplicates under tracks (the inspector functions are very limited for tracks compared to albums). As all my MQA are duplicates (apart 3 albums) I cannot see al the tracks but only the ones of the above mentioned albums.

Last Edit… Turning on “Show hidden tracks and album”, then going to tracks and setting the tag fix the issue of showing all the songs under the Tag, however shuffle only keeps playing the one that have no duplicates.

No idea what I am doing wrong



Hi again,
Try this alternative:

  • Goto the album browser
  • Click the tag filter
  • Click on MQA tag (I’m assuming you have tagged all your Tidal MQA albums).
  • Roon should now be displaying only your tagged MQA albums.
  • Now click shuffle.

I’ve just followed this procedure and Roon is now playing though the MQA tracks in my collection.

Hi @Carl I tried to do as you suggested but it doesn’t work. I think the issue is that I have duplicated albums that are not the primary album and for some reason Roon is skipping them. It doesn’t matter if the “Hidden Tracks” is on or off. It keeps playing only the 3 albums that I are not duplicate.

Let’s tag @support for comment.