Radio Paradise FLAC stream not working?

Not sure when it started, but the Radio Paradise FLAC feed seems not to work anymore. My RP link shows it as the default stream, but playing the station always plays AAC 320k. It’s nice to have song metadata back again, but I can’t seem to get the FLAC stream to play anymore.

Ahh, it looks like they have stopped the internal redirection.
I’ve added the main FLAC stream back again.

Please try that, and I’ll try and deal with the others.

It still seems to revert to AAC fire me. The FLAC link was updated, it just won’t play

?? It’s playing for me.

Try a re-sync. The little blue circle top left in overview screen

Right, I’ve updated all RP streams to be the official ones again. (There was a problem a couple of months ago)

I’ve tested them and they work OK for me.

How about you now?

Working now. Thanks!

My version of Roon has been unable to play the RP Flac stream for a couple days. It always reverts to the 320k AAC stream. I’ve tried clicking directly on the Flac stream link in the Radio Station listing, but it still goes to the lower quality one.

These are working for me:

Seems ok here. Let me look further.

@David_Roberts Can you play other flac streams ok? (Search for flac)

And now it’s working again. Not sure what the issue was…

Ok. Thanks for letting me know.

A half hour after I sent that, I ended up having the same problem again. I thought it was because I was using an iOS client, then decided it was more likely some cached address problem when my MacBook had the same issue. I restarted the RoonServer app on my core (mac mini) and all my clients seem to be doing it right again. The Windows client worked when I sent the reply above, so I just assumed all clients would work. But I think there might still be some rare oddity in how cache-ing of station addresses works. From now on I’ll just restart the core if I see this problem.

I’ve also experienced intermittent use of the AAC stream by Roon for the Main and Eclectic streams. Sometimes I’ve been able to revert to the FLAC stream (which is set to default) by clicking on the play icon next to the stream.

Radio Paradise FLAC stream is working fine for me here in the UK.

The Roon integration of Radio Paradise is very basic though (apart from the availability of a FLAC stream so better than Sonos). There is so much more to RP than the stream (skipping, rating, listening history, great track metadata, sharing tracks and adding tracks to streaming library’s) and it would be nice to see them in Roon. BlueOS does a half decent job. Who should we petition for this, Roon Labs or Radio Paradise?

The RP features that depend on using their own player are unlikely to make it into Roon. The devs are reluctant to spend development resources on an idiosyncratic format supported by a single Internet Radio station.

The example of Radio Bluesflac, however, shows that metadata usable by Roon can be attached to a FLAC stream. At the moment RP FLAC streams do not have metadata but they say they would do it if they could. The metadata seems to be added as “icy-metadata” which is supported by Rocket Server used by Bluesflac.

I have posted on the RP Forum and BillG is looking into it.

1 Like

Very interesting, thanks for the reply.

Are you familiar with BluOS(Bluesound/NAD) integration of RP? If not, if you can check it out, it’s excellent but I would have thought RP/Roon collaboration could come up with something even better. I know it’s only one internet radio station, but it is a very popular one amongst Roon users by the look of it. It includes track metadata and track skipping plus it has the ability to sync its playback with RP’s website.

Suddenly, I can’t stream flac stations from Radio Paradise. Just wondering if anyone else having issues. Thanks

All 4 working here in uk

All OK here (UK also). Checked their forum and no-one complaining there.

What about other flac streams? (Search for “flac”)