Radio plays Artist even though it's marked "do not"

How do I mark an Artist so that the Radio won’t play them?


2 posts were merged into an existing topic: Roon Radio: Option to ban artists completely

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.