Radio Stream stops at random times during playback

Core Machine (Operating system/System info/Roon build number)

Nucleus 1.7 Build 610 OS Version 1.0 Build 227

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Cisco Meraki Router and Switch all wired no wireless

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Meridian 251 version 1.1

Description Of Issue

We use this as an office streamer running a radio station all day long. It will at random times just disconnect. Itnever seems to run more than an hour or so without a disconnection

Hey @David_Vranicar,

Thanks for reaching out!

Which radio station does the issue occur on - does it impact multiple radio stations or just one in particular?

If you try to leave another zone running on the same station, does the issue occur on the other zone at the same time as the issue occurs on the Meridian zone?

I only run WXRT but when it happens it doesn’t just disconnect the source completely goes away.

I only have this zone connected but I can try something else if needed

Hi @David_Vranicar,

That sounds strange, maybe this is device related.

Yes, please try another zone as well. If you don’t have any easily accessible, you can try to connect the HDMI output from the Nucleus to a TV/AVR as a test and use the HDMI zone.

@noris This would appear to be a Nucleus issue. The 251 would not show up as an audio device,so I tried a second unit. It would not connect either. I disconnected from the Nucleus and used the PC as the server and it has worked flawlessly

Hi @David_Vranicar,

That’s strange, I thought that the issue was with the 251 stopping randomly during playback, not that it doesn’t show up at all.

Are you saying that the 251 did operate properly in the past but is now failing to show up? Are the Nucleus and 251 on the same subnet?

Yes this is the case

Hi @David_Vranicar,

That is very strange in that case. If you try to temporarily host the Roon Core on a PC, does the Meridian fail to show up there as well?

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

yes I did this and it sees the unit and connects without an issue

Hi @David_Vranicar,

Thanks for checking this is strange in that case…
Do you see any devices in Roon Settings -> Audio when using the Nucleus Core?
Can you please share a screenshot of your Roon Settings -> Audio tab?

Here are pictures of both versions

Hi @David_Vranicar,

Thanks for those screenshots! It looks like you are still seeing some devices there, so that’s good.

Have you tried a reboot of the Meridian Zone yet? I would see if this and a reboot via the Nucleus WebUI helps clear things up:

Can you provide some more details on how the Nucleus and Meridian fit into this, are they both plugged into the Meraki switch?

If you try to temporarily connect the Nucleus and 251 to the router instead of the switch, do you see the same issue occurring?

Hard rebooted the Meridian and rebooted Nucleus from the web interface. Same result

Hi @David_Vranicar,

Can you please share a screenshot of your Nucleus Web UI?

Is there any change in behavior if you try to toggle IGMP Snooping / Proxying settings on your network configuration? These settings have sometimes helped when there are discovery issues with multicast.

If you have a fully un-managed network, that would be an even better test.

Well that changing IGMP Snooping allowed the meridian to be found again. However we still have an issue that when using the Nucleus we lose radio and then even when we try a playlist of any type it looks to play but does not have audio . It can only be corrected by rebooting the Nucleus

1 Like

Hi @David_Vranicar,

Happy to hear the IGMP Snooping setting helped!

Does it happen with multiple zones or just the Meridian?
Can you try to output to the PC’s internal speakers but keep the Nucleus as the Core?

Yes this definitely looks like a Meridian only issue

1 Like

Hi @David_Vranicar,

Thanks for confirming!

Since the Meridian is the only device impacted and it was failing to show up previously as well, I suspect that having the managed network is causing some kind of interaction where multicast briefly stops working properly and the Meridian stops playback.

Can you try both Nucleus and Meridian on an unmanaged switch?

We are still having issues but it seems to be network related.

Is there a best practices for meraki and roon

Hi @David_Vranicar,

You can find our networking best practices guide here:

We don’t have anything specific for Meraki, but we have the following suggestions for Managed Switches:

Managed Switches

Managed switches can be very robust, but they are often designed for professional installation, so in many cases the out-of-box configuration is not right. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. If in doubt about any of this, try temporarily replacing your managed switch with a “dumb” switch to see if things improve.