Random dropping of connection to roon core resloved by rolling back to Debian 9

Single use case here, I’d been having a spot of trouble recently with random disconnects from my roon core running on Debian 10. I assume this started when I did an upgrade from 9 to 10, sometime in the past month. I tried a fresh install of 10…same result. Tried a fresh install of 9 and it’s been running smoothly for the last day or so.

Hopefully this is of some benefit…


Mikrotik RB750Gr3


UniFi AP-Pro
Board Revision

Host Machine:

Debian 9 VM running on Unraid

System: Host: Roon4 Kernel: 4.9.0-12-amd64 x86_64 (64 bit gcc: 6.3.0)
Desktop: N/A Distro: Debian GNU/Linux 9 (stretch)

Machine: Device: qemu System: QEMU product: Standard PC (Q35 + ICH9 2009) v: pc-q35-4.2
Mobo: N/A model: N/A
UEFI: EFI Development Kit II / OVMF v: 0.0.0 date: 02/06/2015

CPU: Quad core Intel Core i5-3570K (-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3) bmips: 27192
clock speeds: max: 3399 MHz 1: 3399 MHz 2: 3399 MHz 3: 3399 MHz
4: 3399 MHz

Graphics: Card: Red Hat QXL paravirtual graphic card bus-ID: 00:01.0
Display Server: N/A driver: N/A
tty size: 87x41 Advanced Data: N/A for root

Network: Card: Red Hat Virtio network device
driver: virtio-pci v: 1 bus-ID: 02:00.0
IF: enp2s0 state: up speed: -1 duplex: unknown mac:

Drives: HDD Total Size: 128.8GB (13.8% used)
ID-1: /dev/vda model: N/A size: 128.8GB

Partition: ID-1: / size: 110G used: 9.0G (9%) fs: ext4 dev: /dev/vda2
ID-2: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/vda3

Sensors: None detected - is lm-sensors installed and configured?

Info: Processes: 106 Uptime: 1 day Memory: 2133.7/7985.0MB
Init: systemd runlevel: 5 Gcc sys: N/A Client: Shell (sudo) inxi: 2.3.5