Random Music Stoppage

I am able to play music with my NUC 54250 + 2012 Essentials + Experience +Media Pack.

I am having an issue where music just stops playing. If I close Roon, and re-open, then the music plays. Then a random time later, music stops again. Close-Open and music plays.

I have looked through the logs and the last entries are:

05/18 14:57:01 Trace: [library] finished with 931 dirty tracks 56 dirty albums 3 dirty performers 61 dirty works 1 dirty performances 2 dirty creditroles 0 clumping tracks, 0 compute tracks, 0 deleted tracks, 1 tracks to (re)load, 0 tracks to retain, and 66 changed objects
05/18 14:57:01 Trace: [library] endmutation in 16ms
05/18 14:57:01 Trace: [analysis] analyzing trackid=5203250 url=\xxxxxxxxxxxx\MusicServerStorage\Music 2013 WAV #1\George Frederick Handel\2008 – Handel; Twelve Grand Concertos, Disc 2\Disc 2 – 15 – Concerto Grosso in C minor, Op.6-8, HWV 326; 5. Siciliana. Andante.flac
05/18 14:57:02 Info: [library] recorded play for profile 1a137930-d76a-4ecf-98d8-0bc312127803: mediaid=50:1:6c787a10-988c-4722-8a14-df928603450b metadataid=123:0:MT0006744619 contentid= libraryid=50:1:6c787a10-988c-4722-8a14-df928603450b
05/18 14:57:02 Info:
–[ AudioPath ]---------------------------------------------
AudioPath Quality = Inactive

05/18 14:57:02 Trace: [library] finished with 54 dirty tracks 5 dirty albums 1 dirty performers 54 dirty works 1 dirty performances 0 clumping tracks, 0 compute tracks, 0 deleted tracks, 0 tracks to (re)load, 0 tracks to retain, and 5 changed objects

FYI I was playing a completely different song than the last log entry.

Hey Dan, followed up with you via email so you can send me your logs there, these lines are irrelevant. Thanks!

Logs sent… 2nd single log file sent 10 min later - Log file from last stoppage to newest stoppage.

I have this also. I am also using a NUC, but with Windows 8.1.

@kevin, @brian has a recent log, and there are also some here:


I’m happy to send logs every time, but I’ll be busy doing that…

I am getting them every 5-7 mins like clockwork. First, I thought it might be SplashTop, nope - but Splashtop is great as you can start Roon remotely without getting an OpenGL error, and it can use remote resolution - even on an iPad.

Here are most recent stoppages and times - see the 5-7 min window…

3:53 - 3:59
4:04 - 4:10
4:10 - 4:15
4:25 - 4:30

I have sent logs too.

@kevin, just sent another log.

In an effort to try to solve my music stoppage, I am now trying to connect and run with a Roon Remote.

I cannot connect to Roon Core with Roon Remote. I can RDP to the Roon Core Server, I can map a drive, it show up in Network on Remote Machine. From Core I can RDP to the Remote PC and RDP back to the Remote PC, I can map a drive back to the Remote PC. Just cannot connect Roon Remote to Roon Core. (I am going to try another machine after this)

Here is what is going on in the log:

05/19 11:30:04 Info: [brokerclient] connecting to xxxxxxxxxx (71cc0a7f-14c4-4b9a-95cb-c559237d93b5) @ (attempt 1/6)
05/19 11:30:04 Info: [distributedbroker] FOUND BROKER xxxxxxxxxx (71cc0a7f-14c4-4b9a-95cb-c559237d93b5)
05/19 11:30:04 Debug: render area size changed value: 1280x698
05/19 11:30:04 Debug: render area size changed value: 1280x698
05/19 11:30:06 Warn: FRAME TOOK TOO LONG TO DRAW: 60
05/19 11:30:06 Debug: frame59: 10 renbuffers, 10 drawelements, 194 quads, 10 fills, 776 vertexes, 7 textures, 7 wraps, 8 smooths, 7 premultiplied, 0 scissors
05/19 11:30:18 Info: [stats] 397mb Virtual, 117mb Physical, 11mb Managed, 920 Handles, 43 Threads
05/19 11:30:25 Trace: [brokerclient] connect error: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 1xx.xx.xx.xx:49185

Core 2012R2 Essentials, Remote Win 7 Pro.

I fixed the connection issue. Ran Phil’s (@AudioPhil) AO and that took care of it.

So I now have the timer running and playing music but doing it via Remote Roon. Let me see if I still get the stoppages every 5-7 Minutes.

Okay, test done. Music still stops every 5-7 Minutes no matter if I am using RDP into Core and playing music, or using Remote Roon to play music.

Also tried the 2012 Essentials as a Remote Roon with a Win 7 PC on the network as the Core. Music still stopped on 2012 every 5-7 min. Played music on the Win 7 PC (Core) and it played with no issues for 15 min.

So something with 2012.

Check all the services that are running making sure there were no Updater Services running - nope.

May have to bite the bullet and install Win 8.1…

Update: When the music stops, Roon is still active in Task Mgr. Runs about 25% Util and was seeing memory go up and down.

Before I had closed Roon, re-opened, and music played. This time, I just moved the slider ahead a little bit and music started to play again.


I have solved my music playback stoppage every 5-7 min. I “unchecked” USE EXCLUSIVE MODE for my Wadia Di122 Wasapi Driver. I have played songs for 15 min straight, and even played songs from Tidal with no stoppage issues at all.

So for now I will run without exclusive mode selected.

---->>> NOTE: While this issue is solved for continuous playback the SQ is worse with this unchecked (as we all know). So for now I will wait for a fix but be able to enjoy continuous music playback while browsing.

2012R2 - Essentials (Trial Version) - Experience - Media Pack - Audio Optimizer 1.31B10 (@Audio-Phil is the author - need to run this in order for Remote Clients to be able to see Core on 2012) - Schitt Audio Wyrd - Wadia Di122 DAC

I have also posted in the “Windows Server 2012 R2” thread how I got all my Roon issues resolved

I have the same issue even if I don’t use the “WASAPI” Zone. It’s enough if I configure the WASAPI exclusive mode, disable the WASAPI zone and use later the ASIO zone.
After the exclusive mode is unchecked all works O.K. again. I use Windows 8.1

All my issues were fixed with later releases. I can run Exclusive with Wasapi or ASIO now with little or no issues.

No, it is not. I can reproduce it and I use the build 30.