Random playback stopping

Roon Server Machine

Linux ROON-OptiPlex-7020 5.15.0-76-generic #83-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux; Intel(R) Core™ i5-4590 CPU @ 3.30GHz; 8GB DDR3 1333 MHz RAM; Local files stored on QNAP NAS

Networking Gear & Setup Details

mikrotik running RouterOS v6.49.2 using capMAN with numerous AP, but RoonServer, NAS, is all on wired Ethernet

Connected Audio Devices

  • iMac (has both remote and roon bridge) connected via USB => DAC => Amplifier

Also have other 2 channel hifi system and sonos enabled in audio devices. Issue also occurs driving Sonos, but I have experience with Roon-Sonos that I’m not even worrying about those for the moment.

Number of Tracks in Library

38,000+ tracks

Description of Issue

Playback randomly stops. Sometimes apx 1/2 into a song. Other times seemingly at time that crossfade would kick in. Other times everything works as it should. It is random so hard to re-create on demand.

I’m on my last day of trial, set to subscribe for an annual subscription - and this issue just popped up now. I also note, that the remotes are more sluggish in displaying queues or images, etc as of late - the two seem to be connected.

I’ve rebooted the server/remotes/computers. I’m not sure where to begin to troubleshooting this. It happened again and the audio zone disappeared as interface is asking for selecting an audio zone.

[update 1] Perhaps it’s related to me installing Roon Bridge on the Mac as that is perhaps coinciding with this changed behaviour. I installed Bridge, so the endpoint would work without having the Roon GUI up and running.

[update 2] Stopping still, after stopping Roon Bridge. If I’m looking at the remote app on phone when it stops it gives notice, “waiting on roon server” then connects again. Pressing play will resume playback.

Is there something to tweak in my roon server? I’m running Linux Mint xfce (the very light weight minimalist version of Mint designed to run on older/lighter hardware).

Hi @RTNT,

Thank you for your post and the level of detail provided. The team would like to activate and request diagnostics from your RoonServer instance.

Are you able to reproduce this problem and provide us with an approximate timestamp, or the name of a track that failed to play? If you encounter this during cross-fade, then please list the sample rate, file type, and bit-depth of each track.

Thank you!

Hi - thank you for response. I’ve been away on a short trip, will have time over next couple days to listen again. Will monitor and report upon next occurrence the timestamp and name of track.

Hi @connor OK, just had it reoccur after playing about 4-5 songs.
It failed at apx 12:34 (Central time) Jan 6, track that was playing that was interrupted was Courage by Celine Dion (don’t judge, that was Roon Radio autoplay :slight_smile: )

I saw my remote (mobile Android app) flash up about selecting Audio Zone.

This occured playing to this specific audio zone: Peachtree-HiFi (this is an iMac, with wired ethernet, connected via USB cable to DAC => Amplifier). Earlier was playing live internet radio for sometime to Sonos grouped speakers, did not have an interruption.

Let me know if you need me to gather log files. I’ve since initial posting purchased a one month subscription in hopes to sort this issue out before purchasing an annual subscription which was my initial plan.

[Update] again at 14:04 playing Batonga by Santana, et al. After playing a full album without issue.

[Update 2]: Another example 17:43 playing Folsom Prison Blues by Johnny Cash, it stopped twice within the 2:42 song!

[Update 3]: Stopped 3 times in one track at 12:18 ish (Eric Clapton either Kerry or After Midnight).

1 Like

Hi @RTNT,

We’re working with you on a separate issue in a related thread; be sure to reset your system between troubleshooting steps, or test sequentially, so we can keep track of what we’re investigating.

Diagnostic events around the timestamps you’ve submitted show timeouts with Tidal. These are accumulating to the point that the prebuffer fails. Do you have any filtering in place in your upstream connection (VPNs, router security settings, network firewalls, etc. can all introduce a problem here)?

The content you’ve attempted to play in the above scenarios appears to have mostly been higher resolution. Can you reproduce this issue playing 16/44 Flac files from Tidal, as well?

For the moment, I recommend unplugging and turning off all your Sonos gear and troubleshooting with the dedicated endpoint in question. SonosNET will remain active with any hardwired S1 or S2 firmware Sonos device - it’s best to eliminate this variable entirely.

No, there’s no upstream filtering/router settings/etc.

The error did not happen during my listening session today of ~4 hours, so have not been able to check the lower res files. That’s the challenge with random problems. Would it be equally relevant to check if this happens playing only local files?

Hi @RTNT,

This test would eliminate the upstream component - the prebuffer would originate in your RoonServer, rather than outside the LAN.

It’s certainly worth performing this test to eliminate any network snags in the LAN, but we don’t have evidence so far that you’re intranet settings or topology are at fault here. Here’s what I recommend - temporarily log out of Tidal and then initiate a Roon Radio session from any local track, playing to the Peachtree endpoint. If you encounter a playback stoppage under these conditions, please let us know the name of the track that was playing.

Next, try an inversion of the same test. Log back into Tidal and any other streaming services. In Roon → Settings → Storage, disable your Watched Folder locations temporarily (note that Roon will reanalyze your library when you reactivate them). Then, initiate a Roon Radio session and let it spin only Tidal content to the Peachtree until you reproduce an error.

Additionally, what is the Resync Delay value for the Peachtree DAC? This will be under Device Setup (gear icon) in Roon → Settings → Audio. This value will be the time allotted (ms) for the prebuffer to accommodate file type changes during queued playback. I’d try all of the above tests with the value set to 9ms.

ok, 7 hours of listening with Tidal disabled no interruption to playback.

will try inverse setup soon.

About 5 hours with only Tidal running, local folders disabled. No interruption. So can’t recreate the what used to be frequent errors!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.