Random popping noises on Tidal tracks

Every once in a while, a Tidal stream starts producing irregular digital popping sounds. The popping sounds are quiet enough to just barely be noticeable through my fairly resolving hifi system: Revel F208 speakers, Bel Canto Ref600m amps, DEQX PreMate Plus Roon endpoint using ethernet input. Running Roon core on MacBook Pro since my Intel NUC is currently out of commission )possible hard drive failure).

I can spend more time trying to troubleshoot the issue to see what exactly is the cause, but I figured I would reach out now to get it on your radar and see if this is a known issue and if you have any guidance.

When this problem occurs while streaming a Tidal track via Roon, I can switch to playing the same track through the Tidal desktop app on the same MacBook Pro via optical cable to my DEQX PreMate Plus and no popping occurs. So this appears to be a Roon issue. Oh and none of these tracks are MQA so that’s not the culprit.

Just because I hear the popping on a particular track one night, doesn’t mean the popping will be there on that same track the next day. Also, the pops don’t occur at the same times within a track. If I play the track repeatedly, the pops will occur at random.

One possible cause (though it could be a coincidence) is Volume Leveling in Roon. I played a Yo Yo Ma track with Volume Leveling on and set at its default value of -23LUFS and no popping occurred. Then I changed the Volume Leveling to -15LUFS, and the popping started to occur. With some other music, I’ve experienced the pops without volume leveling turned on, but I did have a max volume limit set at 70/100.

Between playing Roon via ethernet and Tidal app via optical, I don’t think a faulty ethernet cable is to blame because I swapped it out with a new one. The ethernet cable works fine for streaming tv and movies.

Between this problem, and my two other outstanding tickets (https://community.roonlabs.com/t/this-track-is-not-currently-available-tidal-error-message/34549/27 , https://community.roonlabs.com/t/rock-database-issue/31750/38) it feels like my Roon experience these days is a real drag.

@support More of this tonight playing Angeles by Elliot Smith’s Either/Or. Popping via Room but no popping playing Tidal. Would be great to get your opinion of this matter.

Hey Brice – this is on my radar. It’s really hard to draw conclusions about different connections (optical vs Roon Ready, in this case) but we’re going to pull the DEQX off the shelf and see if we can reproduce this.

You’re confident the clicks and pops happen at random times, which vary from play to play, right? And they happen all the time, not just at track boundaries or when switching sample rates?

Yes, I am confident that the pops happen at different, random times. I tested this aspect specifically at least with one or two different tracks from different albums because I knew if the pops were at the same time, that would be a clue its part of the recording. I don’t think they tend to happen at just the track boundaries. They are all throughout the track. Switching sample rates has nothing to do with it because I’m listening to 16/44.1 tracks via Tidal pretty much all of the time. I planned on going through more extensive testing this weekend since I don’t have much time during the week. I still have my DirectStream Junior in house so I could use that as a control/variable too. I’ve also experienced this issue listening to the following tracks (just that I’ve written down):

The Pull by Now, Now
Appointments by Julien Baker
My Body is a Cage by Arcade Fire

Before we even get to diagnosing/fixing the problem, I’m just eager to see if you can reproduce this issue with the DEQX. It’s not a hit-you-over-the-head obvious loud popping. It’s subtle, but noticeable. The kind where the first couple times you hear it, you’re like what was that? Was that something? Then once you’re listening for it, you can pinpoint it each time it happens.

Hi @Brice_Lang ---- Touching base with you to see if any progress or new observations have been made during your test runs. Additionally, if you are still hearing this “popping noise” on TIDAL tracks, may I kindly ask you to please supply a screenshot of your signal path leaving Roon when the issue is occurring?

Many thanks!

Haven’t had a chance to do more tests since I last chimed in. I’ll get some screenshots the next chance I get.

1 Like

i have found the same pops over the last few days, In both roon & my ios device But I don’t think its roon problem as it happens on my ios device aswell using tidal app. I have mailed tidai but no reply as yet.

I was without Roon for a couple months due to a crashed database and had to replace my Intel NUC, SSD hard drive, and ram. When i got things up and running again a couple weeks ago, all was well and I did not experience this popping issue until now. I have noticed it on a few tracks streamed from Tidal today and am setting about to troubleshoot it. I’ll report back.

@eric This evening, I went back and listened to three tracks I experienced popping noises with earlier in the day. On one of them, the pop seemed to be at the same moment three times in a row so i chalk that up to the recording. The other two played cleanly. So… on this day I wasn’t able to replicate the problem.

@eric I am listening to music now and ran into this problem again. It is unmistakably noticeable. The popping sounds happen at random intervals of about 3-10 seconds. The problem track is Heavy Eyes by Julia Kent. I tried to change a number of variables to see if the popping would go away. I tried restarting all my remotes. I tried updating to Roon build 310 for my remotes and ROCK. Tried power cycling my Intel NUC. I tried turning off volume leveling. Nothing made the popping noises stop. I wonder if you can try streaming this track and hear any popping. I’ll make a note to try streaming this track again in a few hours to see if there is any change (like last time).

Just played, no popping for me

The popping persists when I stream this track from Tidal from my Intel NUC Roon Core using the ethernet bridge on my DEQX PreMate. Here is the laundry list of other ways I can listen to this track without popping sounds:

-Tidal desktop app to my earphones
-Tidal desktop app to my DAC via USB cable
-Roon to my DAC via USB using “Macbook System Output”

I tried to play Roon to my DAC via USB using “Built-In Output” but that sound will only come through my laptop speakers even though my laptop is set to output to the Xmos USB.

Based on these tests it seems that Roon and ethernet input are causing the problem. I know from DEQX customer support that the USB input and the ethernet input share the same board so I don’t see why one would work and not the other. I’m about to reach the end of my rope in terms of troubleshooting this. Not sure where else to turn. I’d greatly appreciate some guidance from Roon @eric. I’ve had this problem off and on since early January with many different setups, cables, and components in the chain.

Mark, have you continued to experience this problem at all? Your account is at odds with mine because I have not experience the popping noises using the Tidal desktop app or mobile app. Only via Roon.

Hay Brice
No more issues with tidal desktop app only lasted a few days, As for the mobile app again not tidal fault turns it is a apple ios fault a lighting port bug which affects a lot of iPhones there was a update last night and they seemed to have fixed it but still some more listening to check. Happy to say I’ve had no issues at all with roon fingers crossed.

Hi @Brice_Lang ---- Thank you for the update and flagging me down here, I am sorry to hear of the frustrations. A few things moving forward, Brice.

  1. During your troubleshooting have you tested with the any additional processing temporarily disabled in Roon (i.e DSP engine)? I see from your previous screenshot that the DSP engine (and volume leveling) are both active.

  2. You had mentioned that the Roon - > USB - > DAC was unsuccessful. During this test run did the DAC not present itself as an available zone in the application when mounted USB? I am surprised to hear that the “built in output” was used for this test exercise.

  3. Can you share a screenshot of the playback settings being used in Roon when the popping noise occurs?

  4. I just ran the requested test via a PS Audio PerfectWave DAC and had no issues with “Heavy Eyes”.


@eric I have tried turning off volume leveling and that didn’t fix the popping. Other than that, the only DSP is the signal going through the DEQX Processor in bypass mode, meaning that it’s not doing anything to the signal like room correction or EQ. I don’t think there is any way for me to avoid that. Plus, the whole point of having a DEQX is to use its DSP which I’ll be doing in the future. That said it’s a little worrying because on one track, “Heavy Eyes” by Julia Kent, I heard the popping using the ethernet input (see first image of Signal Path), but the popping wasn’t there when i played the same song using the USB input (second image of Signal Path). Previously, I was mistaken about how to get the music from Roon on my Macbook to the DEQX via USB cable. I went into Roon’s Audio Settings and enabled xCORE USB Audio 2.0 (the DEQX’s USB input) as an audio zone. That got me up and running playing music over USB for this test.

@eric I also tried playing that same Julia Kent song to the Ethernet input (screenshot below) and USB input (forgot to take screenshot) on my PS Audio Directstream Junior and there were no popping sounds. So that points me once again to the DEQX’s Ethernet input (perhaps due to the DEQX Processor in the signal path, I can’t be sure).

Hi @Brice_Lang ---- Thank you for touching base with me! The follow up and feedback are both appreciated!

Continuing forward, I would agree that this behavior does appear to be isolated to the PreMate’s ethernet input. My assumption is that when you performed the test with the DSJ, that the same ethernet cable that had been used with the DEQX was used again. Is this correct?


Correct. I used the same cable.