Random stopping


Core machine is a dedicated NUC Server - 1.9-4.2Gh i7 quad core NUC running Audiolinux with ROON 1.6 Build 416

Server is connected to my router by Ethernet. Router is Netgear R9000. Modem is Netgear CM1000. Service is 500 mbps - often see speeds higher.

NUC Server feeds a NUC Endpoint - 1.9-4.2 i7 quad core NUC running Audiolinux with ROON 1.6 Build 416. This is connected to the router via 5G WiFi. Router is approximately 10 feet away. The Endpoint is connected via USB to a Devialet 1000. I also updated the Devialet to the latest firmware but this hasn’t solved the problem. Music is ether from TIdal (mostly) or NAS connected to the router via Ethernet.

ISSUE - I have been experiencing random ROON stops - usually in the middle of a song but sometimes at the beginning (doesn’t seem related to sample rate). This occurs anywhere from 20 min after starting music up to 24+ hours. I am not always in the same room when it stops. When I look at the remote it is as if someone pushed the pause button. If I hit ‘play’ it starts the music again.
This is 95% of the times - several times when the music stops, ROON loses the connection to the zone (Endpoint) and I have to restart the Endpoint for it to show up as an option. Once or twice I have seen ‘Tidal is loading slowly…”

I have tried everything I know to locate the problem with no luck:

  • had the internet service guy check everything. He said everything was fine - speed was 550 m
  • changed Endpoint from WiFi to Ethernet
  • removed the Endpoint and went straight from Server to Devialet via WIFi with ROONAIR and separately Devialet ROON READY
  • removed the NAS and only played from Tidal
  • removed Tidal and only played from the NAS

The last thing I tried was to remove both Server and Endpoint and use a laptop (connected by Ethernet) as ROON CORE and send music straight to Devialet via WiFi 2.4 using only the NAS. This is as simple as I can make the system. Over night it stopped again - after starting 20 hours earlier.

I have looked at the logs on the laptop but I can’t decipher anything - I am hoping ROON Support can spot something in the logs when it stops that will point to something.





not sure if I needed to add the above or not…

Hi @DJD,

Thanks for reaching out to us, I have a few thoughts on this issue:

  1. Can you note the exact local time + date in your country when this behavior next occurs and then manually send me the logs from your Core by using these instructions?

  2. Does this issue only occur on your Devialet zone or does it occur when outputting to other zones as well? For example “System Output” would give us a great data point to have.

  3. Netgear routers sometimes need special settings applied, as mentioned on our Networking Best Practices Guide. Can you please verify if disabling the “Enable Smart Connect” setting has any impact? Also, is the router up-to-date on firmware?

  4. Let’s try to take the NAS out of the equation and have a few media files stored on the Core itself. If you play a long playlist or queue up tracks, do you experience the same issue when the media is on the Core itself?

Thanks Noris for responding.

  1. Logs - can you folks not access these on line? The reason I ask is that my main core is on a NUC that I am hard pressed to access. I can ask the person that built the NUC to do this if I have to. I could send logs from my MacBook, but, I would like to solve this with the NUCs.

  2. I don’t use any other zones. I can try system output although I have never used this.

  3. I don’t have “enable smart connect” enabled.

  4. Same issue here as on #1. I can inquire if it is possible to do this with the guy that built the NUC which is where the core is - it is not something that I can do.


Hi @DJD,

Yes, I can enable diagnostics mode from our end. Can I please ask you to note the exact local time + date in your country when this behavior next occurs and then also share a screenshot of your Roon Settings -> About tab when connected from a Roon Remote? The about tab should list the Software Serial/Hardware Serial information.

Please do let me know what the results is for this test when possible as well.

Thanks Noris,

It stopped again last night mid-song at 5:03 pm EST in the USA.

After restarting and listening to music for a hour or so it paused for a second a couple times but then keep playing. One of the times the “Tidal is loading slowly” note came up mid-song. I quickly did a speed test on the iPad and the download was at 800mps. Not sure if that is helpful or not.


Hi @DJD,

Thanks for sharing that timestamp and additional setup information. I have tried to enable diagnostics mode for your account several times but it appears that the command is not going through for some reason. What diagnostics mode should do is automatically upload a set of logs to our servers for analysis, but since this feature is not working, we will have to resort to manual logs.

In case it will take time to reach out to the person who built the NUC, getting answers to the following questions would be useful in the interim:

  1. Does System Output display the same behavior?

  2. Is the NUC Core/NUC Endpoint using a Reserved IP Address? I wonder if perhaps the IP of the Core/Endpoint is changing and the DHCP lease is expiring when you notice this issue?

Thanks Noris,

I don’t have Dropbox - how do I get them to you?



Hello Noris,

I have the logs ready to go. Just let me know how to send them.

Unfortunately, the NUCs don’t have the ability to play to System Output.

The Server is a static IP address and the Endpoint has a reserved address. I don’t think that could be the whole problem since the stops have been random and sometimes as close as an hour. However, maybe some of the drops could be caused by this. Does it make sense to put the Endpoint on a static address too?

Thanks again for your assistance.


Hi @DJD,

You can use Send.firefox.com to get the logs over to me if you don’t have Dropbox / Google Drive. If the NUCs have Reserved/Static IP then I no longer suspect that this is due to the IP changing, but rather could be either due to the network connection or the Core itself. Since you don’t have System Output, would you be able to use HDMI output as a temporary test?

@noris - I think the files were sent - let me know. I do use google docs so I was just looking and I can probably send them that way if the Firefox approach didn’t work - guess I just need an email address for the google doc approach.

The NUC does have an HDMI connection - but, showing my ignorance here, where is the music going?


Hi @DJD,

I did not receive any files. If you have a Google account, you can upload them to Google Drive by using these instructions: https://support.google.com/drive/answer/7166529

You will want to upload the file to a folder on your google drive (drive.google.com) and then turn on Link Sharing and “Get Shareable Link” and let me know that link address.

If you are not able to use Google Drive for the files, then Send.firefox.com would be a bit simpler and would work as well.

The audio would be going to the NUC’s HDMI port. You may not have anything connected to it and that’s ok. This would just be an additional data point if this behavior affects just the Devialet zone or if it affects all zones.

The way I see this work is you select a long playlist or shuffle tracks from the NAS and output to the HDMI port. If this test still fails after a while, then we have ruled out the Devialet as being the source of the issue and focus further on the network, but if it does not fail, we know to take a closer look at the Deivalet and treat this as an endpoint issue.

Hi @DJD,

Thanks for sending those logs over. I have reviewed them and it suggests that the endpoint is losing connection to the Core when you experience this behavior. I have a different follow-up test based on the logs:

Can you please perform a Backup of your current database and then try temporarily hosting the Roon Core on another PC (such as a Windows/Mac computer)? The Devialet would still be connected via USB to the 2nd NUC in this test, and the only thing that you would be changing here is the location of the Core.

If you configure your setup in this kind of configuration, can you let me know if streaming is stable?

I think I may have done that (I’ve tried so many things) but, I definitely can do that - it may take me a couple of days, and then I’ll report back.

Thanks again for your help.


1 Like

@noris - Did you see anything that made you suspect the network? I was going to try a new cable to bypass a splitter to the Modem. I was also going to try a different Modem/Router. I also realized a can play to my iPad and bypass the Endpoint and Devialet if would still be helpful.

I’ll do the test you suggested as soon as I try a new cable (it’s in place now) to the modem that bypasses a splitter.


@noris - Thought I would pass on a couple other times it stopped (all times EST USA) when I tried different scenarios - some with core on NUC and some with Core on Mac. I will try the test you requested in the next day or so.

7-26 1am Both NUCs connected by ethernet to router NUC Endpoint to Devialet by USB
7-26 5:18pm Both NUCs connected by ethernet to router NUC Endpoint to Devialet by USB
7-27 10pm Core on Mac (no NUCs) by ethernet to router ROONAIR to Devialet by WiFi
7-28 4pm Core on Mac (no NUCs) by ethernet to router ROONAIR to Devialet by WiFi
7-30 1pm Core on Mac (no NUCs) by ethernet to router ROONREADY to Devialet by WiFi
8-4 5am Core on Mac (no NUCs) by ethernet to router ROONAIR to Devialet by WiFi
(this test was no TIDAL - just played from NAS)

Hi @DJD,

Yes, there were some network traces present in your logs, so it is not clear yet if it is the Core at fault of if the network. If you can try replacing the router as a temporary test that would give us a great data point.

Please do let me know the results of this test, as I see the other aspects have been addressed and it is useful information to have. Thanks!


I’ve run several tests.

First, I ran a coax cable to an existing splitter outside the house - temporarily bypassing an additional splitter in the house. I then ran a test with ROON on the NUC Server (Ethernet to Router) playing to the NUC Endpoint (5g WiFi to Router) and Endpoint connected to Devialet by USB. This stopped Friday Aug 9th at 11:30 am -ish. I had played for 43 hours - which is the longest it has gone without stopping in a while.

I then switched to ROON core on the Mac (Ethernet to Router) playing to the NUC Endpoint (5g WiFi to Router)and Endpoint connected to Devialet with USB - thus taking the NUC Server out of the mix. This played for about 42 hours until it stopped at 6:02 am Sunday the 11th. The curious thing here was I came down first thing in the morning and it was playing away. I queued up a new album and hit ‘play now’. It started the first track then stopped 16 seconds later.

I then tested the ROON core on the Mac playing to ‘system output”. This played for about 28 hours until it stopped today around 1:00 pm. It skipped 4 tracks then stopped at the beginning of Taj Mahal & Keb Mo’s song ‘Om Sweet Om’.

Does this latest round of testing point the finger at the network (service, router, or modem)?

I am attaching a picture of the Core info on the Mac in hopes that you can remotely review the last two tests.


One follow up - I have gone back to the NUCs for now - Do I need to have the Mac Core active for you to remotely connect? If so, I may try and have the logs parked on google drive again.