Rapid clicking sound on Tidal playback coming through MacBook speakers [Answered]

I’ve just set up Roon trial version and connected to Tidal (Masters). When playing Tidal albums on MacBook, I’m getting a rapid clicking and sonic distortion sounds. On ripped cd’s, no problems. Problem seems to be the MacBook and/or Tidal as I have the MacBook disconnected from my external audio system and DAC. Essentially renders Roon useless for Tidal. Recommendations? Thanks.

Hi @David_Monti_Sr ----- Thank you for the PM! The feedback is appreciated!

Moving forward, we typically try handling any support related questions on the “support” thread of the community site so other users have access to any information or advice being shared should it prove useful to them as well. Would you mind if I made this PM a public topic and we can go from there? Let me know.

Furthermore, if I am understanding your report correctly. As it stands now there are no external audio devices mounted to the mentioned MacBook, correct? When you make this observation what are you using, “system output” or “build-in output”?


Sorry. My bad. I don’t know what “we typically” do for customer support as I am new to Roon and I am in the “trial” period. In any case, moving forward, I did put the question on the thread but no reply had been received. When the clicking occurs, the MacBook is not connected to anything external. Roon setting is showing “System Output” and the MacBook is on “Built-In Output”. Also, I’ve discovered that this rapid clicking does not occur on all Tidal Masters albums that I am using. I first discovered the noise on the John Coltrane album “A Love Supreme” in Masters. I then added the same album, but not a Master’s copy. No noise whatsoever.

Thanks for getting back to me @David_Monti_Sr, appreciated!

Can you please try playing the mentioned album (i.e "A Love Supreme” in Masters) via “built-in Output” with “exclusive mode” engaged and let me know if you are still experiencing the reported clicking?


1 Like

I’ve set the MacBook to “built-in output”. However, when I enter Roon - setting - audio - system output, the options are: “device setup”, "DSP engine” and “disable”. Am I in the wrong place?

Hi @David_Monti_Sr ---- You’ll want to do the following:

  • “Settings” - > “audio”

  • Click the “gear” icon next to the “built-in output” zone.

  • Select “device setup”.

  • When the “device setup” window pops up, go to the “playback” tab, and turn on “exclusive mode”.


I did the setup as instructed on the Coltrane Masters album and the rapid “clicking” is gone. I also checked my other Masters albums and they all seem fine except for one album. This Mozart/Beethoven sonatas album also had the same clicking as the Coltrane album and that distortion is now gone. But this one album also had a second playback issue. In addition to the clicking, the playback also sounds as if the artists are underwater, a vibrating “gurgling” distorted sound - no really, I’m serious. I have also played this album in the non-Master version and it’s fine. This is the only album I’ve found so far in Tidal’s Master recordings that had unique two distortions. The clicking is now gone. So, 1) how do I remove this “gurgling” distortion from this album, 2) why are different Master’s albums displaying differing distortions, and 3) why are my other Master’s albums playing normally? Thanks.

Is it a UMG/DG release? Search on here and web for watermarking. If it is then nothing to do with Roon.

The album on Tidal is a Warner Classics release; title is “Mozart & Beethoven Violin Sonatas”; artist - Ji Young Lim; release date July 7, 2017. There are two versions of the album: Master w/watermark and non-Masters.


If I play the album directly on Tidal (w/o Roon) or on Audirvana, playback is normal. If you find the Roon playback also normal, wouldn’t that suggest a problematic setting on my MacBook related to its interaction w/Roon?

I’m at work. I can try later or maybe someone else will.

Hi @David_Monti_Sr ---- Thank you for touching base with me very appreciated! I am glad to hear that the suggested adjustment has helped.

Moving forward, in regard to this “gurgling distortion” you are hearing when listening to the mentioned TIDAL content (“Mozart & Beethoven Violin Sonatas”; artist - Ji Young ). I just gave this album a spin on my MacBook Air via both the “system output” and the “built-in output” , and have not noticed any issues.

Would it be possible for you to provide me with the following screenshots so I can be sure I am matching all of your settings:

  • The signal path leaving Roon when you notice the issue.

  • The playback settings being used with zone. This information is found in “device setup”.


Playback setting and signal path screenshots.

  • David

Hi @David_Monti_Sr — Thank you for touching base.

Please also be sure to provide screenshots of the “general” and “playback” tabs.


Hi David,

Just jumping in here. You are showing screenshots of Built-In Audio Settings, but the Signal Path shot is still showing System Output.

Can you click the Zone Picker and the bottom right of the screen, next to the volume icon and select Built-In? Then post the screenshot of that Signal Path.

Cheers, Greg

Is this what you’re referring to? Thx.


Not really, but it definitely helps.

I believe the speaker icon above System Output is your Built-In Output. You should give it a name, like MacBook or Built-In, or something. You can type it in the Unnamed box right in that screen. Is that an Apple TV at the top? You can also give it a name.

Once they’re named, click on the Built-In to select it and start playing music. See if you still get the clicks or distortion.

You can also post a screenshot of the Built-In, just like the one you did above:

Cheers, Greg

That did it. Thanks for the help. Much appreciated.


1 Like