Rare When I Can Add a TIDAL Album

Core Machine (Operating system/System info/Roon build number)

ROCK version 1, build 227; Roon version 1.7, build 667 on Roon-spec Intel NUC

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon Core connected directly via Ethernet to new TP-Link AX3000 router; Comcast 250 megabit per second service to our home

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

All RPI4’s with HiFiBerry HAT’s and HiFiBerryOS

Description Of Issue

It seems it’s more likely nowadays that I WON’T be able to add an album from TIDAL to my Roon library. I am constantly getting the “Taking longer than normal, Roon will try to add this album in the background”. Except that never happens, and note that clicking the “heart” icon from within the desktop TIDAL app also fails to make the album appear in my Roon album collection.

My network is working great, Roon works fine otherwise, including being able to stream TIDAL albums, and this feature has of course worked in the past. But this has been going on for days now and seems more than just a glitch in your interface with TIDAL?

Hi @Dean_Clough,

Is there any change in behavior if you try to log out and back in to TIDAL via the Roon Settings -> Services tab?

Can you please share a screenshot of your ROCK’s Web UI?

Yes, logging out and logging back in seems to have helped, although I had completely forgotten about that as a fix, and it would be great if it wasn’t necessary.

FYI I added other members to my TIDAL “family” on my TIDAL account, but I can’t imagine that impacting my original TIDAL account, used in Roon, and that has been unchanged for years. I’ve the screenshot as you requested and thanks for the help.

1 Like

Hi @Dean_Clough,

Thanks for that screenshot, that looks to be as expected.

Glad to hear that this helped, and I agree it should not be necessary. Following the log out and log back in, are you still seeing this issue?

If you are seeing the issue, can you please let me know the exact local time + date of occurrence and the album you were trying to add?

Thank you for the follow-up. I have not had an incident with the TIDAL interface since logging out and then back in from the service from within Roon. I just added an album a moment ago and it worked as it should.

But this has been my experience in the past . . .

1 Like

Hi @Dean_Clough,

I’ll go ahead and leave this thread open for you and if the issue was to re-occur, can you please provide the information previously requested and we can look into it further?

Thanks!

Hi Noris - OK, it just happened again. I attempted to add Beck’s “Morning Phase” album and I go the “taking longer than usual”. Everything else from OP is the same, including my LAN/WAN performance otherwise - I’m showing 250 megabits per second via a WiFi connection on my notebook, so I’d assume the ROCK connected via ethernet is getttng at least that.

Local date and time for when it didn’t work is 22 November 2020 at 09:47 AM Pacific Standard Time.

I have not logged out of Tidal and back in via Roon - I will await guidance if I can assist in troubleshooting.

Hi @Dean_Clough,

Sorry to hear that the issue has happened again. Can I please ask that you try to log out and back in and verify if this resolves the issue?

Then after trying to logout/back in and confirming if the issue is fixed, can you please send me a set of your ROCK logs by using these instructions?

Any questions, just let me know, thanks!

At 15:39 PST today 23 November, I attempted to add a Keith Richards live album and it failed. I then logged out and logged back in to TIDAL from Roon, and it added the album after it synced. I was also able to add another album easily, “Waterfall II” by My Morning Jacket, after the log-out/log-in with TIDAL.

Here is a public link (https://drive.google.com/file/d/1izDFpvHNiG_7PNeX4eBDkWPwIW7h1XZv/view?usp=sharing) to a zipped Log folder, named “DeanCloughRoonLog.zip”.

Hi @Dean_Clough,

I wanted to check in here with you, are you still having this issue with Roon? We have tried to access the logs you sent, but they appear to have been removed.

In the past we have seen issues with Comcast’s default DNS server, so one suggestion if you haven’t done so yet:

I would try to change the DNS servers on your router to Cloudflare DNS, Quad9 or Google DNS, as this may help with intermittent networking issues like the ones your described above.

Hello - I left the .zip there for a while, but yes, I did recently remove it.

Your suggestion makes sense, but my router is already configured in that way. I use 8.8.8.8 (Google DNS) as my primary, and 1.1.1.1 (Cloudflare DNS).

But please see my other post regarding a weird “stuck” situation. And BTW, I just had exactly the same problem (failing to add an album) this morning, Guided by Voice’s “Styles We Paid For” (LOL the irony!). I get the “Album taking longer to add than normal, Roon will try to add in the background”. This was after logging out of Tidal and back in (trying to solve the “stuck” issue).

Hello - I am seeing a constantly spinning wheel, which I know signifies syncing, etc. But it’s not going away and when I click on it, I get an irrelevant message. My system is completely to Roon spec (see last photo).

I’ve logged out of Tidal via Roon, cold-booted the Core and everything else, etc. etc. etc. Confused!

Roon Stuck Spinner

Typically that message persists when Roon can’t reach their backend services … I’d suggest a full reboot of your network gear and the Roon core.

If that does not work, I’m out of suggestions and Roon’s @support will have to looked deeper.

Hi @Dean_Clough,

I’ve merged your two threads because I believe these symptoms could be related.

Are you using the latest firmware on your router?

If the issue re-occurs after the router firmware update, can you please reproduce the issue, note the exact local time + date of the occurrence and send a new log set for review?

Thank you. But my router’s firmware is current.

1 Like

Thanks for checking @Dean_Clough, in that case: