Raspberry pi endpoint doesn't show up

@Thomas_Prossima1, another suggestion to try:

  1. Remove all partitions using Windows.
  2. Then format using SD Formatter (quick should be fine).
  3. After you create the image, verify that you can view the kernel file.

I am somewhat at a loss as to what is going on.

This is a somewhat macOS-centric instructional tutorial that I created a few weeks ago. May be helpful though. https://youtu.be/NmVWMiPBjEw

After writing the image with Etcher, does it verify the image OK?

As you are familiar with the Pi, does it load NOOBS Pi OS (if it still called that) or Raspian? You will be able to see that on the network if so and verify that the Pi is not broken (may have a bad SD card interface)?

If you plug a monitor in to the HDMI port on the Pi you should see what’s happening at least until Ropieee is up and running then HDMI disabled

Im guessing you have a dud RPi - I have a dozen or so RPi’s with ROpieee and never any issues. I used to use Dietpi moons ago but Ropieee is so much more flexible, especially with XL now supporting Airplay, DLNA and Spotify streaming.

Moving this to #audio-products:ropieee area

Nathan: The procedure you outlined is what I’ve been doing - without any success. However, the boot partition that contains the kernel is not viewable in Windows.

Anthony: Yes, the verify is always successful. I have 2 RPI 3B’s that I have tried. Both work fine when I install my picoreplayer SD card in them. I also have a SD card with raspian installed on it, and that too runs fine. So, I know the RPi’s are good.

Wizardofoz: The ports on the RPi never powerup, as the led error states it can’t find “kernel.img”.

I really think there’s something wrong with the boot partition. I can’t think of another thing to try. I do appreciate your help though.

I’m in my 14 day trial period. But, I’m not going to pay for Roon if I get get a RPi to work.

Try anther RPi … its not hard to see whats going on with an HDMI monitor … if its not getting that far then maybe you have dud SD cards… I personally try to stick with 16GB cards. 8GB will work too.

Good to hear it. In that case then you should be able to download the Roon Bridge software and install it on that I think (using SSH), just as a test. Others here more expert on the Pi can give you the commands.

EDIT: instructions from your own thread first time round last year:

You do seem to have a fundamental SD card programming issue at the moment though. Can you program one with Raspian afresh and see if that works?

@Thomas_Prossima1, yeah, I think you are right, it isn’t visible in Windows. Sorry about that, and sorry about the frustrating experience.

Do you have an 8 or 16 card to try?

@spockfish Harry is in CET, so may have some ideas in a few hours. Your experience isn’t common at all.

HI @Thomas_Prossima1,

Weird stuff going on…

Anyways, a few observations:

  • there’s no need to remove the existing partition. As the image is a raw image it wipes everything on the SD card.
  • have you tried using a smaller card then 32 GB?

Thanks

Yes, I also have an 8GB SD card. I’ve also been using that card throughout this entire procedure. I get the same “no kernel.img” error with this card also.

I’ve watched some other how-to examples on this and on one, I noticed the roon image was a “.IMG” file, instead of the “.BIN” that I’m downloading now. Is there a way to get the roon image in the IMG format?

there is no ‘IMG’ format. It’s a binary blob.

The reason for the .bin is because of that browser called Internet Explorer :wink:

Which made me think: which browser did you use to download the image?

Firefox, but I’ll try it again in Chrome

I just went and downloaded the standard compressed file in Chrome and Internet Exploder. One by one I flashed each on a Sandisk 32GB and a Kingston 16GB card. I tried both versions on both cards and no joy. I still just get the green led flashing 7 times for the “no kernel.img found” error.

Then as a “sanity check” I flashed the 32GB card with piCorePlayer v5. I inserted it in the RPI and it booted and ran just fine.

Needless to say this is getting beyond frustrating :frowning:

Is there any other repository I can download from?

Did you expand the compressed file before flashing?

No, from what I read Etcher can image using the compressed file

Just a thought - try de-compressing first, and then use Etcher on the resulting file…

OK - 1 step forward.
I had a 3rd RPi 3B+ that was running something else. I tried it with one of RoPiee SD cards and it worked! The only difference between this one and the previous two RPi’s is that this is a newer version of the 3B+. I don’t understand this as the homepage states RoPieee will work with versions 2 & 3.

Thanks to everyone for your assistance!

The Pi bottom left is not a 3B+ – it’s an old 2014 B+ model (it’s printed near the logo). That one uses an ARMv6 chipset. Roon Bridge needs ARM7 or ARMv8 to run – Ropieee as well, most likely.

For the Raspberry Pi, that means a Pi2B or later.

2 Likes

Ah! Mystery solved then :grinning:
My mistake in assuming they were a 3B.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.