Raspberry Pi entrypoint

Core Machine (Operating system/System info/Roon build number)

Intel NUC 7th generation running ROCK

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon core connected via ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

iFi USB DAC

Description Of Issue

I read about using entrypoints to stream music form a turntable to different Roon zones in the roon labs community summary from September 23th. I have a Raspberry Pi with a HiFiBerry DAC+ADC and would like to set that up. I am by no means a computer expert and struggling to make it work. I am getting really frustrated with all the different github pages etc. Is there an easy step by step how to for that like the one for setting up the DIY ROCK on a NUC. If not, I would like to extend my gratitude to anyone who would make one.

You really need to post in tinkering as that is where the tinkerers who play with this hang out. It’s not officially supported.

1 Like

The documentation entry point for Entrypoints is its Wiki. I just added the Raspberry Pi Installation Guide to it. At a later time I will also add usage instructions for the different Entrypoint extensions.

Please let me know if the installation guide has the level of detail you need, I’ll be happy to further improve it.

1 Like

Haven’t tried the installation process yet, but it seems to be exactly what I needed. Nice work! Thank you so much.

I’ve gone through the installation process twice now and everything seems to work out as in the guide right up to the point where I add the station into Roon and get an error message. Any suggestions?
Thanks


The screenshots look as expected.

If the Audio Entrypoint is in the “Playing’” state, as in the second screenshot, and you click the Entrypoint Gateway link, is there a mountpoint listed?

If it is then you might try playback from there.

If not then you can restart the entrypoint “with logging” via the Extension Manager. With logging active you start the Broadcast again and try to setup the station in Roon. The created log file can be downloaded via the Extension Manager link. If you upload the log and share a link I will have a look.

I don’t think there is a mountpoint listed, but I’m not entirely sure (see screenshot). Anyway, it’s not possible to play from it.

Please find the log file in this link:

Thanks

The mountpoint is the gray rectangle in the screenshot, it indicates an active radio stream. It should be the case that if you click on the play symbol (left from the 0:00 / 0:00 text) that the stream is played to the local Windows audio output.

The log file you provided is the log of Roon itself, can you also provide me the zip file that is shown as a download in the screenshot, i.e. extension-logs.tar.gz?

Oh I see. Nothing happens when I click on the play symbol unfortunately.
Please find the log file on this link:
https://drive.google.com/file/d/1I_gQtf9OkLaAkjOPwbGxYOOMZvi8JHwq/view?usp=sharing

Thank you for your help

Hi @Jan_Koudijs. Great work on the wiki and architecture for this solution! Input zones are a feature from the SONOS ecosystem that I’ve missed in Roon. I don’t have an immediate application, but I have a lot of friends who may be interested.

I had a look at the log file and it seems that playback stops because there is no audio coming in. Have you connected the HiFiBerry DAC+ADC as you described in the first post, and if so are you supplying it with an input signal when you try to start playback?

Strange. Yes it is connected to a phonostage which in turn is connected to a turntable

Let’s try to do some pinpointing here. Can you connect to the Pi and run the following commands?

First we have to get into the container:

docker exec -it entrypoint-audio bash

Then we can list the soundcards:

arecord -L

What is the ouput?

There should be multiple entries for the HAT, one of which should be called default. For my HiFiBerry Digi+ it looks like this:

default:CARD=sndrpihifiberry
    snd_rpi_hifiberry_digi,
    Default Audio Device

Is such an entry there?

This is what it returns:


Nothing unexpected in that output.

What model of the Raspberry Pi do you use? And is there a difference if you switch to 44.1 kHz sampling in the Entrypoint settings?

It is a Raspberry Pi 4 Model B - 2GB

I’ve tried feeding the url for the RP to Roon both in the 48 and 44.1 kHz setting and I get the same error in both instances.

I’m out of suggestions for the moment. I have a HiFiBerry DAC+ ADC on order and will test it when it arrives.

Ok. Which pi and sound board is the program made for?
Would it make sense for me in the meantime to test it as an endpoint in order to see if the hifi berry is working?

I would expect your configuration to work, but as I don’t have this setup myself it is difficult to pinpoint the issue. Till now I tested on a Pi 3B+ combined with a HiFiBerry Digi+ I/O.

I earlier had a report about stopping playback with a DAC+ ADC and a Pi 2B, so that is the configuration I ordered. When I can get that working I expect a Pi 4 to work as well.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.