Raspotify on USBridge and Amanero Combo (lks 004) with Dietpi GUI 6.1- no sound

usbridge is working fine with the new dietpi gui image 6.1

ok i like to get spotifyconnect running…
i installed over ssh in dietpi-software “raspotify”

after a reboot i lost the usbridge with the Amanero lks004. here is the solution from MichaT @ computeraudiophil

This is what I was advised to do:

SSH into diet pi and check the uEnv.txt file

The command = nano /DietPi/uEnv.txt

Check the end of the second line of the text file. I had to scroll along manually to do this. You are looking for “aotg.aotg1_speed value”. The speed value needs to be set to 0 for 32 bit USB 2.0 DACs like my Mojo. If you’re using a dragonfly or other USB 1.1 DACs it should be set to 1. The last line should look like this… $d/systemd aotg.urb_fix=1 aotg.aotg1_speed=0

Exit and save the file then reboot the system. You should then be back in business!

this is working

now i need to configure raspotify and i need some help.
at ssh wit aplay -L

i get the name from my card…
Combo384 Amanero, USB Audio
Direct sample mixing device
Combo384 Amanero, USB Audio
Direct sample snooping device
Combo384 Amanero, USB Audio
Direct hardware device without any conversions
Combo384 Amanero, USB Audio
Hardware device with all software conversions

now i think my usb card is Amanero

so i changed the name in ssh with
nano /etc/default/raspotify

OPTIONS=“—device plughw:Amanero”
and no # at the beginning

------i don´t know if i need to put my spotifyname and password for the 320 option? please clarify.
ok i can see the raspotifydevice but no music.
plz help

What are you running Spotify on? Have you turned up it’s volume? You don’t need to add your name and password for 320kbs.

i don´t know exactly what you mean…allo usbridge with dietpi GUI image 6.1 . USB-port from the bridge is connected to an lks004 with combo amanero.
Spotify runs on different devices -ios and osx

thanks for helping

yes what I mean is if you are running spotify on an iphone connected to raspotify have you turned up the volume on the iphone?

sure…no sound

Have you tried the command alsamixer selected your card and ensured it is at 100% volume?

still no sound…
i can see the raspotify device in spotify but i can´t realy connect…

maybe you can confirm that i did the raspotify correct…i´m not used to ssh so i don´t know about ",.`=´…
anything from this?

card 1: Amanero [Combo384 Amanero], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

looks like you have a space between = and " It should be OPTIONS="–device plughw:Amanero"

thanks…still no sound
maybe its the bit-depth`? Amanero needs 32? in shairpoint and squeezelight i had to change it over the GUI to bring it to life…

it plays for ever…and no sound

I am at a loss as to what to suggest now. I don’t have or have access to an Amanero to try to figure it out…

great answer from dietpiforum…
copy paste mistake…"-" instead of “–”

by Facel@dietpi…
You have to
issue the command aplay -l
Note the name of your Dac in the output of aplay -l
edit the config file by the command nano /etc/default/raspotify
change the speed from 160 to 320
add a line as follows

OPTIONS=“—device plughw:dacname”
(on your screen shot it seems thate there is written “-device …” instead of “–device …”

substitute dacname with the name you noted with aplay-l command

Save your changes and exit nano.
Issue the command systemctl restart raspotify

that should do the trick

I type it as two - characters. Don’t know what you typed. If it were me I would have copy pasted my text rather than typing afresh. Does it work now? The clue is also in the config file comments!

its working… somewhere copy paste mistake…

double-- is correct…