Read FAQs, But HQPlayer Still Not Playing With Roon [Solved]

After fiddling with this for a few hours I’m giving up and asking for help getting HQPlayer to play through roon. I’m confident this is a simple setting issue.

I have a Windows 10 desktop running a registered copy of HQPlayer 4 and roon. It is connected to my router, and the router is also connected to my streamer (an SOtM sMS-1000SQ).

In the SOtM’s “Eunhasu” web interface, I can select roon as the playback device, and everything works fine. I can select “HQPlayer” in Eunhasu, and HQPlayer plays fine. But, when I select the HQPlayer zone in roon I get no sound, and the following things occur:

  • the “play” button turns to “pause” as if roon thinks the track is playing;
  • the “equalizer” (misnomer, I know) icon bubbles, indicating roon thinks the track is playing;
  • the progress bar in roon does not move (I do have the selection set to “time” in HQPlayer per roon FAQs);
  • no sound is played through any of my roon zones.

I have tried changing the output device in HQPlayer so roon and HQPlayer are not competing for control of my SOtM.

Also, after getting the above symptoms when using “localhost” for the location of the HQPlayer device in roon setup, I tried the static IP address of the SOtM, and that resulted in a “Can’t communicate with HQPlayer” error from roon, telling my “localhost” must be correct.

Edit: additional information: if I allow roon to continue “playing” using the HQPlayer zone the file never advances, indicating the file isn’t actually playing. The repeat function is not engaged.

Also added photo of the signal path when trying to use roon with HQPlayer.

Any ideas as to what I’m doing wrong? Thanks for your help!!




Does playback work from HQPlayer standalone? Without Roon. It would be good to first ensure HQPlayer works alone and then adding Roon on top is more straightforward.

P.S. Do not turn volume up higher than -3 dBFS as you will begin triggering the limiter. Volume knob turns red for a reason…

Hi Jussi. Yes, HQPlayer works flawlessly without roon. Thanks!

In my pic, the red arrow is pointing to the network control. in my pic it is selected, in your pic, it does not look like it is.

Good catch! I toggled network control on in HQPlayer, but same issue persists.

Here is one thing (of many) I don’t understand, but this might be the issue: how does roon know which device to use as the output device in the HQPlayer zone? I don’t see such a setting anywhere. Given roon seems to think the file is playing, perhaps I’ve missed this setting and that’s the issue.

If you haven’t already done so, you need to add the hqplayer zone. This is done in roon via settings > setup > add hqplayer. If hqplayer is running on the same machine as roon server just leave the address as localhost, or you can use 127.0.0.1.

If hqplayer is on another machine, put the address of the machine hqplayer is running on in the address field.

Then, from roon, you should be able to select hqplayer as a zone and when you play tracks from that zone it’ll send the audio to hqplayer and hqplayer will upsample as per your settings and send that to your dac. (Sorry lots of ands) :roll_eyes:

Hi there. Thanks for the idea. I removed my prior HQPlayer zone and created a new zone using 127.0.0.1 instead of localhost, but still no change to any of the symptoms.

To confirm, HQPlayer 4 Desktop and roon Core are on the same computer.

Thanks again!

Problem solved. The issue was my lack of understanding as to what happens when using roon and HQPlayer together. I believed roon was still the “engine,” so in my streamer’s GUI I selected roon as the streaming service. When I looked at the signal path and realized roon is playing through HQPlayer rather than the other way around, it occurred to me to set HQPlayer as the “engine” in my streamer’s GUI. Setting the “engine” to HQPlayer solved the problem.

Many thanks to those who helped me troubleshoot!

4 Likes

Roon doesn’t know where HQPlayer is playing to. Roon just sends audio to HQPlayer for playback. Output device selection and configuration is completely owned by HQPlayer.

Just make sure you don’t have same DAC enabled as output zone in Roon that is configured in HQPlayer.

Thanks Jussi, and thanks for the note about reducing max volume to -3dB. I didn’t think the volume mattered when using fixed volume in the software and controlling volume with a preamp far downstream.

Your software and customer service are top notch, and greatly appreciated.

1 Like

I had to put my specific host name in Roon for HQPlayer to work after the last update, not localhost, not 127.0.0.1, but iMac2017.fritz.box