Really slow core

About two weeks back my Roon core started acting really slow. It can take up a minute for a new page to load completely. Sometimes graph showing the progress of a song stops while the music continues. Meanwhile my remote is about same as before. What’s happening?

I think people will need to know more about your set up. Have you re booted the core?

If you’re running Windows 10 and using Intel GPU:

Flag @support

1 Like

Hi @bigj ---- Thank you for the report and my apologies for the troubles.

If you can provide me with the details of your setup as seen here and some further insight into this behavior you are reporting, I am sure we can help figure this out :wink:

Looking forward to your feedback!

Someone in another thread said he had to reinstall gfx drivers, so maybe just reinstall latest gfx drivers might help.

1 Like

I have Roon core ( 1.3 218 64bits )on a Asus nuc I 5 1.8 processor. Using HD 4000 graphics and Windows 10. My problems seems very close to the problems described by others with windows updates and hd4000 graphics. Everything on my pc is just fine. It’s just the Rooncore that’s so slow it’s ridiculous. Thank god both my iPads air works as before as remotes.

Hi @bigj ---- I wanted to check in with you to see any new observations or progress has been made here. Have you tried reinstalling the gfx drivers as suggested in the article mentioned above?


I did with no improvment. Viewing Roon through core is a test of your patience.

Hi @bigj ---- Thank you for the update.

During your troubleshooting of this behavior have you tried using the 32bit version of Roon? According to this post another user was able to remedy this behavior by using the 32 bit version instead of the 64 bit one.


Just to add a data point here…

For a very long time now, I’ve been able to run the 64bit version of Roon on my Atom-based Lenovo ThinkPad 10 without any problems. However, it’s now running a Windows Insider test build of Windows 10 (Build 16226), and has just been upgraded to Build 234 of Roon. And now, suddenly, Roon runs like a dog - album art appears very slowly, if at all, and responsiveness is like wading through treacle.

So I replaced the 64 bit version of Roon with the 32 bit version of Roon, and now I’m back to the old snappy responsiveness…

As an additional sidenote, I’ve always had to use the 32bit version of Roon on my Surface 3 (another Atom-based tablet). Unlike the ThinkPad, it never was able to deal with the 64bit version of Roon…

1 Like

Ok. Is there a guide how to revert to 32 bits without to much hassle?

Just uninstall the 64bits version (and leave the settings and database intact - you’ll see this when you start the uninstall). Then download and install the 32bits version of Roon.

Thanks, Geoff. Will try…

Well, I’ll be…
Before uninstalling the 64 bit Roon I thought I’d update the graphics drivers once more. It took a while, but after Roon was as fast as it ever was. Runs perfectely👍

The problem really hasnt been solved. Since a few months back it´s been getting worse, and now since my remotes doesnt workat all the problem becomes intorable.

It’s not clear if you ever installed 32bit roon, so disregard this if you did.

Windows keeps on doing auto updates of your drivers in the background. This used to happen to me all the time. If you don’t want to keep on re-installing old graphics drivers that work, or switch off auto update and either of those options can be quite a challenge to do right then just install 32bit roon.

Just remember that if you have a large library above about 110k tracks you will have to install roon as a 64bit core, plus roon as a 32bit remote even on the same machine. If you don’t you will see a lot database corruptions in your logs and you will have a dead roon rather than a slow roon. There is a link somewhere on this forum if you need to do that.

Very strange… After my last post I used roon the day after and it is working soooooo much better now. I didnt do anything. Now three days later it still works as it should.
I checked and I have the 64 bit version.

Under Windows 10, I used to find this hit and miss behavior you are describing. Eventually, I had to accept I couldn’t really control Windows auto update and in my case I have roon 64bit as a core but control it with a roon 32bit on the same machine. No problems at all since.