Really Stuck with Linux Issue; Trying to Run Harmony Extension for Roon

I have reached the edge of my understanding here. Try to program a Rpi B+ to run the Harmony Deep Integration extension (Khazul).

I flashed Stretch Rasbian, then added the ARM version of Docker along with the extension software and its companion ‘Run.SH’ file from Khazul. Two problems have surfaced:

  1. When trying to run ‘Run.SH’ from the terminal, I receive this error: “bash: ./ Permission denied”. I have tried some fixes found via Goggle but no success yet.

  2. The extension actually appears in Roon. But when I try to Enable it and set options, it stalls out when Saving my changes and updating the extension:

My knowledge of Linux is quite shallow, and I hope that these issues might have easy fixes known by Linux pros.

More detail as wanted. Many thanks for the assist.

Looks like you are following too much of the instructions. If you use the Docker Image then you don’t need the file (both are different distributions of the same extension). If you run both you get two instances of the extension, as you reported in the other thread.

The last step you should take from the instructions is executing the docker run command.

Does it get more stable if you have only one instance running?

Any attempt to save settings and options in Roon will fail because the extension will not complete the save process. But, I realize this app is a work in progress so it may still have some rough edges.

I have not yet tried to program the Harmony remote yet. Still more adventure. Thanks for the tip.

I take it you don’t have a Nas? It’s the easiest way to run and manage the extension with no Linux knowledge needed.

That’s said have you performed the update to install the latest version which is 2600 as this will fix this issue looks like your still on the default install one of 243. It should appear in the tools menu to update. The latest one in the docker repository is quite old. So you need to update it first before configuring it. They changed the underlying API for Roon extensions a while back and the update fixes this.

Also be aware that Logitech removed the option for 3rd Pary plugins to communicate and control Harmony Hub. After much backlash they released a beta version to get round this. Apparently they removed it for security reasons. So you need to connect the hub to a pc or mac and run the harmony desktop app and put it into admin mode by clicking on CTRL F9 on windows (dont know mac way you will have to look it up) and logging into your hub. You can then install the developer beta software its right at the bottom of the list.

Thank you so much. I saw the “security” update but didn’t connect the dots.

My extension version now reads “Deep Harmony 2.1.5 + 260” so somewhere along the way it got updated. Again, thanks for the info.

Your welcome.

@CrystalGipsy @jan_koudijs @Adam_Goodfellow

Not out of the Harmony woods yet. The “old” extension (v2.1) pulled from dockerhub would not update in Roon, so I removed that extension version from the RPi and started anew.

The latest extension version, 2.15, was on Github, and I manually downloaded the ARM7 version zip file into RPi’s Downloads folder, and unzipped it there.

It cames with a Run.SH script, which seems important because it was part of the zip file. And I followed the instructions to enter “./” command line, and received a “denied permission” error. So I have the extension and script loaded (in the Downloads folder) but not yet running on the RPi.

So to anyone who has successfully navigated these waters, please help me over this last set of rapids.

Apologies if this is a bit obvious but I take it you’ve checked that is executable and that you have the rights to run it? Are you root when you are installing this?

eclectic, for all I know, this may be the problem. “Am I root?” I don’t understand.

As for, the extension instructions say, “Open a command prompt and change directory to where you unpacked the files. At the command prompt, type ./ The supplied script is a very simple script to keep the extension executable running. Note that while you can directly run the executable, the script is required as part of the self-update service.”

This is all I have to go on.

Go to the directory where is and type sudo chmod +x and try to run it again.

Root is the superuser (admin) account on unix/linux based systems. The command sudo temporarily elevates you to that level.

Now I’m getting a series of permission denied’s; terminated with exit code 126; restarting…over and over again

Had to reboot to cancel .

I’d try running it as root. sudo ./

Hi John_V,

did you solve it?

I have the same issue, can somebody help us?

Thanks in advance.


Honestly I don’t remember how I got that fixed. Sorry.


Thanks Jonh_V.

honestly it seemed apparently easy to install it, but after checking other posts, it seems complex.

@Roon’s expert users
is there either any workaround or Harmony extension for dummies?

Thanks in advance for your support.