Rebuilding Roon Library

Intel NUC 7i7BNH, 16GB, SSD, W10, Roon 1.8 (Build 764)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired Ethernet / TP Link 108

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

dCS Debussy WASAPI Local Connection or
Euphony Roon Bridge to a dCS Debussy or
Allo DigiOne/RoPieeXL to a MERIDIAN 566 DAC.

Description Of Issue

My Library consists of ~110.000 Tracks (7.000 Albums). It is located in a Synology DS108j storage, and includes both my long time iTunes db (~5.700 albums maintained constantly) and a folder with my DSD music.

After Upgrading to Roon 1.8, I realized I was missing Albums in my library, which I could see either in “AUDIRVANA” or “Euphony Stulus”.

Tried to clean my Library.

Finally I decided to Uninstall Roon S/W, removing all database and settings.

The new Installation is searching my Music folder up to ~3.648 – 3.651 albums and then crashes.

I tried a clean installation of Roon on a different i9-9900K/ 16GB /SSD W10 machine with exactly the same behaviour.

Is there something I am missing or have you any Idea on this matter?

Attached a capture just before the crash.

Best Regards,

Christos Patelis

Hi @Christos_Patelis

Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link? Thanks!

Thank You for the response!
Log Files in the link.

I’m back again!
Parsing through the log files, I saw that there was a problem in a STEVEN WILSON folder.
Deleted the png file.
Retried but stopped again.
Removed from iTunes lib album and files.
Importing to Roon passed that point and coninued up to appr. 61.000 tracks.
I attached the second Roon Log files set. at the same shared folder.

Stops when tring to import AIFF files …

Coming back to our previous communication.

I have no indication whether you had the oportunity to parse the Log files.

This is the 4th day I have no service from my Roon Server…

Best Regards,

Christos Patelis

Apologies for the delay here, @Christos_Patelis — I’ve been out of the office for a few days but I’ve had a chance to review the logs you shared with us.

\\SynDS218j\music\1_ChrisP_iTunes_Library\iTunes Media\Music\LSO dir. Valery Gergiev\Gustav Mahler _ Symphony No 9  (48_24)

Can you try moving this Gustav Mahler folder out of Roon’s watched folders and let us know if there is any change after?

As I Described earlier in the discussion, whenever I removed albums or files in AIFF format, the Roon process run smoothly.

I Unloaded all content in AIFF format from my iTunes Lib.

Deleted files (794 tracks),

Convert all tracks to Apple Lossless,

Imported tracks - albums back to the iTunes library.

Roon imported all content of my Music folder, be it in PCM the iTunes lib or DSD in the flat DSD folder, successfully.

Now I am still in the process to Analyze Roon db content ( ~50.000 from 100.000 tracks processed).

I do not know if this is an “workaround” or Roon is not able to process AIFF files any more …

Hi @Christos_Patelis

I’d like to have our team take a look at some of these files. Can you please zip up one of the albums causing troubles and upload them here? Thanks!