Receiver not consistently recognized as multichannel-capable over HDMI

Core Machine (Operating system/System info/Roon build number)

macOS 10.15.2 / MacMini (late 2014, i7) / Roon 1.7 (build 511)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Pioneer Elite receiver connected to core via HDMI

Description Of Issue

Receiver is not CONSISTENTLY recognized as multichannel in Roon, though Audio MIDI on the Mini is set to 8-channel and is consistently recognized. Very frustrating - I wish we could just “lock” the output once set correctly via device setup and not have it flip back and forth between stereo and multichannel :frowning:

Hi @jhwalker,

Can you please share a screenshot of the Device Setup tab for this zone and one for the “Advanced” area of Device Setup for the zone as well? Have you tried using a different HDMI cable?

Sure - but it’s working today, so it will look ‘normal’ :stuck_out_tongue:

Audio Midi on the Roon server (Mac Mini):

Device Setup in Roon:

Advanced Setup in Roon:

Hi @jhwalker,

Thanks for sending those screenshots. Can you confirm if you’re using the full 8 channels for HDMI output? It looks like you have 5.1 (6ch) set in the device setup tab. Is there any change if you set it to 7.1 output in Roon?

Well, I went to try this and the Roon setting has reverted back to stereo (e.g., 2.0), even though the Mac Mini clearly sees all 8 channels in Audio MIDI; i.e., exactly the problem I described:

Audio Midi:


You can see the Channel Layout is not even editable (it’s greyed out).

Hi @jhwalker,

Thanks for the screenshot. I plan to discuss your case with our technical team later this week, once I have more information to share I will be sure to reach out once more.

Hi @jhwalker,

I brought up your report with the technical team and we’re going to attempt to reproduce this behavior in the lab.

To assist with reproduction, are there any set of steps that you can use to consistently get into this state? Example: Entering and exiting standby mode, restarting Roon, changing the channel count in Device Setup?

I had a similar problem. In my case, it seemed to be a problem with the avr switching between sources that had multi-channel or not. It kept reporting different capabilities, resolutions, etc. which is apparently part of the hdmi spec. It also seemed to involve the avr “zone 2” feature. I finally got tired of fooling around with it and ran an optical input from the pc to the avr. No more problems, but it only works for two channel.

The only other thing that ever worked for me was to shut everything off and start it all back up in some sequence I don’t remember, and maybe waving a rubber chicken over the rig, don’t recall exactly.

Tldr; it’s probably your avr.

No pattern that I can discern - sometimes it works, sometimes it doesn’t. Doesn’t seem to have any rhyme / reason. I guess switching from one zone (e.g., local headphones vs. AVR) is a common theme.

1 Like

Probably :confused: Just wish there were an option to tell Roon “THIS is the right configuration, stop trying to re-detect it every time!”, as I noted in my first post.

I tried that too, with hdmi profiles in the os, etc. Didn’t work. At the time I was using different player software. I asked them if they could allow some sort of profile as you are suggesting. They said it wouldn’t work because if they did that and sent the specified profile to the hdmi adapter that wasn’t expecting it that it would just come out as noise.

Thanks for this info, I’ll note it with the hardware team.

You can feel free to open a feature request regarding this capability.

Hi @jhwalker,

I spoke to the hardware team and we would like to analyze your Roon logs when this issue next occurs. Can I please request that you note the exact local time + date when Roon is next in this state (of being able to see 8ch in Midi but Roon not allowing it) and let me know here?

After noting the timestamp, please use these instructions to send your Roon logs to me (via Dropbox / Google Drive). If you don’t have Dropbox / Google Drive I can provide an alternate upload method.

After sending the logs there is one thing we can try as well - on the Roon Settings -> Audio tab, there is a “refresh” button next to “This PC” or “Connected to Core”. Is there any change in behavior if you press the “refresh” button (spinning arrow)?

I’m out of town this week, but will give it a try this weekend. Thanks!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.