Receiving "error loading folder unexpected error" when I try to add my music folder

Roon Core Machine

My server is running on Ubuntu Server 20.04

Number of Tracks in Library

180,000 tracks

Description of Issue

I just installed Roon Server and connected to it using the Roon application on Windows, but when I went to add my music folder I was greeted with the error “error loading folder unexpected error,” and I’m at a loss as of how to fix it.

If I add the folder with this error message, the scan picks nothing up. My other audio folders (such as aduiobooks and podcasts) are scanned just fine.

There’s nothing obvious there so do the usual (if you haven’t already). restart the core (& core machine) and try again, often the simplest things work.

Let us know what happens :crossed_fingers:t4:

Unfortunately I’m still getting the same error

Can you add and access a different folder ?

Is your music folder on an internal drive or external (usb / networked) ?

any restricted characters in the folder path?

is the folder hidden, shared?

is there a firewall rule causing problems?

The folder is on an external hard drive, it previously worked in Plex on the same PC. I can access every other folder on the hard drive. Do you have a list of restricted characters? I was wondering if maybe that was the cause. I have a lot of Russian, Japanese, Korean, etc. music and the folders are labelled in those languages.

I was just wondering on the Windows device, did you install Roon to run as remote which connects to the Roon Core on the linux device?

You could try creating another folder on the drive and adding it to the watched list to prove there’s no sharing/permissions problems and you’ll then know if the problem is your music folder or elsewhere.

Eidit: is your music folder encrypted? this could cause problems.

If the file names include special characters this could cause a problem, but I’ve not seen this affect folders. Try renaming a couple of folders to see if this is the cause.

To be clear, the media is attached to the Ubuntu server? If so, try using / (root) for the path through to /media where the disk is attached.

1 Like

Yes, the Windows PC is just being used as a remote to the Linux PC.

I tested it out, and the folder with my music in it is the only folder on the drive that can’t be read.

The folder is not encrypted.

The music folder is attached to my Ubuntu server, yes. It’s all on an external hard drive which is connected by USB. I tried adding the path that way and had the same result as before.

I think the special characters (double-byte) may be the problem since these often cause incompatibility, especially when used between operating systems.

Try renaming the root folder(s) on the drive. Does this help?

Also, screenshots/ examples would be useful.

2 Likes

It certainly looks like as issue with special (or restricted) characters as Martin has pointed out.
And as also mentioned, screenshots would now be helpful especially the names in some of the sub folders.

You could also try creating a new folder and migrate some (or all) of your folders & files to it.
I did have a problem recently where a music folder was corrupted (probably a record in the MFT) and I wasn’t able to access it or delete it, eventually a disc reformat was the only solution, so, make sure your music files are backed up.

Hey @Brendan_Stupik,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Checking in on this thread, are you still running into issues getting access to your folder? What is the model of the external drive you’re using, and how is it formatted?

As @PixelPopper mentioned, if you take a small selection of the music on this folder and add it to a newly created folder, do you run into the same issue?

I’ll be on standby for your reply :pray: