Recurrence of long term problem with metadata after build 610 release

Core Machine (Operating system/System info/Roon build number)

NUC 8i5

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Sky Q Router; Cisco 2960 switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

N/A but using Sonore microRendu/Mytek Brooklyn+ and Linn Klimax DS/1 connected by ethernet cat6a. My Ron control points run on Windows 10 PC or IOS (iPad Air).

Description Of Issue

Following the release of software version 1.7 , I had a metadata problem which remained from the installation of version 1.7 until recently. This problem was finally resolved following a software release in the week of June 19 this year, and after I reported that it had been resolved, the support thread I raised was closed by Roon Support. Roon (and metadata display within Roon Radio) has worked perfectly from around June 19 until now with no metadata problems whatsoever. Unfortunately, following the installation of the recent build 610 within the past week or so, the problem has now returned with build 610 after 9 or so weeks of working absolutely perfectly.

There are two problems that have returned with Build 610:

  1. I now once again get an “error loading page” when I attempt to load the Tidal main page. Reloading the page gets rid of the message.

  2. When I run Roon Radio, selections chosen by Roon frequently display no Album art, no album details or no Artist details. Sometimes a complete blank page, but on other occasions possibly just missing artist info.

As I said earlier, it is extremely annoying that this longstanding problem which appeared to have been resolved has recurred after the most recent build (610) of 1,7. The original bug has obviously been re-introduced - perhaps a problem with regression testing?

Can you please resolve this infuriating problem that I thought had been fully resolved until the release of build 610? Roon Radio still plays music ok, but it is almost impossible for me to identify and add albums I like to my library when no metadata is displayed.

I first raised the thread about the “missing metadata” in Nov 19, 2019, and the thread for the issue with “error loading page” on Dec 1, 2019. These have both been closed by Roon Support following my posts on June 19 to inform Roon Support that they had been resolved.

Here is an example of the problem occurring at around 18:17 (UK time) on 27 August.

The above screenshot shows the album that Roon Radio is playing (15th of August - Giovanni Guidi)

The second page shows the blank screen that appears when I try to display the metadata associated with the album.

I posted many similar screenshots in my previous (now closed) thread.

Another example of partial metadata being displayed (around 18:51 UK time):



Any idea why these problems have returned with Build 610, having had no problems since mid June?

Hello @hmack, and thanks for bringing this to our attention. If you reboot is the issue temporarily resolved? I’d also recommend trying another core temporarily so we can narrow this down to either that machine or to something network related. Please try:

  • Make a Backup of your current Roon Database
  • Install the Roon app on the other PC
  • If you have an existing installation go Roon Settings -> General -> Disconnect
  • On the Choose your Core screen, select “Use this PC”
  • Do not restore your old database yet
  • Verify if the same issue is occurring on the other PC

I found your original report internally and would be happy to reopen this issue so we can get you resolved again! Please let me know if another core produces the same issue.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.