Red X Crashing on Windows 10

same situation over here… no matter how many times I reinstall the app (64 & 32) it keeps crushing … suddenly desapearing wile working or plainly showing a big red cross over white background on start up… where can I download the previous version that works just fine for me?

@noris the machine is a Microsoft Surface 3Pro, de device name is “Surface”, crushing time 05:04PM (-3GMT)
Please, where can I download the previous version that worked fine for me?

Roon doesn’t make previous versions available once a new version comes out.

Hang in there. Support will figure it out for you, and for others.

Unfortunately, downgrading is not supported.

I’m 100% confident the support team can get this working for you @Eduardo_Cabral, so thanks in advance for your patience here.

Hey, @xxx thank you for your input.
I cannot avoid to resent 2 things from Roon though;

  1. Not coming forward with a straight unswer to my very reasonable request.
  2. Doesnt seem fair to force a user that has paid for the system to wait until somewone comes up with a solution. One one hand, I cannot use what I paid for by simply returning to the previous version till Ronn provides a new version that actually works, on the other hand, as I am a year suscriber, the clock is ticking on my money.
    Not nice, really. @mike

Is this a previously reported problem or the one you reported a few hours ago?

it is the same report, all along… it keeps crushing or shutting down the very moment I open it

Hey @Eduardo_Cabral – most people think I’m pretty nice, and once we get you fixed I’m sure you will agree :slight_smile: Our QA team does zero testing of downgrading, and I want to make sure we get you stable, not make things worse.

Also, if you’re not able to use Roon for any extended period of time, I’ll make sure we credit your subscription so you get what you paid for.

For now, can you do me a favor and follow the instructions here to upload some logs to us? That will help us look into this for you.

Also, can you let me know exactly what you tried so far? Have you uninstalled? Is this your Core machine?

Can you also give the basic details of your setup, as described here?

We are looking forward to resolving this for you @Eduardo_Cabral – I can assure you we will be able to fix this for you soon.


1 Like


First things first. The “not nice” comment was about the situation, not about you, so: sorry for the misunderstanding and thanks for the humor.

My systems is as follows:


  • Windows Microsoft Surface (WiFi)


  • Roon ROCK Intel 7i3BNH to Data Switch (Ethernet) (Core)

  • Internet router to Data Switch (Ethernet)

  • Pro-Ject Streambox S2 Ultra to Data Switch (Ethernet) (End-point)

  • Then, Pro-Ject Streambox S2 Ultra to Mytek Brooklyn, and from there it´s all analog

I have zipped the log files, as you requested, but I dont know how to attach it to the message.

Said all that, please, in the future, when you publish a new software try it to be totally reliable & solid (especially considering your policy about downgrading) to avoid making your customers part of your beta testing team. You see, being an audio professional myself, I am used to “charge”, as opposite to “pay”, for all these procedures.

Once again, thank you for your polite sense of humor and, please, get it fixed as soon as you can.

Best regards

Thanks @Eduardo_Cabral. You can upload the log files here, using alpha for both user name and password.

Another question – have you rebooted the device?

I just talked to the developer who wrote our graphics engine, and he said this tends to only happen when something is preventing our engine from drawing the interface – so this might be something like a problem with RAM, or VRAM, graphics driver, etc.

Rebooting is a good start in all these cases, so if you haven’t already, do that and then send the logs over if you’re still stuck.

Thanks again for your patience @Eduardo_Cabral!

@Mike I found the way to send it in your instructions link
Here it is

@Mike I have rebooted, reinstaled, redownloaded version, installed 32bit, restore PC to previous week, etc… done it all…

the graphics is unlikely to be the point… the application doesnt only fail by flagging the big red cross… actually I cannot even get to see the cross, as the app shuts down at the very moment it opens up… I mean, the app is failing in 2 different ways

1 Like

Ok, logs are interesting – thanks for sending. The crash seems related to some content in your library ("Wayman Tisdale - Fabulicious") but I’m confirming with our developers exactly why this is happening.

I’m confirming exactly what’s going on but for now, can you try something?

  • Close Roon on the Surface
  • Find your Roon database on the Surface
  • Navigate to Roon\Database\Registry\Client
  • In that folder, delete only files that start with GMS (meaning files like GMScf9de776-5fef-4f81-8108-025e67730646 – leave all other files alone
  • Restart Roon

If that doesn’t work, I should have some more feedback soon. Thanks!

@Mike, there are no GMS starting files in the Client directory

@Eduardo_Cabral, does “Fabulicious [29gU]” mean anything to you?

“Wayman Tisdale” related maybe…

@mike Not at all

@Mike Fabulicious is a song by Wayman Tisdale (Google says) but I dont have it in my PC

It seems like this Wayman Tisdale - Fabulicious content is probably the issue – if you know what that is, would you mind sending me these files?

I’m guessing if you remove that file your crashing will stop. And if you send it to us, we can fix the bug :pray:

Thanks again!

where you possibly playing internet radio?